aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2006-01-20 19:55:20 +0800
committermarkus <markus@FreeBSD.org>2006-01-20 19:55:20 +0800
commitc0e81ebf8101f9ca40a7b6a32c39c834824056d9 (patch)
treea65fd93467e48ab3843baca2ed28905c2302c2d2 /graphics
parent7bed7514b6100acc4d56eef6ed36348791237f3b (diff)
downloadfreebsd-ports-gnome-c0e81ebf8101f9ca40a7b6a32c39c834824056d9.tar.gz
freebsd-ports-gnome-c0e81ebf8101f9ca40a7b6a32c39c834824056d9.tar.zst
freebsd-ports-gnome-c0e81ebf8101f9ca40a7b6a32c39c834824056d9.zip
- Fix serial port detection on FreeBSD 6.0 and above
- Bump PORTREVISION
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgphoto2/Makefile2
-rw-r--r--graphics/libgphoto2/files/patch-libgphoto2_port-serial-unix.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 7c1eb3a6776f..8c8838469a4b 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgphoto2
PORTVERSION= 2.1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
diff --git a/graphics/libgphoto2/files/patch-libgphoto2_port-serial-unix.c b/graphics/libgphoto2/files/patch-libgphoto2_port-serial-unix.c
new file mode 100644
index 000000000000..024a3ff23353
--- /dev/null
+++ b/graphics/libgphoto2/files/patch-libgphoto2_port-serial-unix.c
@@ -0,0 +1,14 @@
+--- libgphoto2_port/serial/unix.c.orig Wed Jan 18 18:06:35 2006
++++ libgphoto2_port/serial/unix.c Wed Jan 18 18:08:39 2006
+@@ -108,7 +108,11 @@
+
+ /* FreeBSD */
+ #if defined(__FreeBSD__)
++#if __FreeBSD_version < 600000
+ #define GP_PORT_SERIAL_PREFIX "/dev/cuaa%x"
++#else
++#define GP_PORT_SERIAL_PREFIX "/dev/cuad%x"
++#endif
+ #define GP_PORT_SERIAL_RANGE_LOW 0
+ #define GP_PORT_SERIAL_RANGE_HIGH (0xf)
+ #endif