aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-10-22 05:41:06 +0800
committerjgh <jgh@FreeBSD.org>2012-10-22 05:41:06 +0800
commitecb7f273af0911e3e6a5f07fd4fd5ed0c15a973b (patch)
treeb40aa968454b297b7b576b5ab46c8634b053ee38 /graphics
parent0c72f9a302f41ae9e49a37ec2ce53dc78202b980 (diff)
downloadfreebsd-ports-gnome-ecb7f273af0911e3e6a5f07fd4fd5ed0c15a973b.tar.gz
freebsd-ports-gnome-ecb7f273af0911e3e6a5f07fd4fd5ed0c15a973b.tar.zst
freebsd-ports-gnome-ecb7f273af0911e3e6a5f07fd4fd5ed0c15a973b.zip
- move graphics/deegree-* suite to tomcat6
- move DOCS to optionsNG while here, and trim Makefile headers Submitted by: jgh@ Approved by: wen@ (private mail) Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/deegree-csw/Makefile14
-rw-r--r--graphics/deegree-igeoportal/Makefile14
-rw-r--r--graphics/deegree-wcs/Makefile14
-rw-r--r--graphics/deegree-wfs/Makefile14
-rw-r--r--graphics/deegree-wms/Makefile14
-rw-r--r--graphics/deegree-wps/Makefile14
-rw-r--r--graphics/deegree-wpvs/Makefile13
7 files changed, 49 insertions, 48 deletions
diff --git a/graphics/deegree-csw/Makefile b/graphics/deegree-csw/Makefile
index 6c1321e0b7e3..c57c094a371d 100644
--- a/graphics/deegree-csw/Makefile
+++ b/graphics/deegree-csw/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-csw
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= csw
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Catalogue Service(CSW)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,11 +30,13 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-csw.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_csw_2.0.2_documentation_en.pdf ${DOCSDIR}
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index 839daf9f7d7b..9c40f70752a9 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-igeoportal
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= igeoportal
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PORTNAME}-std_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Browser based client handling WMS, WFS, and proxy service
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,11 +30,13 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/igeoportal-std.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_igeoportal_documentation_en.pdf ${DOCSDIR}
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
index 17b61bd42e51..703740619eb5 100644
--- a/graphics/deegree-wcs/Makefile
+++ b/graphics/deegree-wcs/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-wcs
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= wcs
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Coverage Service(WCS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,12 +30,14 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wcs.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
cd ${WRKDIR} && \
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_wcs_documentation_en.pdf ${DOCSDIR}
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
index 2b7c6f2887cf..82b66087b9a0 100644
--- a/graphics/deegree-wfs/Makefile
+++ b/graphics/deegree-wfs/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-wfs
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= wfs
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Feature Service(WFS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,12 +30,14 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wfs.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
cd ${WRKDIR} && \
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_wfs_documentation_en.pdf ${DOCSDIR}
diff --git a/graphics/deegree-wms/Makefile b/graphics/deegree-wms/Makefile
index 11392a251d8b..5bd2ea940df3 100644
--- a/graphics/deegree-wms/Makefile
+++ b/graphics/deegree-wms/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-wms
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= wms
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Map Service(WMS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,11 +30,13 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wms.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_wms_documentation_en.pdf ${DOCSDIR}
diff --git a/graphics/deegree-wps/Makefile b/graphics/deegree-wps/Makefile
index a0293854e493..6c735f140339 100644
--- a/graphics/deegree-wps/Makefile
+++ b/graphics/deegree-wps/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-wps
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= wps
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Processing Service(WPS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
TOMCATOWN= www
TOMCATGRP= www
@@ -34,11 +32,13 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wps.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_wps_documentation_en.pdf ${DOCSDIR}
diff --git a/graphics/deegree-wpvs/Makefile b/graphics/deegree-wpvs/Makefile
index 725e36eba3e9..209b27a5bf09 100644
--- a/graphics/deegree-wpvs/Makefile
+++ b/graphics/deegree-wpvs/Makefile
@@ -1,12 +1,11 @@
-# New ports collection makefile for: deegree-wpvs
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
#
PORTNAME= wpvs
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +14,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Terrain Service(WTS)/Web Perspective View Service(WPVS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,11 +31,13 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wpvs.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_wpvs_documentation_en.pdf ${DOCSDIR}