aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-12 21:01:59 +0800
committerkrion <krion@FreeBSD.org>2004-06-12 21:01:59 +0800
commitf47b74c8d2e38403e8d53563b0dc41259a048f69 (patch)
treeb32360611211db6f9de0ecf64ea96028362868e5 /graphics
parenteef661797cb1755ac3ce0e291a2396bb2139b68d (diff)
downloadfreebsd-ports-gnome-f47b74c8d2e38403e8d53563b0dc41259a048f69.tar.gz
freebsd-ports-gnome-f47b74c8d2e38403e8d53563b0dc41259a048f69.tar.zst
freebsd-ports-gnome-f47b74c8d2e38403e8d53563b0dc41259a048f69.zip
Add bugle 0.0.20040609,
BuGLe is a tool for OpenGL debugging, implemented as a wrapper library that sits between your program and OpenGL. PR: ports/67795 Submitted by: Erik Greenwald <erik@smluc.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/bugle/Makefile24
-rw-r--r--graphics/bugle/distinfo2
-rw-r--r--graphics/bugle/pkg-descr4
-rw-r--r--graphics/bugle/pkg-plist22
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a4ce2dd142b4..202cbaa81973 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -30,6 +30,7 @@
SUBDIR += blender
SUBDIR += blender-devel
SUBDIR += bmeps
+ SUBDIR += bugle
SUBDIR += cadubi
SUBDIR += camediaplay
SUBDIR += chbg
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
new file mode 100644
index 000000000000..39e21f2958b3
--- /dev/null
+++ b/graphics/bugle/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: bugle
+# Date created: Jun 8, 2004
+# Whom: Erik Greenwald <erik@smluc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bugle
+PORTVERSION= 0.0.20040609
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bugle
+
+MAINTAINER= erik@smluc.org
+COMMENT= A debugging library for OpenGL
+
+USE_GCC= 3.3
+USE_GL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/bugle/distinfo b/graphics/bugle/distinfo
new file mode 100644
index 000000000000..cc43807e10c6
--- /dev/null
+++ b/graphics/bugle/distinfo
@@ -0,0 +1,2 @@
+MD5 (bugle-0.0.20040609.tar.gz) = 59b071b6b5b106c229aa16896ca69c58
+SIZE (bugle-0.0.20040609.tar.gz) = 311287
diff --git a/graphics/bugle/pkg-descr b/graphics/bugle/pkg-descr
new file mode 100644
index 000000000000..2cea4264d013
--- /dev/null
+++ b/graphics/bugle/pkg-descr
@@ -0,0 +1,4 @@
+BuGLe is a tool for OpenGL debugging, implemented as a wrapper
+library that sits between your program and OpenGL.
+
+WWW: http://bugle.sourceforge.net
diff --git a/graphics/bugle/pkg-plist b/graphics/bugle/pkg-plist
new file mode 100644
index 000000000000..6070eaf95232
--- /dev/null
+++ b/graphics/bugle/pkg-plist
@@ -0,0 +1,22 @@
+lib/bugle/common.a
+lib/bugle/common.la
+lib/bugle/common.so
+lib/bugle/common.so.0
+lib/bugle/debugger.a
+lib/bugle/debugger.la
+lib/bugle/debugger.so
+lib/bugle/modify.a
+lib/bugle/modify.la
+lib/bugle/modify.so
+lib/bugle/modify.so.0
+lib/bugle/tracker.a
+lib/bugle/tracker.la
+lib/bugle/tracker.so
+lib/bugle/validate.a
+lib/bugle/validate.la
+lib/bugle/validate.so
+lib/libbugle.a
+lib/libbugle.la
+lib/libbugle.so
+lib/libbugle.so.0
+@dirrm lib/bugle