aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-11-18 01:44:51 +0800
committeracm <acm@FreeBSD.org>2006-11-18 01:44:51 +0800
commitff406047024960f614d0f7262eb0dcced03c258a (patch)
tree3222f89607bc1c623b934a612d5255943ca94db2 /graphics
parent699b63b15ffc2b45383442243296d5eb0e25ac62 (diff)
downloadfreebsd-ports-gnome-ff406047024960f614d0f7262eb0dcced03c258a.tar.gz
freebsd-ports-gnome-ff406047024960f614d0f7262eb0dcced03c258a.tar.zst
freebsd-ports-gnome-ff406047024960f614d0f7262eb0dcced03c258a.zip
New ports: graphics/php4-ffmpeg graphics/php5-ffmpeg
The ffmpeg-php is an extension for PHP that adds an easy to use, object-oriented API for accessing and retrieving information from video and audio files. It has methods for returning frames from movie files as images that can be manipulated using PHP's image functions. This works well for automatically creating thumbnail images from movies. ffmpeg-php is also useful for reporting the duration and bitrate of audio files (mp3, wma...). The ffmpeg-php can access many of the video formats supported by ffmpeg (mov, avi, mpg, wmv...) WWW: http://ffmpeg-php.sourceforge.net/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile2
-rw-r--r--graphics/php4-ffmpeg/Makefile30
-rw-r--r--graphics/php4-ffmpeg/distinfo3
-rw-r--r--graphics/php4-ffmpeg/pkg-descr11
-rw-r--r--graphics/php5-ffmpeg/Makefile17
-rw-r--r--graphics/php5-ffmpeg/distinfo3
-rw-r--r--graphics/php5-ffmpeg/pkg-descr11
7 files changed, 77 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 565e736fd39d..38cde760e930 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -501,9 +501,11 @@
SUBDIR += photopc
SUBDIR += php-magickwand
SUBDIR += php4-exif
+ SUBDIR += php4-ffmpeg
SUBDIR += php4-gd
SUBDIR += php4-ming
SUBDIR += php5-exif
+ SUBDIR += php5-ffmpeg
SUBDIR += php5-gd
SUBDIR += php5-ming
SUBDIR += phplot
diff --git a/graphics/php4-ffmpeg/Makefile b/graphics/php4-ffmpeg/Makefile
new file mode 100644
index 000000000000..2e3351f73119
--- /dev/null
+++ b/graphics/php4-ffmpeg/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: php4-ffmpeg
+# Date created: 2006-10-19
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffmpeg
+PORTVERSION= 0.5.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}-${PKGNAMEPREFIX:S/4-//}
+PKGNAMEPREFIX?= php4-
+DISTNAME= ${PORTNAME}-${PKGNAMEPREFIX:S/4-//:S/5-//}-${PORTVERSION}
+EXTRACT_SUFX= .tbz2
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= The ffmpeg shared extension for php
+
+LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+ gd.4:${PORTSDIR}/graphics/gd
+
+USE_BZIP2= yes
+USE_PHP= yes
+USE_PHPEXT= yes
+IGNORE_WITH_PHP?=5
+DEFAULT_PHP_VER?=4
+CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+
+.include <bsd.port.mk>
diff --git a/graphics/php4-ffmpeg/distinfo b/graphics/php4-ffmpeg/distinfo
new file mode 100644
index 000000000000..c796e60dd489
--- /dev/null
+++ b/graphics/php4-ffmpeg/distinfo
@@ -0,0 +1,3 @@
+MD5 (ffmpeg-php-0.5.0.tbz2) = f13bbbe9d46ba29402fefb942a2c4adf
+SHA256 (ffmpeg-php-0.5.0.tbz2) = 9f6ac3ca74cd867c60fd84eab026493e558f5d929be7bb9028dfad1955926962
+SIZE (ffmpeg-php-0.5.0.tbz2) = 1606351
diff --git a/graphics/php4-ffmpeg/pkg-descr b/graphics/php4-ffmpeg/pkg-descr
new file mode 100644
index 000000000000..d37829bb1543
--- /dev/null
+++ b/graphics/php4-ffmpeg/pkg-descr
@@ -0,0 +1,11 @@
+The ffmpeg-php is an extension for PHP that adds an easy to use,
+object-oriented API for accessing and retrieving information from video and
+audio files. It has methods for returning frames from movie files as images
+that can be manipulated using PHP's image functions. This works well for
+automatically creating thumbnail images from movies. ffmpeg-php is also useful
+for reporting the duration and bitrate of audio files (mp3, wma...).
+
+The ffmpeg-php can access many of the video formats supported by ffmpeg (mov,
+avi, mpg, wmv...)
+
+WWW: http://ffmpeg-php.sourceforge.net/
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
new file mode 100644
index 000000000000..e57db6a0b8e4
--- /dev/null
+++ b/graphics/php5-ffmpeg/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: php4-ffmpeg
+# Date created: 2006-10-19
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics
+
+PKGNAMEPREFIX= php5-
+
+MASTERDIR= ${.CURDIR}/../../graphics/php4-ffmpeg
+
+IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=5
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/php5-ffmpeg/distinfo b/graphics/php5-ffmpeg/distinfo
new file mode 100644
index 000000000000..c796e60dd489
--- /dev/null
+++ b/graphics/php5-ffmpeg/distinfo
@@ -0,0 +1,3 @@
+MD5 (ffmpeg-php-0.5.0.tbz2) = f13bbbe9d46ba29402fefb942a2c4adf
+SHA256 (ffmpeg-php-0.5.0.tbz2) = 9f6ac3ca74cd867c60fd84eab026493e558f5d929be7bb9028dfad1955926962
+SIZE (ffmpeg-php-0.5.0.tbz2) = 1606351
diff --git a/graphics/php5-ffmpeg/pkg-descr b/graphics/php5-ffmpeg/pkg-descr
new file mode 100644
index 000000000000..d37829bb1543
--- /dev/null
+++ b/graphics/php5-ffmpeg/pkg-descr
@@ -0,0 +1,11 @@
+The ffmpeg-php is an extension for PHP that adds an easy to use,
+object-oriented API for accessing and retrieving information from video and
+audio files. It has methods for returning frames from movie files as images
+that can be manipulated using PHP's image functions. This works well for
+automatically creating thumbnail images from movies. ffmpeg-php is also useful
+for reporting the duration and bitrate of audio files (mp3, wma...).
+
+The ffmpeg-php can access many of the video formats supported by ffmpeg (mov,
+avi, mpg, wmv...)
+
+WWW: http://ffmpeg-php.sourceforge.net/