aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /graphics
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgphoto2/Makefile5
-rw-r--r--graphics/lprof-devel/Makefile11
-rw-r--r--graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c12
-rw-r--r--graphics/lprof-devel/files/patch-src_argyll_spectro_usbio.c10
-rw-r--r--graphics/s10sh/Makefile14
-rw-r--r--graphics/s10sh/files/Makefile.bsd4
-rw-r--r--graphics/sane-backends/Makefile4
7 files changed, 48 insertions, 12 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index b38512d23f2a..3e197226061b 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -39,9 +39,12 @@ PLIST_SUB+= NLS=""
.if ${OSVERSION} < 800064
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-.else
+.elif ${OSVERSION} < 800069
CONFIGURE_ENV+= LIBUSB_LIBS="-L/usr/lib -lusb20" LIBUSB_CFLAGS="-I/usr/include/dev/usb -I/usr/include"
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-usb20
+.else
+CONFIGURE_ENV+= LIBUSB_LIBS="-lusb" LIBUSB_CFLAGS="-I/usr/include"
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-usb20
.endif
post-patch:
diff --git a/graphics/lprof-devel/Makefile b/graphics/lprof-devel/Makefile
index 058c66f7dc59..fba3ab1d1e5d 100644
--- a/graphics/lprof-devel/Makefile
+++ b/graphics/lprof-devel/Makefile
@@ -19,8 +19,7 @@ COMMENT= Open source color profiler
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- vigraimpex.2:${PORTSDIR}/graphics/vigra \
- usb-0.1.8:${PORTSDIR}/devel/libusb
+ vigraimpex.2:${PORTSDIR}/graphics/vigra
USE_BZIP2= yes
USE_XORG= x11 xext sm ice xxf86vm
@@ -33,6 +32,12 @@ CMAKE_USE_PTHREAD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/asm\/types.h/ d' ${WRKSRC}/src/argyll/spectro/hidio.c
@${REINPLACE_CMD} -e '/DESTINATION/ s|data/|share/${PORTNAME}/data/|' \
@@ -41,4 +46,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/data/icons/lprof.png ${PREFIX}/share/pixmaps
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c b/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c
index e3b36a617da4..0561d219f1ea 100644
--- a/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c
+++ b/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c
@@ -1,6 +1,14 @@
--- src/argyll/spectro/unixio.c.orig 2008-02-20 00:02:24.000000000 +0300
-+++ src/argyll/spectro/unixio.c 2008-08-03 21:47:17.000000000 +0400
-@@ -585,9 +585,8 @@
++++ src/argyll/spectro/unixio.c 2009-03-07 21:19:48.000000000 +0300
+@@ -35,6 +35,7 @@
+ #include "insttypes.h"
+ #include "icoms.h"
+ #include "usbio.h"
++#include <dirent.h>
+
+ #undef DEBUG
+
+@@ -585,9 +586,8 @@
break;
if (!(
diff --git a/graphics/lprof-devel/files/patch-src_argyll_spectro_usbio.c b/graphics/lprof-devel/files/patch-src_argyll_spectro_usbio.c
new file mode 100644
index 000000000000..9ee392c2e375
--- /dev/null
+++ b/graphics/lprof-devel/files/patch-src_argyll_spectro_usbio.c
@@ -0,0 +1,10 @@
+--- src/argyll/spectro/usbio.c.orig 2009-03-07 21:18:13.000000000 +0300
++++ src/argyll/spectro/usbio.c 2009-03-07 21:18:41.000000000 +0300
+@@ -20,6 +20,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #include <time.h>
+ #include <signal.h>
+ #if defined(UNIX)
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index 3aed416d77d7..0ea05615bb5a 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -14,12 +14,6 @@ MASTER_SITES= http://www.reynoldsnet.org/s10sh/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= USB/serial userspace driver for the Canon PowerShot digital cameras
-.if defined(NOUSB) || defined(WITHOUT_USB)
-MAKE_ENV+= WITHOUT_USB=YES
-.else
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-.endif
-
# Don't extract the libusb bundled with s10sh:
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libusb*'
@@ -27,6 +21,14 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
.include <bsd.port.pre.mk>
+.if defined(NOUSB) || defined(WITHOUT_USB)
+MAKE_ENV+= WITHOUT_USB=YES
+.else
+. if ${OSVERSION} < 800069
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+. endif
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/s10sh/files/Makefile.bsd b/graphics/s10sh/files/Makefile.bsd
index d9b2f58516e2..8abbf4eb98b8 100644
--- a/graphics/s10sh/files/Makefile.bsd
+++ b/graphics/s10sh/files/Makefile.bsd
@@ -7,10 +7,14 @@ LDADD += -lreadline -ltermcap
CFLAGS += -DHAVE_READLINE
.if !defined(WITHOUT_USB)
+. if ${OSVERSION} < 800069
USBLIB != ${LOCALBASE}/bin/libusb-config --libs
LDADD += ${USBLIB}
USBCF != ${LOCALBASE}/bin/libusb-config --cflags
CFLAGS += ${USBCF} -DHAVE_USB_SUPPORT
+. else
+LDADD += -lusb
+. endif
SRCS += usb.c
.endif
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 7860e1c4360f..992fa09418e3 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -41,6 +41,10 @@ USE_LDCONFIG= yes
.include "Makefile.man"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800069
+BROKEN= does not compile due to changes in USB stack
+.endif
+
.if defined(WITHOUT_USB)
CONFIGURE_ARGS+= --disable-libusb
.else