aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2009-12-20 18:43:14 +0800
committerkwm <kwm@FreeBSD.org>2009-12-20 18:43:14 +0800
commit10d0d006f2fea061784e765016d4a9cf6bee80fa (patch)
tree3725d638b4952689cbf3ac8d3981a1ecb22a15fb /graphics
parent43b2355ee868af4fb140bdc2e62a204e5b60884e (diff)
downloadfreebsd-ports-gnome-10d0d006f2fea061784e765016d4a9cf6bee80fa.tar.gz
freebsd-ports-gnome-10d0d006f2fea061784e765016d4a9cf6bee80fa.tar.zst
freebsd-ports-gnome-10d0d006f2fea061784e765016d4a9cf6bee80fa.zip
Fix usage of USE_QT* macros. So depends are detected correctly.
PR: ports/141347 Submitted by: Dima Panov <fluffy@FreeBSD.org> (based on patch by makc@)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/poppler/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index d3758582c102..559d07a53b59 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -27,8 +27,10 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-zlib \
--enable-xpdf-headers \
--with-html-dir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS=-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 ${PTHREAD_CFLAGS}
+LDFLAGS=-L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
.if !defined(SLAVEPORT)
OPTIONS= CAIRO "Enable cairo output backend" on \
@@ -70,6 +72,7 @@ QT_COMPONENTS= gui corelib xml qtestlib moc_build
# can read more PDF files than without, tested with demos's poppler_qt4viewer.
#BUILD_WRKSRC= ${WRKSRC}/qt4
INSTALL_WRKSRC= ${WRKSRC}/qt4
+.include "${PORTSDIR}/Mk/bsd.qt.mk"
.else
CONFIGURE_ARGS+=--disable-poppler-qt4
.endif