aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-04-16 03:26:28 +0800
committernemysis <nemysis@FreeBSD.org>2014-04-16 03:26:28 +0800
commit3a1cf367db41904d0ef81afb8a2cd368eb5123c6 (patch)
tree8bcbe992b868f4c41b0a4e7e77d11347c23c2cf9 /graphics
parent08a560ba4611eace092d2bf47d9033a335a544f6 (diff)
downloadfreebsd-ports-gnome-3a1cf367db41904d0ef81afb8a2cd368eb5123c6.tar.gz
freebsd-ports-gnome-3a1cf367db41904d0ef81afb8a2cd368eb5123c6.tar.zst
freebsd-ports-gnome-3a1cf367db41904d0ef81afb8a2cd368eb5123c6.zip
- Update to 1.0.1, Announce message:
Do not create JFIF header (APP0 block) by default. This saves 18 bytes per image. - Add jpeg and libjpeg-turbo to CONFLICTS_INSTALL - Add USE_LDCONFIG=${PREFIX}/include ${PREFIX}/lib - Change CONFIGURE_ARGS, change USE_LDCONFIG, remove PORTNAME from PLIST_SUB, change STRIP_CMD, change pkg-plist - Add autoheader and libtoolize to USE_AUTOTOOLS, remove run-autotools, add AUTOMAKE_ARGS - Remove LIBTOOL_ARGS and LDFLAGS - Remove SIMD from default Options - Use GCC=yes instead of GCC=any - Change BUILD_DEPENDS from nasm to yasm, moved to SIMD - Change SOMAJORVERSION to VER - Reordering Options - Break lines around 80 characters - Change REINPLACE, cosmetical changes - Patch for warning: always_inline function might not be inlinable http://sourceforge.net/p/libjpeg-turbo/patches/56/ - Use .if for DOCS due to large number of files installed PR: ports/188540 Submitted by: Horia Racoviceanu <horia@racoviceanu.com> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mozjpeg/Makefile38
-rw-r--r--graphics/mozjpeg/distinfo4
-rw-r--r--graphics/mozjpeg/pkg-plist2
3 files changed, 21 insertions, 23 deletions
diff --git a/graphics/mozjpeg/Makefile b/graphics/mozjpeg/Makefile
index 722d627e8bda..888324e6bef5 100644
--- a/graphics/mozjpeg/Makefile
+++ b/graphics/mozjpeg/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mozjpeg
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
CATEGORIES= graphics
MAINTAINER= horia@racoviceanu.com
@@ -10,24 +10,22 @@ COMMENT= Fork of libjpeg-turbo with 'jpgcrush' functionality
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-
USE_GITHUB= yes
GH_ACCOUNT= mozilla
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= febf346
+GH_COMMIT= 0c7449c
-USE_AUTOTOOLS= aclocal:env autoconf automake libtool
+USE_AUTOTOOLS= aclocal autoconf autoheader automake libtool libtoolize
USE_LDCONFIG= ${PREFIX}/include/${PORTNAME} ${PREFIX}/lib/${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir=${PREFIX}/share/doc/${PORTNAME} \
--includedir=${PREFIX}/include/${PORTNAME} \
--libdir=${PREFIX}/lib/${PORTNAME}
-LIBTOOL_ARGS+= --finish ${PREFIX}/lib/${PORTNAME}
+AUTOMAKE_ARGS+= -fiv --add-missing
LDFLAGS+= -L${PREFIX}/lib/${PORTNAME}
PLIST_SUB= PORTNAME=${PORTNAME} \
- SOMAJORVERSION=${SOMAJORVERSION}
+ VER=${VER}
PORTDOCS= *
@@ -52,7 +50,7 @@ OPTIONS_MULTI_LIBRARIES= SHARED STATIC
OPTIONS_SINGLE= API_ABI_EMULATION
OPTIONS_SINGLE_API_ABI_EMULATION= JPEG6B JPEG7 JPEG8
-OPTIONS_DEFAULT= DECODING ENCODING GCC JPEG6B SHARED SIMD STATIC TURBOJPEG
+OPTIONS_DEFAULT= DECODING ENCODING GCC JPEG8 SHARED STATIC TURBOJPEG
OPTIONS_SUB= yes
@@ -70,8 +68,9 @@ JPEG6B_DESC= API/ABI-compatible with libjpeg v6b
JPEG7_DESC= API/ABI-compatible with libjpeg v7 (implies arith-coding)
JPEG8_DESC= API/ABI-compatible with libjpeg v8 (implies arith-coding)
-GCC_USE= GCC=any
+GCC_USE= GCC=yes
SIMD_CONFIGURE_WITH= simd
+SIMD_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
TURBOJPEG_CONFIGURE_WITH= turbojpeg
JPEG7_CONFIGURE_WITH= jpeg7
@@ -89,28 +88,27 @@ CONFIGURE_ARGS+= --without-arith-enc
. if ! ${PORT_OPTIONS:MDECODING}
CONFIGURE_ARGS+= --without-arith-dec
. endif
-SOMAJORVERSION= 63
+VER= 63
.else
-SOMAJORVERSION= 8
+VER= 8
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|docdir = \$$(datadir)/doc|&/mozjpeg|; \
- s|exampledir = \$$(datadir)/doc|exampledir = ${EXAMPLESDIR}|" \
- ${WRKSRC}/Makefile.am
-
-run-autotools: run-autotools-autoreconf
-
-run-autotools-autoreconf:
- cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -fiv
+ @${REINPLACE_CMD} -e 's|docdir = $$(datadir)/doc|&/mozjpeg|; \
+ /^exampledir/s|=.*|= ${EXAMPLESDIR}|' \
+ ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's|__attribute__((always_inline))",|inline &|' \
+ ${WRKSRC}/configure.ac
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR1}
${INSTALL_DATA} ${DOC_FILES:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+.endif
.if ${PORT_OPTIONS:MSHARED}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/libjpeg.so.${SOMAJORVERSION}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/libjpeg.so.${VER}
.endif
.if ${PORT_OPTIONS:MSHARED} && ${PORT_OPTIONS:MTURBOJPEG}
diff --git a/graphics/mozjpeg/distinfo b/graphics/mozjpeg/distinfo
index 7e00de5948bc..39a9e878ea95 100644
--- a/graphics/mozjpeg/distinfo
+++ b/graphics/mozjpeg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mozjpeg-1.0.tar.gz) = 6c4845d7fa0bddd77e4a209e8e81bde11af8524dcd2cb0bb10bfd9519548ec95
-SIZE (mozjpeg-1.0.tar.gz) = 1032706
+SHA256 (mozjpeg-1.0.1.tar.gz) = f3ddbdc323ef3daf6b6958ba1365fc869819d07b201727be1ab3fdaa3213b0c4
+SIZE (mozjpeg-1.0.1.tar.gz) = 1039871
diff --git a/graphics/mozjpeg/pkg-plist b/graphics/mozjpeg/pkg-plist
index 60671e6af85d..2a9c410eb132 100644
--- a/graphics/mozjpeg/pkg-plist
+++ b/graphics/mozjpeg/pkg-plist
@@ -12,7 +12,7 @@ include/%%PORTNAME%%/jpeglib.h
%%STATIC%%lib/%%PORTNAME%%/libjpeg.a
lib/%%PORTNAME%%/libjpeg.la
%%SHARED%%lib/%%PORTNAME%%/libjpeg.so
-%%SHARED%%lib/%%PORTNAME%%/libjpeg.so.%%SOMAJORVERSION%%
+%%SHARED%%lib/%%PORTNAME%%/libjpeg.so.%%VER%%
%%STATIC%%%%TURBOJPEG%%lib/%%PORTNAME%%/libturbojpeg.a
%%TURBOJPEG%%lib/%%PORTNAME%%/libturbojpeg.la
%%SHARED%%%%TURBOJPEG%%lib/%%PORTNAME%%/libturbojpeg.so