aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-20 23:01:39 +0800
committerkrion <krion@FreeBSD.org>2003-11-20 23:01:39 +0800
commit415cb274e2334b746da02a02949573a1ac0daeca (patch)
treeab37545b4e5de53999805b9dfbc79c4e43aeab16 /graphics
parent74cd628686aa5fd2db820c7b36b5c5bc0fbb652a (diff)
downloadfreebsd-ports-gnome-415cb274e2334b746da02a02949573a1ac0daeca.tar.gz
freebsd-ports-gnome-415cb274e2334b746da02a02949573a1ac0daeca.tar.zst
freebsd-ports-gnome-415cb274e2334b746da02a02949573a1ac0daeca.zip
- Add patch to choose build for print/ghostscript-gnu and
print/ghostscript-afp1 PR: 54926 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 0e583f833954..410cbff34df6 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -213,12 +213,18 @@ CONFIGURE_ARGS+= --without-mpeg2
.endif
.if defined(NEED_GS)
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
.if defined(WITHOUT_X11)
-BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
-RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
+BUILD_DEPENDS+= gs:${PORTSDIR}/${GSPORT}-nox11
+RUN_DEPENDS+= gs:${PORTSDIR}/${GSPORT}-nox11
.else
-BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
-RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
+BUILD_DEPENDS+= gs:${PORTSDIR}/${GSPORT}
+RUN_DEPENDS+= gs:${PORTSDIR}/${GSPORT}
.endif
.endif