aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-27 12:29:58 +0800
committerkris <kris@FreeBSD.org>2003-06-27 12:29:58 +0800
commit5180d1a6e443deb8b675f35cead08fe057bc7256 (patch)
treed0c3aefa7591c923e140e0373d1bf9fbc3ec13a3 /graphics
parent4c888e8236d90051ddf5b9ef90759d4f57450a88 (diff)
downloadfreebsd-ports-gnome-5180d1a6e443deb8b675f35cead08fe057bc7256.tar.gz
freebsd-ports-gnome-5180d1a6e443deb8b675f35cead08fe057bc7256.tar.zst
freebsd-ports-gnome-5180d1a6e443deb8b675f35cead08fe057bc7256.zip
Allocate MAXPATHLEN size for filename manipulation to avoid risk
of truncation. Bump PORTREVISION. Obtained from: OpenBSD
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gqview/Makefile1
-rw-r--r--graphics/gqview/files/patch-src_main_c19
2 files changed, 20 insertions, 0 deletions
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index c3eb05a7d6eb..60157f6d65b7 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gqview
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/gqview/files/patch-src_main_c b/graphics/gqview/files/patch-src_main_c
new file mode 100644
index 000000000000..4eca3da4f350
--- /dev/null
+++ b/graphics/gqview/files/patch-src_main_c
@@ -0,0 +1,19 @@
+--- src/main.c.orig Thu Jun 26 21:27:18 2003
++++ src/main.c Thu Jun 26 21:28:56 2003
+@@ -10,6 +10,7 @@
+ */
+
+
++#include <sys/param.h>
+ #include "gqview.h"
+
+ #include "collect.h"
+@@ -159,7 +160,7 @@
+
+ void start_editor_from_path_list(gint n, GList *list)
+ {
+- gchar current_path[512];
++ gchar current_path[MAXPATHLEN];
+ gchar *success;
+ gchar *cmd;
+ gchar *buf;