aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2010-06-04 09:54:58 +0800
committersahil <sahil@FreeBSD.org>2010-06-04 09:54:58 +0800
commit5392172f4ec15399efbd2e550f3d894c43f9fffa (patch)
treefb1523e8d06b585f2c6bb2fe78f1d95fe7450377 /graphics
parentb52e25b818b73fdaa6e2d84ca360a218009e77fc (diff)
downloadfreebsd-ports-gnome-5392172f4ec15399efbd2e550f3d894c43f9fffa.tar.gz
freebsd-ports-gnome-5392172f4ec15399efbd2e550f3d894c43f9fffa.tar.zst
freebsd-ports-gnome-5392172f4ec15399efbd2e550f3d894c43f9fffa.zip
Graphy is a simple Python library for generating charts. It tries
to get out of the way and let you just work with your data. At the moment, it produces charts using the Google Chart API. WWW: http://graphy.googlecode.com/ Approved by: wxs@ (mentor)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-graphy/Makefile49
-rw-r--r--graphics/py-graphy/distinfo3
-rw-r--r--graphics/py-graphy/pkg-descr5
-rw-r--r--graphics/py-graphy/pkg-plist48
5 files changed, 106 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 13e1e6a2ec38..2e9b2e2bd59c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -763,6 +763,7 @@
SUBDIR += py-graph-core
SUBDIR += py-graph-dot
SUBDIR += py-graphviz
+ SUBDIR += py-graphy
SUBDIR += py-gvgen
SUBDIR += py-imaging
SUBDIR += py-ming
diff --git a/graphics/py-graphy/Makefile b/graphics/py-graphy/Makefile
new file mode 100644
index 000000000000..c8ba4bc8c77c
--- /dev/null
+++ b/graphics/py-graphy/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: py-graphy
+# Date created: 2010-06-01
+# Whom: Sahil Tandon <sahil@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphy
+PORTVERSION= 1.0
+CATEGORIES= graphics python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= sahil@FreeBSD.org
+COMMENT= A simple chart library for Python
+
+USE_BZIP2= yes
+USE_PYTHON_RUN= yes
+
+PORTDOCS= README
+PORTEXAMPLES= *
+
+NO_BUILD= yes
+NO_INSTALL_MANPAGES= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|python2.4|${PYTHON_VERSION}|' \
+ ${WRKSRC}/examples/*.py \
+ ${WRKSRC}/${PORTNAME}/*.py
+ @${FIND} ${WRKSRC} -name '.svn' -or -name '*.bak' | \
+ ${XARGS} ${RM} -rf
+
+do-install:
+ @${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
+ @(cd ${WRKSRC}/${PORTNAME}/ && \
+ ${COPYTREE_SHARE} \* ${PYTHON_SITELIBDIR}/${PORTNAME})
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 555 -d ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-graphy/distinfo b/graphics/py-graphy/distinfo
new file mode 100644
index 000000000000..aecc69752c6f
--- /dev/null
+++ b/graphics/py-graphy/distinfo
@@ -0,0 +1,3 @@
+MD5 (graphy_1.0.tar.bz2) = cbf392db1866f3158608f6de97488de1
+SHA256 (graphy_1.0.tar.bz2) = d51c726c7deb028304fe4745afebd5e4fcd012ef2ee214d971f902f5d321492b
+SIZE (graphy_1.0.tar.bz2) = 69099
diff --git a/graphics/py-graphy/pkg-descr b/graphics/py-graphy/pkg-descr
new file mode 100644
index 000000000000..aea35282166a
--- /dev/null
+++ b/graphics/py-graphy/pkg-descr
@@ -0,0 +1,5 @@
+Graphy is a simple Python library for generating charts. It tries
+to get out of the way and let you just work with your data. At the
+moment, it produces charts using the Google Chart API.
+
+WWW: http://graphy.googlecode.com/
diff --git a/graphics/py-graphy/pkg-plist b/graphics/py-graphy/pkg-plist
new file mode 100644
index 000000000000..5ddbf7993b58
--- /dev/null
+++ b/graphics/py-graphy/pkg-plist
@@ -0,0 +1,48 @@
+%%PYTHON_SITELIBDIR%%/graphy/__init__.py
+%%PYTHON_SITELIBDIR%%/graphy/__init__.pyc
+%%PYTHON_SITELIBDIR%%/graphy/all_tests.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/base_encoder_test.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/util_test.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/util.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/pie_chart_test.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/__init__.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/encoders.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/bar_chart_test.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/line_chart_test.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/__init__.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/encoders.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/util.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/base_encoder_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/util_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/pie_chart_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/bar_chart_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api/line_chart_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/backends/__init__.py
+%%PYTHON_SITELIBDIR%%/graphy/backends/__init__.pyc
+%%PYTHON_SITELIBDIR%%/graphy/bar_chart.py
+%%PYTHON_SITELIBDIR%%/graphy/bar_chart.pyc
+%%PYTHON_SITELIBDIR%%/graphy/bar_chart_test.py
+%%PYTHON_SITELIBDIR%%/graphy/bar_chart_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/common.py
+%%PYTHON_SITELIBDIR%%/graphy/common.pyc
+%%PYTHON_SITELIBDIR%%/graphy/common_test.py
+%%PYTHON_SITELIBDIR%%/graphy/common_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/formatters.py
+%%PYTHON_SITELIBDIR%%/graphy/util.py
+%%PYTHON_SITELIBDIR%%/graphy/formatters.pyc
+%%PYTHON_SITELIBDIR%%/graphy/formatters_test.py
+%%PYTHON_SITELIBDIR%%/graphy/formatters_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/graphy_test.py
+%%PYTHON_SITELIBDIR%%/graphy/graphy_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/line_chart.py
+%%PYTHON_SITELIBDIR%%/graphy/line_chart.pyc
+%%PYTHON_SITELIBDIR%%/graphy/line_chart_test.py
+%%PYTHON_SITELIBDIR%%/graphy/line_chart_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/pie_chart.py
+%%PYTHON_SITELIBDIR%%/graphy/pie_chart.pyc
+%%PYTHON_SITELIBDIR%%/graphy/pie_chart_test.py
+%%PYTHON_SITELIBDIR%%/graphy/pie_chart_test.pyc
+%%PYTHON_SITELIBDIR%%/graphy/util.pyc
+@dirrm %%PYTHON_SITELIBDIR%%/graphy/backends/google_chart_api
+@dirrm %%PYTHON_SITELIBDIR%%/graphy/backends
+@dirrm %%PYTHON_SITELIBDIR%%/graphy