aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-10-24 19:01:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-10-24 19:01:48 +0800
commit588813295ea4a1d1e7ac498eb1570836b9d0465a (patch)
tree3f5f453ff9b37b67db443a0e8297ae4bf04f0af4 /graphics
parent9189a899c37b519e986d38b2d7a0361fcb7c799e (diff)
downloadfreebsd-ports-gnome-588813295ea4a1d1e7ac498eb1570836b9d0465a.tar.gz
freebsd-ports-gnome-588813295ea4a1d1e7ac498eb1570836b9d0465a.tar.zst
freebsd-ports-gnome-588813295ea4a1d1e7ac498eb1570836b9d0465a.zip
- Fix build WITH_JAVA on i386
- Mark broken on !i386 when built WITH_JAVA (does not build) - Disable java by default as suggested in ports/127386 (too many problems with it after all) PR: 128329 Submitted by: Stephen Montgomery-Smith <stephen at math dot missouri dot edu>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opendx/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index eed26c02489a..d06b630ddc76 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -50,13 +50,14 @@ LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
CONFIGURE_ARGS+= --without-netcdf
.endif
-.if !defined(WITHOUT_JAVA)
+.if defined(WITH_JAVA)
USE_JAVA= yes
JAVA_VERSION= 1.3+
BUILD_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
RUN_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
-CONFIGURE_ARGS+= --with-cosmojar-path=${JAVALIBDIR}/npcosmop211.jar \
- --with-java40jar-path=${JAVALIBDIR}/java40.jar
+CONFIGURE_ARGS+= --with-cosmojar-path=${JAVALIBDIR}/npcosmop211.jar \
+ --with-java40jar-path=${JAVALIBDIR}/java40.jar \
+ --with-jni-path=${JAVA_HOME}/include:${JAVA_HOME}/include/freebsd
PLIST_SUB+= JAVA=""
DIR2PRUNE= dx/java/user dx/java/server/nets
.else
@@ -68,6 +69,10 @@ PLIST_SUB+= UNAMEP=${ARCH}
.include <bsd.port.pre.mk>
+.if defined(WITH_JAVA) && ${ARCH} != "i386"
+BROKEN= does not build
+.endif
+
post-patch:
@${RM} -f ${WRKSRC}/include/stamp-h.in
.for dir in doc help html man
@@ -82,7 +87,7 @@ post-patch:
post-install:
@${CP} ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
-.if !defined(WITHOUT_JAVA)
+.if defined(WITH_JAVA)
${CHMOD} 0775 ${PREFIX}/dx/java/server/nets
${TOUCH} ${DIR2PRUNE:S|^|${PREFIX}/|:S|$|/.keepme|}
@${ECHO} "---------------------------------------------------------" \