aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-18 17:25:43 +0800
committermiwi <miwi@FreeBSD.org>2012-05-18 17:25:43 +0800
commit5c331f69fac5e5dfbcc5f430d2247cb74d818903 (patch)
tree40af122eed1a28a96dd047f3fe92343c3dba9a72 /graphics
parent0a22ca8779e05e93fe22630fb7717b321942a768 (diff)
downloadfreebsd-ports-gnome-5c331f69fac5e5dfbcc5f430d2247cb74d818903.tar.gz
freebsd-ports-gnome-5c331f69fac5e5dfbcc5f430d2247cb74d818903.tar.zst
freebsd-ports-gnome-5c331f69fac5e5dfbcc5f430d2247cb74d818903.zip
With PEAR::Image_Barcode2 class you can create a barcode representation of a
given string. This class uses GD function because this the generated graphic can be any of GD supported image types. WWW: http://pear.php.net/package/Image_Barcode2/ PR: ports/166979 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pear-Image_Barcode2/Makefile26
-rw-r--r--graphics/pear-Image_Barcode2/distinfo2
-rw-r--r--graphics/pear-Image_Barcode2/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6acd9360fe95..dab7a115d511 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -696,6 +696,7 @@
SUBDIR += pear-IO_SWF
SUBDIR += pear-Image_3D
SUBDIR += pear-Image_Barcode
+ SUBDIR += pear-Image_Barcode2
SUBDIR += pear-Image_Canvas
SUBDIR += pear-Image_Color
SUBDIR += pear-Image_Graph
diff --git a/graphics/pear-Image_Barcode2/Makefile b/graphics/pear-Image_Barcode2/Makefile
new file mode 100644
index 000000000000..778ca7ad1612
--- /dev/null
+++ b/graphics/pear-Image_Barcode2/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Image_Barcode2
+# Date created: 16 Apr 2012
+# Whom: Muhammad Moinur Rahman <5u623l20@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image_Barcode2
+PORTVERSION= 0.2.1
+CATEGORIES= graphics www pear
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= PEAR class for barcode generation
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+USE_PHP= gd
+
+LATEST_LINK= pear-${PORTNAME}
+
+PEAR_AUTOINSTALL= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/graphics/pear-Image_Barcode2/distinfo b/graphics/pear-Image_Barcode2/distinfo
new file mode 100644
index 000000000000..f9c61109c334
--- /dev/null
+++ b/graphics/pear-Image_Barcode2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/Image_Barcode2-0.2.1.tgz) = 30e7d04521d48b59dc20cb99a3562146a3bd08093c3ed745dee9b8fed643fad0
+SIZE (PEAR/Image_Barcode2-0.2.1.tgz) = 15032
diff --git a/graphics/pear-Image_Barcode2/pkg-descr b/graphics/pear-Image_Barcode2/pkg-descr
new file mode 100644
index 000000000000..1df7703c61e0
--- /dev/null
+++ b/graphics/pear-Image_Barcode2/pkg-descr
@@ -0,0 +1,7 @@
+With PEAR::Image_Barcode2 class you can create a barcode representation of a
+given string.
+
+This class uses GD function because this the generated graphic can be any of
+GD supported image types.
+
+WWW: http://pear.php.net/package/Image_Barcode2/