aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-04-07 03:43:29 +0800
committerstas <stas@FreeBSD.org>2009-04-07 03:43:29 +0800
commit5e7cfd7943fb4a4afc024f23f31c23431ead5ee3 (patch)
tree76e3316d8b08237afe8c0aa9c72d898a58980801 /graphics
parent1adc597c19e8e8501ef9b308a66916c12fd4a358 (diff)
downloadfreebsd-ports-gnome-5e7cfd7943fb4a4afc024f23f31c23431ead5ee3.tar.gz
freebsd-ports-gnome-5e7cfd7943fb4a4afc024f23f31c23431ead5ee3.tar.zst
freebsd-ports-gnome-5e7cfd7943fb4a4afc024f23f31c23431ead5ee3.zip
- Make ocaml-lablgl to work with tk versions above 8.4.
PR: ports/133113 Submitted by: Scot Hetzel <swhetzel@gmail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ocaml-lablgl/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
index 4dd337ee6ca5..3d13edbea446 100644
--- a/graphics/ocaml-lablgl/Makefile
+++ b/graphics/ocaml-lablgl/Makefile
@@ -21,6 +21,7 @@ USE_OCAML= yes
USE_OCAML_WASH= yes
ALL_TARGET= all opt
DEPENDS_ARGS+= WITH_TK=yes
+USE_TK= yes
MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
PATTERN= [[:space:]]*(do|then)?[[:space:]]*)cp([[:space:]]
@@ -39,6 +40,8 @@ post-extract:
-e "s,^\(RANLIB[ \t]*=\).*,\1ranlib,g" \
-e "s,^#\(LIBDIR[ \t]*=\).*,\1${PREFIX}/lib/ocaml,g" \
-e "s,^#\(DLLDIR[ \t]*=\).*,\1${PREFIX}/lib/ocaml/stublibs,g" \
+ -e "s,^\(TKINCLUDES[ \t]*=\).*,\1-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR},g" \
+ -e "s,^\(TKLIBS[ \t]*=\).*,\1-L${LOCALBASE}/lib -ltk${USE_TK} -ltcl${USE_TCL},g" \
${WRKSRC}/Makefile.config
@${REINPLACE_CMD} \