aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsmace <smace@FreeBSD.org>1998-09-23 04:04:41 +0800
committersmace <smace@FreeBSD.org>1998-09-23 04:04:41 +0800
commit8af16213ceb0c0f6bdfed2546a8a206f956c4fff (patch)
tree487197d6d1c8cf617cb779c7c01ec21a99b36ec8 /graphics
parent23c862245ea962cb073e5ad6088ef85f32933c72 (diff)
downloadfreebsd-ports-gnome-8af16213ceb0c0f6bdfed2546a8a206f956c4fff.tar.gz
freebsd-ports-gnome-8af16213ceb0c0f6bdfed2546a8a206f956c4fff.tar.zst
freebsd-ports-gnome-8af16213ceb0c0f6bdfed2546a8a206f956c4fff.zip
Convert to ELF.
1. jbig is elfed 2. use PERL5 variable 3. fix ldconfig Note: PerlMagick is still broken is some respects
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 893efa3a08b9..2953d2f8619c 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -3,7 +3,7 @@
# Date created: 15 November 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.53 1998/09/21 08:41:42 asami Exp $
+# $Id: Makefile,v 1.54 1998/09/21 08:54:23 asami Exp $
#
DISTNAME= ImageMagick-4.0.9
@@ -23,7 +23,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
mpeg.1:${PORTSDIR}/graphics/mpeg-lib \
tiff34.1:${PORTSDIR}/graphics/tiff34 \
png.2:${PORTSDIR}/graphics/png \
- jbig\\.1\\.:${PORTSDIR}/graphics/jbigkit \
+ jbig.1:${PORTSDIR}/graphics/jbigkit \
ttf.2:${PORTSDIR}/print/freetype
BUILD_DEPENDS= fig2dev:${PORTSDIR}/print/transfig \
picttoppm:${PORTSDIR}/graphics/netpbm \
@@ -36,10 +36,10 @@ MAN5= quantize.5
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --enable-lzw --enable-shared --with-perl=${PREFIX}/bin/perl5
+CONFIGURE_ARGS= --enable-lzw --enable-shared --with-perl=${PERL5}
USE_PERL5= YES
CONFIGURE_ENV= LDFLAGS="$(LDFLAGS) -L${WRKSRC}/magick/.libs"
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>