aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-10-26 03:21:39 +0800
committerknu <knu@FreeBSD.org>2000-10-26 03:21:39 +0800
commit8eb2bd4554b72f85d0c94381a6f55e23d3e11319 (patch)
treec9540d23912a40d8767bda3c0f23b0bac9c8b776 /graphics
parent508fa37180aa8743cbbbb705a0068a55cdc87993 (diff)
downloadfreebsd-ports-gnome-8eb2bd4554b72f85d0c94381a6f55e23d3e11319.tar.gz
freebsd-ports-gnome-8eb2bd4554b72f85d0c94381a6f55e23d3e11319.tar.zst
freebsd-ports-gnome-8eb2bd4554b72f85d0c94381a6f55e23d3e11319.zip
Complete _includeinstall for 3-STABLE or older.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libflash/files/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/graphics/libflash/files/Makefile b/graphics/libflash/files/Makefile
index 7d6b4df5eb29..58e8037fbdbc 100644
--- a/graphics/libflash/files/Makefile
+++ b/graphics/libflash/files/Makefile
@@ -19,3 +19,18 @@ LIBDIR= ${LOCALBASE}/lib
INCDIR= ${LOCALBASE}/include
.include <bsd.lib.mk>
+
+# For FreeBSD 3.x or older
+.if !target(_includeinstall)
+_includeinstall:
+.if defined(INCS)
+.for header in ${INCS}
+ cd ${.CURDIR} && \
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${header} ${DESTDIR}${INCDIR}
+
+.endfor
+.endif
+
+beforeinstall: _includeinstall
+.endif