aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-04-19 21:42:46 +0800
committertijl <tijl@FreeBSD.org>2015-04-19 21:42:46 +0800
commita4093e0b0a09b37fc122fb2334af72ba0fe24a72 (patch)
tree11c5164008038f87e60f6658b7ad3ad25015b3c3 /graphics
parent06a6a52e3721c544d3a159457aa871842fa61d4c (diff)
downloadfreebsd-ports-gnome-a4093e0b0a09b37fc122fb2334af72ba0fe24a72.tar.gz
freebsd-ports-gnome-a4093e0b0a09b37fc122fb2334af72ba0fe24a72.tar.zst
freebsd-ports-gnome-a4093e0b0a09b37fc122fb2334af72ba0fe24a72.zip
Modernise configure.in and Makefile.am
Reported by: antoine
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cinepaint/files/patch-Makefile.am10
-rw-r--r--graphics/cinepaint/files/patch-configure.in61
2 files changed, 65 insertions, 6 deletions
diff --git a/graphics/cinepaint/files/patch-Makefile.am b/graphics/cinepaint/files/patch-Makefile.am
new file mode 100644
index 000000000000..236652e6fb22
--- /dev/null
+++ b/graphics/cinepaint/files/patch-Makefile.am
@@ -0,0 +1,10 @@
+--- Makefile.am.orig 2008-10-26 07:47:29 UTC
++++ Makefile.am
+@@ -2,6 +2,7 @@
+
+ ## Process this file with automake to produce Makefile.in
+
++ACLOCAL_AMFLAGS = -I aclocal
+ SUBDIRS = libhalf lib libgimp plug-ins app po po-plug-ins po-script-fu data
+
+ bin_SCRIPTS = cinepainttool
diff --git a/graphics/cinepaint/files/patch-configure.in b/graphics/cinepaint/files/patch-configure.in
index c688732a9d89..777dbba7a51f 100644
--- a/graphics/cinepaint/files/patch-configure.in
+++ b/graphics/cinepaint/files/patch-configure.in
@@ -1,15 +1,44 @@
---- configure.in.orig 2013-05-06 05:19:29.000000000 +0900
-+++ configure.in 2013-05-09 01:25:06.000000000 +0900
-@@ -2,7 +2,7 @@
+--- configure.in.orig 2013-05-05 20:19:29 UTC
++++ configure.in
+@@ -2,7 +2,8 @@ dnl Process this file with autoconf to p
prefix=/usr/bin
-AC_INIT(gimprc.in)
+AC_INIT(cinepaintrc.in)
++AC_CONFIG_MACRO_DIR(aclocal)
AM_CONFIG_HEADER(lib/config.h)
dnl Initialize automake stuff
-@@ -109,7 +109,7 @@
+@@ -38,9 +39,9 @@ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+-AC_CHECK_HEADER(sys/time.h, AC_DEFINE(HAVE_SYS_TIME_H))
+-AC_CHECK_HEADER(sys/times.h, AC_DEFINE(HAVE_SYS_TIMES_H))
+-AC_CHECK_HEADER(unistd.h, AC_DEFINE(HAVE_UNISTD_H))
++AC_CHECK_HEADER(sys/time.h, AC_DEFINE(HAVE_SYS_TIME_H, 1, [desc]))
++AC_CHECK_HEADER(sys/times.h, AC_DEFINE(HAVE_SYS_TIMES_H, 1, [desc]))
++AC_CHECK_HEADER(unistd.h, AC_DEFINE(HAVE_UNISTD_H, 1, [desc]))
+ AC_TYPE_PID_T
+ AC_TYPE_SIGNAL
+ AC_FUNC_VPRINTF
+@@ -83,12 +84,12 @@ AC_TRY_COMPILE([#include <sys/types.h>],
+ if test $cinepaint_ok = no; then
+ AC_HEADER_EGREP(fd_mask, sys/select.h, cinepaint_ok=yes)
+ if test $cinepaint_ok = yes; then
+- AC_DEFINE(HAVE_SYS_SELECT_H)
++ AC_DEFINE(HAVE_SYS_SELECT_H, 1, [desc])
+ fi
+ fi
+ AC_MSG_RESULT($cinepaint_ok)
+ if test $cinepaint_ok = no; then
+- AC_DEFINE(NO_FD_SET)
++ AC_DEFINE(NO_FD_SET, 1, [desc])
+ fi
+
+ dnl flex check; beku
+@@ -109,7 +110,7 @@ fi
dnl check for pkg-config
export PKG_CONFIG_PATH
AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
@@ -18,7 +47,7 @@
AC_MSG_WARN([
*** Check for pkg-config failed. Many packages requires it.
*** You can download it from http://pkgconfig.sourceforge.net/ .])
-@@ -517,9 +517,9 @@
+@@ -517,9 +518,9 @@ fi
if test "x$FLTK_CONFIG" != "xno"; then
FLTK_CONFIG="$FLTK_CONFIG"
FLTK_LDFLAGS="`$FLTK_CONFIG --use-images --ldflags | sed \"$STRIPOPT\"`"
@@ -30,7 +59,27 @@
else
AC_MSG_WARN([
*** Check for fltk-config failed. Depending plug-ins may not compile.
-@@ -818,8 +818,8 @@
+@@ -528,8 +529,8 @@ fi
+ fi
+
+ dnl Check for shared memory
+-AC_CHECK_HEADER(sys/ipc.h, AC_DEFINE(HAVE_IPC_H), no_sys_ipc=yes)
+-AC_CHECK_HEADER(sys/shm.h, AC_DEFINE(HAVE_SHM_H), no_sys_shm=yes)
++AC_CHECK_HEADER(sys/ipc.h, AC_DEFINE(HAVE_IPC_H, 1, [desc]), no_sys_ipc=yes)
++AC_CHECK_HEADER(sys/shm.h, AC_DEFINE(HAVE_SHM_H, 1, [desc]), no_sys_shm=yes)
+ if test "$ac_cv_header_sys_shm_h" = "yes"; then
+ AC_MSG_CHECKING(whether shmctl IPC_RMID allowes subsequent attaches)
+ AC_TRY_RUN([
+@@ -555,7 +556,7 @@ if test "$ac_cv_header_sys_shm_h" = "yes
+ exit (0);
+ }
+ ],
+- AC_DEFINE(IPC_RMID_DEFERRED_RELEASE)
++ AC_DEFINE(IPC_RMID_DEFERRED_RELEASE, 1, [desc])
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no),
+ AC_MSG_RESULT(assuming no))
+@@ -818,8 +819,8 @@ dnl Output the Makefiles
AC_OUTPUT(
Makefile
user_install