aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-09-15 20:12:15 +0800
committerknu <knu@FreeBSD.org>2002-09-15 20:12:15 +0800
commitca89a86b96c043c44e277458f16cc47933302074 (patch)
tree412ad4b302c8289840891904cc33088062d3f03d /graphics
parent6942edbd36eb11807c7a3ba1fafdce2691fcbd5f (diff)
downloadfreebsd-ports-gnome-ca89a86b96c043c44e277458f16cc47933302074.tar.gz
freebsd-ports-gnome-ca89a86b96c043c44e277458f16cc47933302074.tar.zst
freebsd-ports-gnome-ca89a86b96c043c44e277458f16cc47933302074.zip
Update to 0.0.9-beta and chase the gdchart update.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ruby-gdchart/Makefile23
-rw-r--r--graphics/ruby-gdchart/distinfo2
-rw-r--r--graphics/ruby-gdchart/files/extconf.rb11
-rw-r--r--graphics/ruby-gdchart/files/patch-gdchart.c23
-rw-r--r--graphics/ruby-gdchart/pkg-plist4
5 files changed, 20 insertions, 43 deletions
diff --git a/graphics/ruby-gdchart/Makefile b/graphics/ruby-gdchart/Makefile
index ec58fd69520d..26b74044cd30 100644
--- a/graphics/ruby-gdchart/Makefile
+++ b/graphics/ruby-gdchart/Makefile
@@ -5,17 +5,16 @@
# $FreeBSD$
PORTNAME= gdchart
-PORTVERSION= 0.0.1
-PORTREVISION= 1
+PORTVERSION= 0.0.9b
CATEGORIES= graphics ruby
-MASTER_SITES= http://www.aragorn.demon.nl/lib/
+MASTER_SITES= http://downloads.sourceforge.jp/ruby-gdchart/1080/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION:S/b$/-beta/}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgdchart.a:${PORTSDIR}/graphics/gdchart
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -23,11 +22,19 @@ USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-gd-include="${LOCALBASE}/include/gd"
INSTALL_TARGET= site-install
-pre-configure:
- ${CP} ${FILESDIR}/extconf.rb ${WRKSRC}/
+DOCS= ChangeLog README.en
+EXAMPLES= *_sample.rb
+.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/README.en ${RUBY_DOCDIR}/${PORTNAME}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/graphics/ruby-gdchart/distinfo b/graphics/ruby-gdchart/distinfo
index dca521e679cb..5921b84a8dfc 100644
--- a/graphics/ruby-gdchart/distinfo
+++ b/graphics/ruby-gdchart/distinfo
@@ -1 +1 @@
-MD5 (ruby/ruby-gdchart-0.0.1.tar.gz) = 23a9a2a28ed364f6234cd35e9b1edaad
+MD5 (ruby/ruby-gdchart-0.0.9-beta.tar.gz) = 2c315df7c3b309e6c5f367b974de532c
diff --git a/graphics/ruby-gdchart/files/extconf.rb b/graphics/ruby-gdchart/files/extconf.rb
deleted file mode 100644
index c7bc6233a5c1..000000000000
--- a/graphics/ruby-gdchart/files/extconf.rb
+++ /dev/null
@@ -1,11 +0,0 @@
-require 'mkmf'
-
-$CFLAGS << ' -DHAVE_JPEG'
-dir_config('gd', '/usr/local')
-dir_config('gdchart', '/usr/local')
-have_library('z')
-have_library('png')
-have_library('jpeg')
-have_library('gd')
-have_library('gdchart')
-create_makefile("GDChart")
diff --git a/graphics/ruby-gdchart/files/patch-gdchart.c b/graphics/ruby-gdchart/files/patch-gdchart.c
deleted file mode 100644
index fe12eeda2968..000000000000
--- a/graphics/ruby-gdchart/files/patch-gdchart.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- gdchart.c.orig Mon Nov 27 00:47:58 2000
-+++ gdchart.c Mon Jul 16 17:23:54 2001
-@@ -16,6 +16,11 @@
- #include "rubyio.h"
-
- VALUE
-+mgdc_get_image_type(VALUE obj) { return INT2FIX(GDC_image_type); }
-+VALUE
-+mgdc_set_image_type(VALUE obj, VALUE arg) { GDC_image_type = FIX2INT(arg); }
-+
-+VALUE
- mgdc_get_ytitle(VALUE obj) { return rb_str_new2(GDC_ytitle); }
- VALUE
- mgdc_set_ytitle(VALUE obj, VALUE arg) { GDC_ytitle = STR2CSTR(arg); }
-@@ -443,6 +448,8 @@
- #endif
- rb_define_module_function(mGDChart, "out_graph", mgdc_out_graph, 8);
-
-+ rb_define_module_function(mGDChart, "image_type", mgdc_get_image_type, 0);
-+ rb_define_module_function(mGDChart, "image_type=", mgdc_set_image_type, 1);
- rb_define_module_function(mGDChart, "ytitle", mgdc_get_ytitle, 0);
- rb_define_module_function(mGDChart, "ytitle=", mgdc_set_ytitle, 1);
- rb_define_module_function(mGDChart, "xtitle", mgdc_get_xtitle, 0);
diff --git a/graphics/ruby-gdchart/pkg-plist b/graphics/ruby-gdchart/pkg-plist
index e45649105e66..17b70e1229c0 100644
--- a/graphics/ruby-gdchart/pkg-plist
+++ b/graphics/ruby-gdchart/pkg-plist
@@ -1,3 +1,7 @@
%%RUBY_SITEARCHLIBDIR%%/GDChart.so
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gdchart/ChangeLog
%%PORTDOCS%%%%RUBY_DOCDIR%%/gdchart/README.en
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gdchart
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gdchart/bar_sample.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gdchart/pie_sample.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gdchart