aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
commitf6763c3cd1541b5d51cd003610210be9e3f57b92 (patch)
treec9a458d29164af55be5bf3330f3f659428ac04ac /graphics
parentffc02588e890cf8d01b2305cfb96dbb0eaf038a8 (diff)
downloadfreebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.gz
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.zst
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'graphics')
-rw-r--r--graphics/inkscape/Makefile12
-rw-r--r--graphics/luminance-qt5/Makefile8
-rw-r--r--graphics/openshadinglanguage/Makefile6
3 files changed, 1 insertions, 25 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 1fd322501dea..21c55be3399e 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -68,18 +68,6 @@ WPG_LIB_DEPENDS= libwpg-0.3.so:graphics/libwpg03
CPPFLAGS+= -Wno-mismatched-tags -Wno-unknown-attributes
.endif
-# Base clang 3.4.1 in FreeBSD 9.3 fails to compile this code on i386
-# but base clang 3.4.1 in FreeBSD 10.1 succeeds. The difference *appears*
-# to be the patch applied in r271597 (head) / r271739 (stable/10). The
-# latter happened shortly before 10.1 was branched.
-.if ${ARCH} == i386 && ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000 && \
- ( ${COMPILER_TYPE} == clang || ${ALT_COMPILER_TYPE} == clang )
-BUILD_DEPENDS+= clang34:lang/clang34
-CPP= ${LOCALBASE}/bin/clang-cpp34
-CC= ${LOCALBASE}/bin/clang34
-CXX= ${LOCALBASE}/bin/clang++34
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g' \
${WRKSRC}/configure
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index b4d1377d5f51..cc43c09f47c3 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -34,12 +34,6 @@ CONFLICTS_INSTALL= luminance-hdr-[0-9]*
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1000024
-USE_GCC= yes
-.endif
-
post-patch:
# Do not install yet another copy of GPL (we use license framework instead)
# and fix installation path for docs (but not for internal help files)
@@ -60,4 +54,4 @@ post-patch:
pre-install:
QT_BINDIR_REL=bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/openshadinglanguage/Makefile b/graphics/openshadinglanguage/Makefile
index 06b339af73cb..8d7f56ca7395 100644
--- a/graphics/openshadinglanguage/Makefile
+++ b/graphics/openshadinglanguage/Makefile
@@ -34,12 +34,6 @@ USES= bison cmake:outsource compiler:c11
USE_GCC= yes
.endif
-.if ${OSVERSION} < 1000033
-BUILD_DEPENDS+= flex>=2.5.37:textproc/flex
-CMAKE_ARGS+= -DFLEX_EXECUTABLE:STRING=${LOCALBASE}/bin/flex
-CXXFLAGS+= -I${LOCALBASE}/include/flex
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' \
${WRKSRC}/src/liboslexec/serialize-bc.bash