aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
committermat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
commit0691688a506fc2dffc574eeeb80dc0d876378fed (patch)
tree204c01c7973e83331fc29d8b09e59b3e9f219bd6 /graphics
parent33639ffbb666f12097ddeff5ef7da2226febf15b (diff)
downloadfreebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.gz
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.zst
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.zip
Remove OSVERSION checks that do not make sense any more.
For example (${OSVERSION} >= 900000 && ${OSVERSION} < 900021) is always true, as is (${OSVERSION} > 900002 || ${OSVERSION} < 900000 && ${OSVERSION} > 800107). Regarding patches, when an EXTRA_PATCHES is no longer needed, I remove it, when it is always needed, I renamed it, in one case, I merged two patches. Differential Revision: https://reviews.freebsd.org/D2209
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aaphoto/Makefile3
-rw-r--r--graphics/rubygem-objectdetect/Makefile8
-rw-r--r--graphics/s10sh/files/Makefile.bsd7
3 files changed, 2 insertions, 16 deletions
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
index c1b253b15ad2..92c79a85bbd6 100644
--- a/graphics/aaphoto/Makefile
+++ b/graphics/aaphoto/Makefile
@@ -30,8 +30,7 @@ PLIST_FILES= bin/aaphoto
.include <bsd.port.pre.mk>
-.if (${ARCH} == "amd64" || ${ARCH} == "i386") && ${OSVERSION} >= 700000 && \
- ${COMPILER_TYPE} == gcc
+.if (${ARCH} == "amd64" || ${ARCH} == "i386") && ${COMPILER_TYPE} == gcc
CFLAGS+= -fopenmp -D__OPENMP__
.endif
diff --git a/graphics/rubygem-objectdetect/Makefile b/graphics/rubygem-objectdetect/Makefile
index fdbf91ea585b..53586cb290d6 100644
--- a/graphics/rubygem-objectdetect/Makefile
+++ b/graphics/rubygem-objectdetect/Makefile
@@ -19,13 +19,7 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
post-patch:
${REINPLACE_CMD} -E 's|(objectdetect)|\1/version|' ${WRKSRC}/test/test_helper.rb
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/s10sh/files/Makefile.bsd b/graphics/s10sh/files/Makefile.bsd
index aae2ceabc7e2..152728510d1a 100644
--- a/graphics/s10sh/files/Makefile.bsd
+++ b/graphics/s10sh/files/Makefile.bsd
@@ -7,14 +7,7 @@ LDADD += -lreadline -ltermcap ${LDFLAGS}
CFLAGS += -DHAVE_READLINE ${CPPFLAGS}
.if !defined(WITHOUT_USB)
-. if ${OSVERSION} < 800069
-USBLIB != ${LOCALBASE}/bin/libusb-config --libs
-LDADD += ${USBLIB}
-USBCF != ${LOCALBASE}/bin/libusb-config --cflags
-CFLAGS += ${USBCF} -DHAVE_USB_SUPPORT
-. else
LDADD += -lusb
-. endif
SRCS += usb.c
.endif