aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-01-26 09:45:13 +0800
committerchinsan <chinsan@FreeBSD.org>2008-01-26 09:45:13 +0800
commit095190a0f7e86450a998845351b66f7a065cb2d3 (patch)
treed5b42569b2288cee71022a31376db31d505080ab /graphics
parentb0c99234d78c19d4b43fa14cdaba6fd06ec67081 (diff)
downloadfreebsd-ports-gnome-095190a0f7e86450a998845351b66f7a065cb2d3.tar.gz
freebsd-ports-gnome-095190a0f7e86450a998845351b66f7a065cb2d3.tar.zst
freebsd-ports-gnome-095190a0f7e86450a998845351b66f7a065cb2d3.zip
A Perl implementation of the reCAPTCHA API.
From the recaptcha.net web site: reCAPTCHA improves the process of digitizing books by sending words that cannot be read by computers to the Web in the form of CAPTCHAs for humans to decipher. More specifically, each word that cannot be read correctly by OCR is placed on an image and used as a CAPTCHA. This is possible because most OCR programs alert you when a word cannot be read correctly. WWW: http://search.cpan.org/dist/Captcha-reCAPTCHA/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Captcha-reCAPTCHA/Makefile26
-rw-r--r--graphics/p5-Captcha-reCAPTCHA/distinfo3
-rw-r--r--graphics/p5-Captcha-reCAPTCHA/pkg-descr12
-rw-r--r--graphics/p5-Captcha-reCAPTCHA/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8f216ce6fbcc..7126f7cd311d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -460,6 +460,7 @@
SUBDIR += p5-CAD-Drawing
SUBDIR += p5-CAD-Drawing-Template
SUBDIR += p5-Cairo
+ SUBDIR += p5-Captcha-reCAPTCHA
SUBDIR += p5-Chart-Clicker
SUBDIR += p5-Chart-Graph
SUBDIR += p5-Chart-PNGgraph
diff --git a/graphics/p5-Captcha-reCAPTCHA/Makefile b/graphics/p5-Captcha-reCAPTCHA/Makefile
new file mode 100644
index 000000000000..5854793c7588
--- /dev/null
+++ b/graphics/p5-Captcha-reCAPTCHA/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Captcha-reCAPTCHA
+# Date created: 2008/01/26
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Captcha-reCAPTCHA
+PORTVERSION= 0.92
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AN/ANDYA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A Perl implementation of the reCAPTCHA API
+
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-HTML-Tiny>=0:${PORTSDIR}/textproc/p5-HTML-Tiny
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Captcha::reCAPTCHA.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Captcha-reCAPTCHA/distinfo b/graphics/p5-Captcha-reCAPTCHA/distinfo
new file mode 100644
index 000000000000..1a6bbaca7d37
--- /dev/null
+++ b/graphics/p5-Captcha-reCAPTCHA/distinfo
@@ -0,0 +1,3 @@
+MD5 (Captcha-reCAPTCHA-0.92.tar.gz) = 36b00fa37fd8a17367e1aa2f3b218f34
+SHA256 (Captcha-reCAPTCHA-0.92.tar.gz) = 2cef933d4ac104c9a15615d70e59009be207e4c2022acfc244fface4db76a0ba
+SIZE (Captcha-reCAPTCHA-0.92.tar.gz) = 8461
diff --git a/graphics/p5-Captcha-reCAPTCHA/pkg-descr b/graphics/p5-Captcha-reCAPTCHA/pkg-descr
new file mode 100644
index 000000000000..3cf61851336d
--- /dev/null
+++ b/graphics/p5-Captcha-reCAPTCHA/pkg-descr
@@ -0,0 +1,12 @@
+This is a Perl implementation of the reCAPTCHA API.
+
+From the recaptcha.net web site:
+
+reCAPTCHA improves the process of digitizing books by sending words that
+cannot be read by computers to the Web in the form of CAPTCHAs for
+humans to decipher. More specifically, each word that cannot be read
+correctly by OCR is placed on an image and used as a CAPTCHA. This is
+possible because most OCR programs alert you when a word cannot be read
+correctly.
+
+WWW: http://search.cpan.org/dist/Captcha-reCAPTCHA/
diff --git a/graphics/p5-Captcha-reCAPTCHA/pkg-plist b/graphics/p5-Captcha-reCAPTCHA/pkg-plist
new file mode 100644
index 000000000000..4aee7668001a
--- /dev/null
+++ b/graphics/p5-Captcha-reCAPTCHA/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Captcha/reCAPTCHA/.packlist
+%%SITE_PERL%%/Captcha/reCAPTCHA.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Captcha/reCAPTCHA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Captcha
+@dirrmtry %%SITE_PERL%%/Captcha