aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2016-01-28 09:58:50 +0800
committergrog <grog@FreeBSD.org>2016-01-28 09:58:50 +0800
commit0ce1496ad33f9eb3659f77c061befb29f8ad65f5 (patch)
treecc7d85f107c76ebb3631c877ddbcba8a3411d6f3 /graphics
parent86f1a0cdd9171e441aa4efe028ba2020a25f83fb (diff)
downloadfreebsd-ports-gnome-0ce1496ad33f9eb3659f77c061befb29f8ad65f5.tar.gz
freebsd-ports-gnome-0ce1496ad33f9eb3659f77c061befb29f8ad65f5.tar.zst
freebsd-ports-gnome-0ce1496ad33f9eb3659f77c061befb29f8ad65f5.zip
Tidy up:
- Remove unused dependencies on lensfun and tclap. - Clean up unneeded cmake patching. - Relax compiler restrictions. - Make python optional. - Modernize options handling. - Sort plist. This is basically what was submitted in PR 204973. It's not clear whether it's a good idea to make python optional, but Hugin works without it. PR: 204973 Submitted by: Dmitry Marakasov Approved by: edwin (mentor) MFC after: 2 weeks
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hugin/Makefile64
-rw-r--r--graphics/hugin/pkg-plist194
2 files changed, 114 insertions, 144 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 03b2dc952d4c..39b70964effb 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hugin
PORTVERSION= 2015.0.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -14,68 +14,38 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libImath.so:${PORTSDIR}/graphics/ilmbase \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
- liblensfun.so:${PORTSDIR}/graphics/lensfun \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
libpano13.so:${PORTSDIR}/graphics/libpano13 \
libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libvigraimpex.so:${PORTSDIR}/graphics/vigra \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
-BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20 \
- tclap>=1.2.1:${PORTSDIR}/devel/tclap
# gmake is really needed at _runtime_. Do not remove it from this list.
RUN_DEPENDS= enblend>=3.1.r20080615:${PORTSDIR}/graphics/enblend \
exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool \
gmake:${PORTSDIR}/devel/gmake
-OPTIONS_DEFINE= PANOMATIC AUTOPANOSIFTC
-OPTIONS_DEFAULT= PANOMATIC AUTOPANOSIFTC
-PANOMATIC_DESC= Install graphics/panomatic
-AUTOPANOSIFTC_DESC= Install graphics/autopano-sift-c
-
-USES= cmake gettext jpeg pkgconfig tar:bzip2 desktop-file-utils python \
- shared-mime-info compiler:features
-
+USES= cmake compiler:c++11-lib desktop-file-utils \
+ gettext jpeg pkgconfig shared-mime-info tar:bzip2
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
-
USE_WX= 2.8+
-WX_UNICODE= yes
-
USE_GL= glew glut
-
INSTALLS_ICONS= yes
-.include <bsd.port.pre.mk>
-
-# If default compiler is GCC, upgrade it because
-# g++ 4.2 is too old. Basically, use the same compiler as graphics/OpenEXR
-# see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=197898
-.if ${COMPILER_TYPE} == gcc
-USE_GCC= yes
-.endif
+OPTIONS_DEFINE= PANOMATIC AUTOPANOSIFTC PYTHON
+OPTIONS_DEFAULT= PANOMATIC AUTOPANOSIFTC PYTHON
+OPTIONS_SUB= yes
-# work around a bug in cmake (?). Without this we get an error like:
-# cd /usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1/base_wx && /usr/bin/c++ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -D_THREAD_SAFE -O2 -fno-strict-aliasing -pipe -pthread;-D_THREAD_SAFE -O3 -DNDEBUG -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin_base -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/foreign -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/foreign/vigra -I/usr/local/include -I/usr/local/include/OpenEXR -isystem /usr/local/lib/wx/include/gtk2-ansi-release-2.8 -isystem /usr/local/include/wx-2.8 -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1 -o CMakeFiles/huginbasewx.dir/ImageCache.o -c /usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1/base_wx/ImageCache.cpp
-# c++: No input files specified
-# with cmake 2.6.0. It works with cmake 2.4.8.
-post-configure:
- ${REINPLACE_CMD} \
- 's/-pthread;-D_THREAD_SAFE/-pthread -D_THREAD_SAFE/g' \
- ${WRKSRC}/src/hugin1/base_wx/CMakeFiles/huginbasewx.dir/flags.make \
- ${WRKSRC}/src/hugin1/hugin/CMakeFiles/hugin.dir/flags.make \
- ${WRKSRC}/src/hugin1/hugin/CMakeFiles/hugin.dir/link.txt \
- ${WRKSRC}/src/hugin1/ptbatcher/CMakeFiles/PTBatcherGUI.dir/flags.make \
- ${WRKSRC}/src/hugin1/ptbatcher/CMakeFiles/PTBatcherGUI.dir/link.txt \
- ${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/flags.make \
- ${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/link.txt
+PANOMATIC_DESC= Install graphics/panomatic
+PANOMATIC_RUN_DEPENDS= panomatic:${PORTSDIR}/graphics/panomatic
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPANOMATIC}
-RUN_DEPENDS+= panomatic:${PORTSDIR}/graphics/panomatic
-.endif
+AUTOPANOSIFTC_DESC= Install graphics/autopano-sift-c
+AUTOPANOSIFTC_RUN_DEPENDS= autopano:${PORTSDIR}/graphics/autopano-sift-c
-.if ${PORT_OPTIONS:MAUTOPANOSIFTC}
-RUN_DEPENDS+= autopano:${PORTSDIR}/graphics/autopano-sift-c
-.endif
+PYTHON_DESC= Python Scripting Interface
+PYTHON_USES= python
+PYTHON_BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20
+PYTHON_CMAKE_ON= -DBUILD_HSI=ON
+PYTHON_CMAKE_OFF= -DBUILD_HSI=OFF
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/hugin/pkg-plist b/graphics/hugin/pkg-plist
index a3a525ba2b21..bafbdf265ed1 100644
--- a/graphics/hugin/pkg-plist
+++ b/graphics/hugin/pkg-plist
@@ -30,12 +30,15 @@ bin/tca_correct
bin/verdandi
bin/vig_optimize
lib/hugin/libceleste.so.0.0
-lib/hugin/libhugin_python_interface.so.0.0
+%%PYTHON%%lib/hugin/libhugin_python_interface.so.0.0
lib/hugin/libhuginbase.so.0.0
lib/hugin/libhuginbasewx.so.0.0
lib/hugin/libhuginlines.so.0.0
lib/hugin/libicpfindlib.so.0.0
lib/hugin/liblocalfeatures.so.0.0
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/_hsi.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/hpi.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/hsi.py
man/man1/PTBatcherGUI.1.gz
man/man1/align_image_stack.1.gz
man/man1/autooptimiser.1.gz
@@ -67,112 +70,54 @@ man/man1/pto_var.1.gz
man/man1/tca_correct.1.gz
man/man1/verdandi.1.gz
man/man1/vig_optimize.1.gz
+share/appdata/PTBatcherGUI.appdata.xml
+share/appdata/calibrate_lens_gui.appdata.xml
+share/appdata/hugin.appdata.xml
share/applications/PTBatcherGUI.desktop
share/applications/calibrate_lens_gui.desktop
share/applications/hugin.desktop
share/applications/pto_gen.desktop
%%DATADIR%%/data/celeste.model
-%%DATADIR%%/data/plugins/shooting_pattern.py
-%%DATADIR%%/data/plugins/top_five.py
-%%DATADIR%%/data/plugins/woa.py
-%%DATADIR%%/data/plugins/crop_cp.py
-%%DATADIR%%/data/plugins/README_woa.txt
-%%DATADIR%%/data/plugins-templates/dual_use.py
-%%DATADIR%%/data/plugins-templates/plugin_skeleton.py
-%%DATADIR%%/data/hugin_exiftool_copy.arg
%%DATADIR%%/data/default.setting
-%%DATADIR%%/xrc/lenscal_frame.xrc
-%%DATADIR%%/xrc/optimize_panel.xrc
-%%DATADIR%%/xrc/lensdb_dialogs.xrc
-%%DATADIR%%/xrc/preview_frame.xrc
-%%DATADIR%%/xrc/main_tool.xrc
-%%DATADIR%%/xrc/cp_list_frame.xrc
-%%DATADIR%%/xrc/image_variable_dlg.xrc
+%%DATADIR%%/data/hugin_exiftool_copy.arg
+%%PYTHON%%%%DATADIR%%/data/plugins-templates/dual_use.py
+%%PYTHON%%%%DATADIR%%/data/plugins-templates/plugin_skeleton.py
+%%PYTHON%%%%DATADIR%%/data/plugins/README_woa.txt
+%%PYTHON%%%%DATADIR%%/data/plugins/crop_cp.py
+%%PYTHON%%%%DATADIR%%/data/plugins/shooting_pattern.py
+%%PYTHON%%%%DATADIR%%/data/plugins/top_five.py
+%%PYTHON%%%%DATADIR%%/data/plugins/woa.py
+%%DATADIR%%/xrc/about.xrc
+%%DATADIR%%/xrc/batch_frame.xrc
%%DATADIR%%/xrc/batch_menu.xrc
+%%DATADIR%%/xrc/batch_toolbar.xrc
%%DATADIR%%/xrc/cp_editor_panel.xrc
+%%DATADIR%%/xrc/cp_list_frame.xrc
%%DATADIR%%/xrc/cpdetector_dialog.xrc
-%%DATADIR%%/xrc/main_frame.xrc
-%%DATADIR%%/xrc/mask_editor_panel.xrc
-%%DATADIR%%/xrc/optimize_photo_panel.xrc
-%%DATADIR%%/xrc/main_menu.xrc
-%%DATADIR%%/xrc/pano_panel.xrc
-%%DATADIR%%/xrc/batch_frame.xrc
-%%DATADIR%%/xrc/dlg_warning.xrc
-%%DATADIR%%/xrc/about.xrc
-%%DATADIR%%/xrc/pref_dialog.xrc
-%%DATADIR%%/xrc/reset_dialog.xrc
-%%DATADIR%%/xrc/images_panel.xrc
-%%DATADIR%%/xrc/batch_toolbar.xrc
-%%DATADIR%%/xrc/edit_script_dialog.xrc
+%%DATADIR%%/xrc/data/COPYING
+%%DATADIR%%/xrc/data/about.htm
+%%DATADIR%%/xrc/data/add_project.png
+%%DATADIR%%/xrc/data/add_projects.png
+%%DATADIR%%/xrc/data/autocrop_tool.png
+%%DATADIR%%/xrc/data/center_pano.png
+%%DATADIR%%/xrc/data/crop_tool.png
+%%DATADIR%%/xrc/data/crop_tool_small.png
%%DATADIR%%/xrc/data/dedication.htm
-%%DATADIR%%/xrc/data/sponsors.htm
-%%DATADIR%%/xrc/data/intro.htm
-%%DATADIR%%/xrc/data/keyboard_pl.html
-%%DATADIR%%/xrc/data/ptbatcher.ico
-%%DATADIR%%/xrc/data/hugin.ico
-%%DATADIR%%/xrc/data/pto_icon.ico
-%%DATADIR%%/xrc/data/filenew.png
+%%DATADIR%%/xrc/data/drag_tool.png
+%%DATADIR%%/xrc/data/drag_tool_small.png
+%%DATADIR%%/xrc/data/druid.control.128.png
+%%DATADIR%%/xrc/data/druid.images.128.png
%%DATADIR%%/xrc/data/druid.lenses.128.png
-%%DATADIR%%/xrc/data/optimize.png
-%%DATADIR%%/xrc/data/stop.png
+%%DATADIR%%/xrc/data/druid.optimize.128.png
%%DATADIR%%/xrc/data/druid.stitch.128.png
-%%DATADIR%%/xrc/data/preview_num_transform.png
-%%DATADIR%%/xrc/data/identify_tool.png
%%DATADIR%%/xrc/data/edit_add.png
-%%DATADIR%%/xrc/data/preview_show_none.png
-%%DATADIR%%/xrc/data/druid.optimize.128.png
-%%DATADIR%%/xrc/data/filesaveas.png
-%%DATADIR%%/xrc/data/splash.png
-%%DATADIR%%/xrc/data/preview_layout_small.png
+%%DATADIR%%/xrc/data/filenew.png
%%DATADIR%%/xrc/data/fileopen.png
-%%DATADIR%%/xrc/data/drag_tool_small.png
-%%DATADIR%%/xrc/data/gl_preview.png
-%%DATADIR%%/xrc/data/straighten_pano.png
-%%DATADIR%%/xrc/data/autocrop_tool.png
-%%DATADIR%%/xrc/data/output_hdr.png
-%%DATADIR%%/xrc/data/crop_tool.png
-%%DATADIR%%/xrc/data/photometric.png
-%%DATADIR%%/xrc/data/preview_show_all.png
-%%DATADIR%%/xrc/data/undo.png
-%%DATADIR%%/xrc/data/preview_white_balance.png
-%%DATADIR%%/xrc/data/drag_tool.png
-%%DATADIR%%/xrc/data/transparent.png
-%%DATADIR%%/xrc/data/hugin.png
-%%DATADIR%%/xrc/data/reload.png
-%%DATADIR%%/xrc/data/preview_control_point_tool.png
-%%DATADIR%%/xrc/data/gl_preview_small.png
%%DATADIR%%/xrc/data/filesave.png
-%%DATADIR%%/xrc/data/remove_project.png
-%%DATADIR%%/xrc/data/info.png
-%%DATADIR%%/xrc/data/output_normal.png
-%%DATADIR%%/xrc/data/pto_icon.png
-%%DATADIR%%/xrc/data/output_blended_fused.png
-%%DATADIR%%/xrc/data/list.png
-%%DATADIR%%/xrc/data/start.png
-%%DATADIR%%/xrc/data/crop_tool_small.png
-%%DATADIR%%/xrc/data/pause.png
-%%DATADIR%%/xrc/data/center_pano.png
-%%DATADIR%%/xrc/data/logo.png
-%%DATADIR%%/xrc/data/preview_auto_update.png
-%%DATADIR%%/xrc/data/preview_white_balance_small.png
-%%DATADIR%%/xrc/data/druid.images.128.png
-%%DATADIR%%/xrc/data/druid.control.128.png
-%%DATADIR%%/xrc/data/preview.png
+%%DATADIR%%/xrc/data/filesaveas.png
%%DATADIR%%/xrc/data/fit_pano.png
-%%DATADIR%%/xrc/data/add_project.png
-%%DATADIR%%/xrc/data/identify_tool_small.png
-%%DATADIR%%/xrc/data/add_projects.png
-%%DATADIR%%/xrc/data/redo.png
-%%DATADIR%%/xrc/data/hugin_small.png
-%%DATADIR%%/xrc/data/ptbatcher.png
-%%DATADIR%%/xrc/data/preview_layout.png
-%%DATADIR%%/xrc/data/output_fused_blended.png
-%%DATADIR%%/xrc/data/skip.png
-%%DATADIR%%/xrc/data/preview_control_point_tool_small.png
-%%DATADIR%%/xrc/data/tips.txt
-%%DATADIR%%/xrc/data/upstream.txt
-%%DATADIR%%/xrc/data/about.htm
-%%DATADIR%%/xrc/data/COPYING
+%%DATADIR%%/xrc/data/gl_preview.png
+%%DATADIR%%/xrc/data/gl_preview_small.png
%%DATADIR%%/xrc/data/help_en_EN/100px-Big_ben_transverse_mercator.jpg
%%DATADIR%%/xrc/data/help_en_EN/100px-PC_img01.jpg
%%DATADIR%%/xrc/data/help_en_EN/100px-PC_img02.jpg
@@ -642,9 +587,67 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_it_IT/Yaw.html
%%DATADIR%%/xrc/data/help_it_IT/Zenith.html
%%DATADIR%%/xrc/data/help_it_IT/license.html
-%%PYTHON_SITELIBDIR%%/hpi.py
-%%PYTHON_SITELIBDIR%%/hsi.py
-%%PYTHON_SITELIBDIR%%/_hsi.so
+%%DATADIR%%/xrc/data/hugin.ico
+%%DATADIR%%/xrc/data/hugin.png
+%%DATADIR%%/xrc/data/hugin_small.png
+%%DATADIR%%/xrc/data/identify_tool.png
+%%DATADIR%%/xrc/data/identify_tool_small.png
+%%DATADIR%%/xrc/data/info.png
+%%DATADIR%%/xrc/data/intro.htm
+%%DATADIR%%/xrc/data/keyboard_pl.html
+%%DATADIR%%/xrc/data/list.png
+%%DATADIR%%/xrc/data/logo.png
+%%DATADIR%%/xrc/data/optimize.png
+%%DATADIR%%/xrc/data/output_blended_fused.png
+%%DATADIR%%/xrc/data/output_fused_blended.png
+%%DATADIR%%/xrc/data/output_hdr.png
+%%DATADIR%%/xrc/data/output_normal.png
+%%DATADIR%%/xrc/data/pause.png
+%%DATADIR%%/xrc/data/photometric.png
+%%DATADIR%%/xrc/data/preview.png
+%%DATADIR%%/xrc/data/preview_auto_update.png
+%%DATADIR%%/xrc/data/preview_control_point_tool.png
+%%DATADIR%%/xrc/data/preview_control_point_tool_small.png
+%%DATADIR%%/xrc/data/preview_layout.png
+%%DATADIR%%/xrc/data/preview_layout_small.png
+%%DATADIR%%/xrc/data/preview_num_transform.png
+%%DATADIR%%/xrc/data/preview_show_all.png
+%%DATADIR%%/xrc/data/preview_show_none.png
+%%DATADIR%%/xrc/data/preview_white_balance.png
+%%DATADIR%%/xrc/data/preview_white_balance_small.png
+%%DATADIR%%/xrc/data/ptbatcher.ico
+%%DATADIR%%/xrc/data/ptbatcher.png
+%%DATADIR%%/xrc/data/pto_icon.ico
+%%DATADIR%%/xrc/data/pto_icon.png
+%%DATADIR%%/xrc/data/redo.png
+%%DATADIR%%/xrc/data/reload.png
+%%DATADIR%%/xrc/data/remove_project.png
+%%DATADIR%%/xrc/data/skip.png
+%%DATADIR%%/xrc/data/splash.png
+%%DATADIR%%/xrc/data/sponsors.htm
+%%DATADIR%%/xrc/data/start.png
+%%DATADIR%%/xrc/data/stop.png
+%%DATADIR%%/xrc/data/straighten_pano.png
+%%DATADIR%%/xrc/data/tips.txt
+%%DATADIR%%/xrc/data/transparent.png
+%%DATADIR%%/xrc/data/undo.png
+%%DATADIR%%/xrc/data/upstream.txt
+%%DATADIR%%/xrc/dlg_warning.xrc
+%%DATADIR%%/xrc/edit_script_dialog.xrc
+%%DATADIR%%/xrc/image_variable_dlg.xrc
+%%DATADIR%%/xrc/images_panel.xrc
+%%DATADIR%%/xrc/lenscal_frame.xrc
+%%DATADIR%%/xrc/lensdb_dialogs.xrc
+%%DATADIR%%/xrc/main_frame.xrc
+%%DATADIR%%/xrc/main_menu.xrc
+%%DATADIR%%/xrc/main_tool.xrc
+%%DATADIR%%/xrc/mask_editor_panel.xrc
+%%DATADIR%%/xrc/optimize_panel.xrc
+%%DATADIR%%/xrc/optimize_photo_panel.xrc
+%%DATADIR%%/xrc/pano_panel.xrc
+%%DATADIR%%/xrc/pref_dialog.xrc
+%%DATADIR%%/xrc/preview_frame.xrc
+%%DATADIR%%/xrc/reset_dialog.xrc
share/icons/gnome/48x48/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
share/locale/ca_ES/LC_MESSAGES/hugin.mo
share/locale/ca_ES@valencia/LC_MESSAGES/hugin.mo
@@ -671,6 +674,3 @@ share/locale/zh_TW/LC_MESSAGES/hugin.mo
share/mime/packages/hugin.xml
share/pixmaps/hugin.png
share/pixmaps/ptbatcher.png
-share/appdata/PTBatcherGUI.appdata.xml
-share/appdata/calibrate_lens_gui.appdata.xml
-share/appdata/hugin.appdata.xml