aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-26 00:29:17 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-26 00:29:17 +0800
commit1081e090d5f5144eee782ae7160c163e9e9da305 (patch)
tree18579be0a668ba7c0b5bcc4143795d94400bbf42 /graphics
parent13425b9ed70a1b295d76d0be7ae87fda3c8a135b (diff)
downloadfreebsd-ports-gnome-1081e090d5f5144eee782ae7160c163e9e9da305.tar.gz
freebsd-ports-gnome-1081e090d5f5144eee782ae7160c163e9e9da305.tar.zst
freebsd-ports-gnome-1081e090d5f5144eee782ae7160c163e9e9da305.zip
Add USES=compiler:c++11-lang.
This fixes digikam-kde4's build on 9.3 after the graphics/lensfun update in r411373. lensfun.h includes C++ code (class and template declarations) inside an extern "C" block that causes base GCC to fail: /usr/local/include/lensfun/lensfun.h:2506: error: template with C linkage /usr/local/include/lensfun/lensfun.h:2508: error: template with C linkage
Diffstat (limited to 'graphics')
-rw-r--r--graphics/digikam-kde4/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index c76a754eefa8..72a2439ad7b5 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -24,7 +24,9 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libkgeomap.so:${PORTSDIR}/astro/libkgeomap \
libboost_graph.so:${PORTSDIR}/devel/boost-libs
-USES+= pkgconfig shebangfix
+# compiler:c++11-lang is necessary because graphics/lensfun's lensfun.h
+# contains C++ code inside an extern "C" block that base GCC cannot handle.
+USES+= compiler:c++11-lang pkgconfig shebangfix
USE_KDE4+= libkdcraw libkexiv2 libkipi
USE_QT4+= sql-sqlite3_run
USE_LDCONFIG= yes