aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-01-27 00:30:12 +0800
committerjohans <johans@FreeBSD.org>2013-01-27 00:30:12 +0800
commit1c4c11c1cacdc91d3fc4f1d8e030d0bd7f2ecb93 (patch)
treed541f006c5b8d7d17d7c9339c5fc1ea08be610d2 /graphics
parente022c7e8e31c9c2b9e9192a83144d48578044c42 (diff)
downloadfreebsd-ports-gnome-1c4c11c1cacdc91d3fc4f1d8e030d0bd7f2ecb93.tar.gz
freebsd-ports-gnome-1c4c11c1cacdc91d3fc4f1d8e030d0bd7f2ecb93.tar.zst
freebsd-ports-gnome-1c4c11c1cacdc91d3fc4f1d8e030d0bd7f2ecb93.zip
- Update xpaint to 2.9.9.3
- Remove some local patch files that are no longer needed
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpaint/Makefile25
-rw-r--r--graphics/xpaint/distinfo4
-rw-r--r--graphics/xpaint/files/patch-fileBrowser.c20
-rw-r--r--graphics/xpaint/files/patch-rw__readWritePNG.c23
-rw-r--r--graphics/xpaint/files/patch-rw_libpnmrw.c11
-rw-r--r--graphics/xpaint/files/patch-rw_readWriteICO.c10
6 files changed, 14 insertions, 79 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index 3e2a6807d5bb..8e66d7193265 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -1,15 +1,10 @@
-# New ports collection makefile for: xpaint
-# Date created: 2 Jan 1995
-# Whom: swallace
-#
+# Created by: swallace
# $FreeBSD$
-#
PORTNAME= xpaint
-PORTVERSION= 2.9.9
-PORTREVISION= 1
+PORTVERSION= 2.9.9.3
CATEGORIES= graphics
-MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
MAINTAINER= johans@FreeBSD.org
COMMENT= A simple paint program
@@ -17,13 +12,14 @@ COMMENT= A simple paint program
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
openjpeg:${PORTSDIR}/graphics/openjpeg \
- tiff.4:${PORTSDIR}/graphics/tiff \
- freetype.9:${PORTSDIR}/print/freetype2 \
- jbig.1:${PORTSDIR}/graphics/jbigkit \
- Xaw3dxft.7:${PORTSDIR}/x11-toolkits/libxaw3dxft
+ tiff:${PORTSDIR}/graphics/tiff \
+ freetype:${PORTSDIR}/print/freetype2 \
+ jbig:${PORTSDIR}/graphics/jbigkit \
+ Xaw3dxft:${PORTSDIR}/x11-toolkits/libxaw3dxft
USE_BZIP2= yes
USE_XORG= xft xmu xpm
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
@@ -33,14 +29,17 @@ MAKE_ENV+= RM="${RM} -f"
MAN1= xpaint.1 pdfconcat.1 imgmerge.1
post-extract:
- @${LN} -sf ${LOCALBASE}/include/X11/Xaw3dxft ${WRKSRC}/xaw_incdir
@${RM} -f ${WRKSRC}/XPaint.ad
post-patch:
@${REINPLACE_CMD} -e 's/-ldl //' \
${WRKSRC}/configure ${WRKSRC}/rw/configure
@${REINPLACE_CMD} -Ee 's:/etc(/X11/app-defaults):${PREFIX}/lib\1:' \
+ -e '/xaw_incdir/s,/usr/include,${LOCALBASE}/include,' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^LIBTOOL/d' \
+ -e '/^install-exec-am:/s/install-libLTLIBRARIES//' \
+ ${WRKSRC}/rw/Makefile.in
@${REINPLACE_CMD} -e '/if (!image)/s/return;/return -1;/' \
${WRKSRC}/rw/readWriteTGA.c
diff --git a/graphics/xpaint/distinfo b/graphics/xpaint/distinfo
index f38306df8c45..40a8a2893b03 100644
--- a/graphics/xpaint/distinfo
+++ b/graphics/xpaint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xpaint-2.9.9.tar.bz2) = 261a3fe356c2e32609cdb640e0ff8174117d82801290192ad191bdde57cc8696
-SIZE (xpaint-2.9.9.tar.bz2) = 1229047
+SHA256 (xpaint-2.9.9.3.tar.bz2) = 66e1d0a183290c0f399b1ca2f9770c6afd96e3002c64350a7f34b583157b953b
+SIZE (xpaint-2.9.9.3.tar.bz2) = 1279801
diff --git a/graphics/xpaint/files/patch-fileBrowser.c b/graphics/xpaint/files/patch-fileBrowser.c
deleted file mode 100644
index 716939706cc3..000000000000
--- a/graphics/xpaint/files/patch-fileBrowser.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- fileBrowser.c.orig 2010-04-28 17:02:11.000000000 +0900
-+++ fileBrowser.c 2010-05-29 13:23:51.000000000 +0900
-@@ -40,7 +40,7 @@
- #include <stdio.h>
- #include <sys/types.h>
- #include <sys/stat.h>
--#if defined(SYSV) || defined(SVR4) || defined(__CYGWIN__) || defined(__VMS )
-+#if defined(SYSV) || defined(SVR4) || defined(__CYGWIN__) || defined(__VMS ) || defined(__FreeBSD__)
- #include <dirent.h>
- #else
- #include <sys/dir.h>
-@@ -513,7 +513,7 @@
- setCWD(arg_t * arg, char *dir)
- {
- DIR *dirp;
--#if defined(SYSV) || defined(SVR4) || defined(__alpha) || defined(__CYGWIN__)
-+#if defined(SYSV) || defined(SVR4) || defined(__alpha) || defined(__CYGWIN__) || defined(__FreeBSD__)
- struct dirent *e;
- #else
- struct direct *e;
diff --git a/graphics/xpaint/files/patch-rw__readWritePNG.c b/graphics/xpaint/files/patch-rw__readWritePNG.c
deleted file mode 100644
index 94ab37daaa64..000000000000
--- a/graphics/xpaint/files/patch-rw__readWritePNG.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- rw/readWritePNG.c.orig 2010-05-14 06:24:49.000000000 +0900
-+++ rw/readWritePNG.c 2010-06-24 04:56:04.000000000 +0900
-@@ -10,16 +10,15 @@
- #include <stdlib.h>
- #include <png.h>
-
--typedef char *String;
--#include <messages.h>
--#include <image.h>
--#include "rwTable.h"
--
- #include <X11/Xlib.h>
- #include <X11/Intrinsic.h>
- #include "xpaint.h"
- #include "../version.h"
-
-+#include <messages.h>
-+#include <image.h>
-+#include "rwTable.h"
-+
- #ifndef TRUE
- # define TRUE 1
- # define FALSE 0
diff --git a/graphics/xpaint/files/patch-rw_libpnmrw.c b/graphics/xpaint/files/patch-rw_libpnmrw.c
deleted file mode 100644
index 3b150ebca7e4..000000000000
--- a/graphics/xpaint/files/patch-rw_libpnmrw.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- rw/libpnmrw.c.orig 2009-12-09 05:39:15.000000000 +0900
-+++ rw/libpnmrw.c 2010-05-29 13:26:56.000000000 +0900
-@@ -131,7 +131,7 @@
- static void
- pm_perror(char *reason)
- {
--#if !defined(__NetBSD__)
-+#if !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__NetBSD__)
- #if defined(BSD4_4)
- __const extern char *__const sys_errlist[];
- #else
diff --git a/graphics/xpaint/files/patch-rw_readWriteICO.c b/graphics/xpaint/files/patch-rw_readWriteICO.c
deleted file mode 100644
index 6d293717b580..000000000000
--- a/graphics/xpaint/files/patch-rw_readWriteICO.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- rw/readWriteICO.c.orig 2010-09-04 23:36:34.000000000 +0200
-+++ rw/readWriteICO.c 2010-09-04 23:37:10.000000000 +0200
-@@ -34,7 +34,6 @@
- #include <ctype.h>
- #include <sys/types.h>
- #include <sys/stat.h>
--#include <error.h>
- #include <errno.h>
- #include <getopt.h>
-