aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-11 07:37:17 +0800
committerpav <pav@FreeBSD.org>2005-02-11 07:37:17 +0800
commit1df17d9bd6a40bcde5d78b94960cf5e48c1c3e57 (patch)
treef42d3d35358278392b6c01d876e3b8bdf65b94b3 /graphics
parenta85e24e00c9b4739acbc50c8c23797668d4e9990 (diff)
downloadfreebsd-ports-gnome-1df17d9bd6a40bcde5d78b94960cf5e48c1c3e57.tar.gz
freebsd-ports-gnome-1df17d9bd6a40bcde5d78b94960cf5e48c1c3e57.tar.zst
freebsd-ports-gnome-1df17d9bd6a40bcde5d78b94960cf5e48c1c3e57.zip
- Update to 2.36
PR: ports/76325 Submitted by: David Yeske <dyeske@yahoo.com> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender-devel/Makefile9
-rw-r--r--graphics/blender-devel/distinfo4
-rw-r--r--graphics/blender-devel/files/patch-SConstruct141
3 files changed, 18 insertions, 136 deletions
diff --git a/graphics/blender-devel/Makefile b/graphics/blender-devel/Makefile
index 3a01ca2665b1..fd3c2218d36e 100644
--- a/graphics/blender-devel/Makefile
+++ b/graphics/blender-devel/Makefile
@@ -5,9 +5,11 @@
# $FreeBSD$
PORTNAME= blender
-PORTVERSION= 2.34
+PORTVERSION= 2.36
CATEGORIES= graphics games
-MASTER_SITES= http://download.blender.org/source/
+MASTER_SITES= http://public.planetmirror.com/pub/blender/source/ \
+ http://download.blender.org/source/ \
+ ftp://ftp.cs.umn.edu/pub/blender.org/source/
PKGNAMESUFFIX= -devel
MAINTAINER= dyeske@yahoo.com
@@ -20,7 +22,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
PLIST_FILES= bin/blender
USE_X_PREFIX= yes
-USE_BZIP2= yes
USE_REINPLACE= yes
USE_PYTHON= yes
USE_SDL= sdl
@@ -30,6 +31,8 @@ USE_GL= yes
CFLAGS+= -O3 -ffast-math
.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable additional compilation optimizations"
diff --git a/graphics/blender-devel/distinfo b/graphics/blender-devel/distinfo
index ec1de640baee..f95b71d94993 100644
--- a/graphics/blender-devel/distinfo
+++ b/graphics/blender-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (blender-2.34.tar.bz2) = dad5ac3d415abefad9c52f7b814339d8
-SIZE (blender-2.34.tar.bz2) = 5499297
+MD5 (blender-2.36.tar.gz) = 8e2237c86b12e6061935632495aec875
+SIZE (blender-2.36.tar.gz) = 6912828
diff --git a/graphics/blender-devel/files/patch-SConstruct b/graphics/blender-devel/files/patch-SConstruct
index 425c509e41c3..10097093308a 100644
--- a/graphics/blender-devel/files/patch-SConstruct
+++ b/graphics/blender-devel/files/patch-SConstruct
@@ -1,132 +1,11 @@
---- SConstruct.orig Thu Aug 5 00:00:39 2004
-+++ SConstruct Thu Oct 21 23:20:37 2004
-@@ -681,6 +681,86 @@
- openal_lib = ['openal']
- openal_libpath = ['/usr/lib']
- openal_include = ['/usr/include']
-+
-+elif sys.platform=='freebsd4' or sys.platform=='freebsd5' or sys.platform=='freebsd6':
-+ print "Building for FreeBSD"
-+ use_international = 'false'
-+ use_gameengine = 'false'
-+ use_openal = 'false'
-+ use_fmod = 'false'
-+ use_quicktime = 'false'
-+ use_sumo = 'false'
-+ use_ode = 'false'
-+ use_buildinfo = 'true'
-+ build_blender_dynamic = 'true'
-+ build_blender_static = 'false'
-+ build_blender_player = 'false'
-+ build_blender_plugin = 'false'
-+ release_flags = ['-O2']
-+ debug_flags = ['-O2', '-g']
-+ extra_flags = ['-pipe', '-fPIC', '-funsigned-char']
-+ cxxflags = []
-+ defines = []
-+ warn_flags = ['-Wall','-W']
-+ window_system = 'X11'
-+ platform_libs = ['m', 'stdc++', 'util']
-+ platform_libpath = []
-+ platform_linkflags = ['-pthread']
-+ extra_includes = []
-+ z_lib = ['z']
-+ z_libpath = ['/usr/lib']
-+ z_include = ['/usr/include']
-+ # png library information
-+ png_lib = ['png']
-+ png_libpath = ['/usr/local/lib']
-+ png_include = ['/usr/local/include']
-+ # jpeg library information
-+ jpeg_lib = ['jpeg']
-+ jpeg_libpath = ['/usr/local/lib']
-+ jpeg_include = ['/usr/local/include']
-+ # OpenGL library information
-+ opengl_lib = ['GL', 'GLU']
-+ opengl_static = ['/usr/lib/libGL.a', '/usr/lib/libGLU.a']
-+ opengl_libpath = ['/usr/lib', '/usr/X11R6/lib']
-+ opengl_include = ['/usr/X11R6/include/']
-+ # SDL library information
-+ sdl_env.ParseConfig ('sdl11-config --cflags')
-+ sdl_cflags = sdl_env.Dictionary()['CCFLAGS']
-+ sdl_include = sdl_env.Dictionary()['CPPPATH']
-+ sdl_env.ParseConfig ('sdl11-config --libs')
-+ sdl_libpath =sdl_env.Dictionary()['LIBPATH']
-+ sdl_lib = sdl_env.Dictionary()['LIBS']
-+ # SOLID library information
-+ solid_lib = [] # TODO
-+ solid_libpath = [] # TODO
-+ solid_include = ['#extern/solid']
-+ qhull_lib = [] # TODO
-+ qhull_libpath = [] # TODO
-+ qhull_include = ['#extern/qhull/include']
-+ # ODE library information
-+ ode_lib = ['ode']
-+ ode_libpath = ['#../lib/linux-glibc2.2.5-i386/ode/lib']
-+ ode_include = ['#../lib/linux-glibc2.2.5-i386/ode/include']
-+ # Python library information
-+ python_lib = ['python%d.%d' % sys.version_info[0:2]]
-+ python_libpath = [sysconfig.get_python_lib (0, 1) + '/config']
-+ python_include = [sysconfig.get_python_inc ()]
-+ python_linkflags = []
-+ # International support information
-+ ftgl_lib = ['ftgl']
-+ ftgl_libpath = ['#../lib/linux-glibc2.2.5-i386/ftgl/lib']
-+ ftgl_include = ['#../lib/linux-glibc2.2.5-i386/ftgl/include']
-+ freetype_env.ParseConfig('pkg-config --cflags --libs freetype2')
-+ freetype_lib = freetype_env.Dictionary()['LIBS']
-+ freetype_libpath = freetype_env.Dictionary()['LIBPATH']
-+ freetype_include = freetype_env.Dictionary()['CPPPATH']
-+ gettext_lib = []
-+ gettext_libpath = []
-+ gettext_include = []
-+ # OpenAL library information
-+ openal_lib = ['openal']
-+ openal_libpath = ['/usr/lib']
-+ openal_include = ['/usr/include']
-
- else:
- print "Unknown platform %s"%sys.platform
-@@ -1188,7 +1268,7 @@
- shutil.copy("../lib/windows/python/lib/python23.dll", "dist/python23.dll")
- shutil.copy("../lib/windows/sdl/lib/SDL.dll", "dist/SDL.dll")
- shutil.copy("../lib/windows/gettext/lib/gnu_gettext.dll", "dist/gnu_gettext.dll")
-- elif sys.platform in ['linux2', 'linux-i386']:
-+ elif sys.platform in ['linux2', 'linux-i386', 'freebsd4', 'freebsd5', 'freebsd6']:
- shutil.copy("blender", "dist/blender")
- if user_options_dict['BUILD_BLENDER_PLAYER'] == 1:
- shutil.copy("blenderplayer", "dist/blenderplayer")
-@@ -1376,6 +1456,15 @@
- elif sys.platform == 'linux2' or sys.platform == 'linux-i386':
- zipext += ".tar.gz"
- pf = "linux"
-+ elif sys.platform == 'freebsd4':
-+ zipext += ".tar.gz"
-+ pf = "freebsd4"
-+ elif sys.platform == 'freebsd5':
-+ zipext += ".tar.gz"
-+ pf = "freebsd5"
-+ elif sys.platform == 'freebsd6':
-+ zipext += ".tar.gz"
-+ pf = "freebsd6"
-
- if user_options_dict['BUILD_BINARY'] == 'release':
- blendname = "blender-" + version + "-" + config_guess
-@@ -1391,7 +1480,7 @@
- print
- if sys.platform == 'win32':
- print "Create the zip!"
-- elif sys.platform == 'linux2' or sys.platform == 'linux-i386':
-+ else:
- print "Create the tarball!"
- print
+--- SConstruct.orig Tue Dec 28 20:56:41 2004
++++ SConstruct Tue Dec 28 20:57:28 2004
+@@ -663,7 +663,7 @@
+ openal_libpath = ['/usr/lib']
+ openal_include = ['/usr/include']
-@@ -1601,7 +1690,7 @@
- if user_options_dict['BUILD_BLENDER_PLAYER'] == 1:
- app_env.Depends(Mappit, playername)
- app_env.Alias("release", Mappit)
-- elif sys.platform in ['win32', 'linux2', 'linux-i386']:
-+ elif sys.platform in ['win32', 'linux2', 'linux-i386', 'freebsd4', 'freebsd5', 'freebsd6']:
- release_env = Environment()
- releaseit = release_env.Command('blenderrelease', appname, zipit)
- if user_options_dict['BUILD_BLENDER_PLAYER'] == 1:
+-elif sys.platform=='freebsd4' or sys.platform=='freebsd5':
++elif sys.platform=='freebsd4' or sys.platform=='freebsd5' or sys.platform=='freebsd6':
+ print "Building for FreeBSD"
+ use_international = 'false'
+ use_gameengine = 'false'