aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2009-05-06 12:45:14 +0800
committeroliver <oliver@FreeBSD.org>2009-05-06 12:45:14 +0800
commit26d083ce7e16f27fff9c87688460375c5456ee6f (patch)
tree2ccfb5add5b669fbfb168851c9bd146892d72345 /graphics
parentfeadcc8b843537851ec001927668973988eda9c4 (diff)
downloadfreebsd-ports-gnome-26d083ce7e16f27fff9c87688460375c5456ee6f.tar.gz
freebsd-ports-gnome-26d083ce7e16f27fff9c87688460375c5456ee6f.tar.zst
freebsd-ports-gnome-26d083ce7e16f27fff9c87688460375c5456ee6f.zip
update to 1.6.2
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ogre3d/Makefile20
-rw-r--r--graphics/ogre3d/distinfo6
-rw-r--r--graphics/ogre3d/pkg-plist31
3 files changed, 33 insertions, 24 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 3e5fc3ef0190..76e2bad442e2 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= ogre3d
-PORTVERSION= 1.4.9
-PORTREVISION= 4
+PORTVERSION= 1.6.2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
-DISTNAME= ogre-v${PORTVERSION:S/./-/g}
+DISTNAME= ogre-v${PORTVERSION:S/./-/g:S/-r1/RC1/g}
MAINTAINER= oliver@FreeBSD.org
COMMENT= A scene-oriented, flexible 3D engine written in C++
@@ -51,7 +50,7 @@ CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include"
BUILD_DEPENDS+= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
RUN_DEPENDS+= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
.else
-CONGIGURE_ARGS+= --disable-ogre-demos
+CONGIGURE_ARGS+=--disable-ogre-demos
.endif
.if defined(WITH_GTK)
@@ -65,21 +64,12 @@ PLIST_SUB+= WITH_GTK="@comment "
post-patch:
@${REINPLACE_CMD} -e '\
- s|sdl-config|${SDL_CONFIG}|g; \
- s|-lpthread|${PTHREAD_LIBS}|g; \
+ s|-pthread|${PTHREAD_LIBS}|g; \
s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
s|-lGL -lGLU|-L${X11BASE}/lib &|g; \
s|" == "x|" = "x|g; \
s|-lfreeimage|-L${LOCALBASE}/lib &|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
- ${WRKSRC}/Samples/Gui/src/Gui.cpp \
- ${WRKSRC}/Samples/Common/CEGUIRenderer/include/OgreCEGUIResourceProvider.h \
- ${WRKSRC}/Samples/Common/CEGUIRenderer/include/OgreCEGUITexture.h \
- ${WRKSRC}/Samples/Common/CEGUIRenderer/include/OgreCEGUIRenderer.h \
- ${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUIRenderer.cpp \
- ${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUIResourceProvider.cpp \
- ${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUITexture.cpp
@${REINPLACE_CMD} -e 's| -Wl,-z,defs||' \
${WRKSRC}/PlugIns/BSPSceneManager/src/Makefile.in \
${WRKSRC}/PlugIns/CgProgramManager/src/Makefile.in \
@@ -87,7 +77,7 @@ post-patch:
${WRKSRC}/PlugIns/OctreeSceneManager/src/Makefile.in \
${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in \
${WRKSRC}/RenderSystems/GL/src/Makefile.in
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
@${REINPLACE_CMD} -e 's|(CEGUI::uint)|(size_t)|' \
${WRKSRC}/Samples/OceanDemo/src/OceanDemo.cpp
diff --git a/graphics/ogre3d/distinfo b/graphics/ogre3d/distinfo
index d41e29ad733f..17e37edb3891 100644
--- a/graphics/ogre3d/distinfo
+++ b/graphics/ogre3d/distinfo
@@ -1,3 +1,3 @@
-MD5 (ogre-v1-4-9.tar.bz2) = 8a73fbcf42fd6b156b2567839d0cd125
-SHA256 (ogre-v1-4-9.tar.bz2) = 38b17826b6b34e70bf1bab17d4791ab1d485409c938cf71e1e5f866f3391c35b
-SIZE (ogre-v1-4-9.tar.bz2) = 29555312
+MD5 (ogre-v1-6-2.tar.bz2) = 0f7e80fc255ad6ffe77151e4a08010be
+SHA256 (ogre-v1-6-2.tar.bz2) = bc43882d8fc0039d65e606cfc55a81f8cea6e6d95310975f89029d47cc964554
+SIZE (ogre-v1-6-2.tar.bz2) = 42822910
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index b24808e444ab..686969e9b3ac 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -1,18 +1,34 @@
bin/OgreMaterialUpgrade
bin/OgreMeshUpgrade
bin/OgreXMLConverter
+bin/rcapsdump
%%WITH_GTK%%include/OGRE/gtk/OgreConfigDialogImp.h
%%WITH_GTK%%include/OGRE/gtk/OgreErrorDialogImp.h
include/OGRE/GLX/OgreConfigDialogImp.h
include/OGRE/GLX/OgreErrorDialogImp.h
include/OGRE/GLX/OgreTimerImp.h
+include/OGRE/OgreAtomicWrappers.h
+include/OGRE/OgreMemoryAllocatedObject.h
+include/OGRE/OgreMemoryAllocatorConfig.h
+include/OGRE/OgreMemoryNedAlloc.h
+include/OGRE/OgreMemoryStdAlloc.h
+include/OGRE/OgreMemorySTLAllocator.h
+include/OGRE/OgreMemoryTracker.h
+include/OGRE/OgreRenderSystemCapabilitiesManager.h
+include/OGRE/OgreRenderSystemCapabilitiesSerializer.h
+include/OGRE/OgreRenderToVertexBuffer.h
+include/OGRE/OgreScriptCompiler.h
+include/OGRE/OgreScriptLexer.h
+include/OGRE/OgreScriptParser.h
+include/OGRE/OgreScriptTranslator.h
+include/OGRE/OgreShadowCameraSetupPSSM.h
+include/OGRE/OgreTangentSpaceCalc.h
include/OGRE/OgreAlignedAllocator.h
include/OGRE/OgreConvexBody.h
include/OGRE/OgreDDSCodec.h
include/OGRE/OgreFreeImageCodec.h
include/OGRE/OgreILUtil.h
include/OGRE/OgreInstancedGeometry.h
-include/OGRE/OgreMaterialScriptCompiler.h
include/OGRE/OgreNumerics.h
include/OGRE/OgrePlugin.h
include/OGRE/OgrePolygon.h
@@ -110,8 +126,6 @@ include/OGRE/OgreMaterialSerializer.h
include/OGRE/OgreMath.h
include/OGRE/OgreMatrix3.h
include/OGRE/OgreMatrix4.h
-include/OGRE/OgreMemoryMacros.h
-include/OGRE/OgreMemoryManager.h
include/OGRE/OgreMesh.h
include/OGRE/OgreMeshFileFormat.h
include/OGRE/OgreMeshManager.h
@@ -119,7 +133,6 @@ include/OGRE/OgreMeshSerializer.h
include/OGRE/OgreMeshSerializerImpl.h
include/OGRE/OgreMovableObject.h
include/OGRE/OgreMovablePlane.h
-include/OGRE/OgreNoMemoryMacros.h
include/OGRE/OgreNode.h
include/OGRE/OgreOptimisedUtil.h
include/OGRE/OgreOverlay.h
@@ -229,20 +242,26 @@ lib/OGRE/Plugin_BSPSceneManager.so
lib/OGRE/Plugin_OctreeSceneManager.a
lib/OGRE/Plugin_OctreeSceneManager.la
lib/OGRE/Plugin_OctreeSceneManager.so
+lib/OGRE/Plugin_OctreeZone.a
+lib/OGRE/Plugin_OctreeZone.la
+lib/OGRE/Plugin_OctreeZone.so
lib/OGRE/Plugin_ParticleFX.a
lib/OGRE/Plugin_ParticleFX.la
lib/OGRE/Plugin_ParticleFX.so
lib/OGRE/RenderSystem_GL.a
lib/OGRE/RenderSystem_GL.la
lib/OGRE/RenderSystem_GL.so
+lib/OGRE/libPlugin_PCZSceneManager.a
+lib/OGRE/libPlugin_PCZSceneManager.la
+lib/OGRE/libPlugin_PCZSceneManager.so
lib/libCEGUIOgreRenderer.a
lib/libCEGUIOgreRenderer.la
lib/libCEGUIOgreRenderer.so
-lib/libCEGUIOgreRenderer-1.4.9.so
+lib/libCEGUIOgreRenderer-1.6.2.so
lib/libOgreMain.a
lib/libOgreMain.la
lib/libOgreMain.so
-lib/libOgreMain-1.4.9.so
+lib/libOgreMain-1.6.2.so
libdata/pkgconfig/CEGUI-OGRE.pc
libdata/pkgconfig/OGRE.pc
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS