aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-01-06 06:57:40 +0800
committerkwm <kwm@FreeBSD.org>2013-01-06 06:57:40 +0800
commit2aab19633c74330198375fb1ee0b2e973fb47a7e (patch)
tree4a30b690095b7c3b36754f571aeca80a710febd6 /graphics
parent6687967dc590683e657a9a60cc81252d0750c79c (diff)
downloadfreebsd-ports-gnome-2aab19633c74330198375fb1ee0b2e973fb47a7e.tar.gz
freebsd-ports-gnome-2aab19633c74330198375fb1ee0b2e973fb47a7e.tar.zst
freebsd-ports-gnome-2aab19633c74330198375fb1ee0b2e973fb47a7e.zip
Convert x11@ owned ports to OptionsNG. Thanks go to bapt@ for review and help
rendered with deciphering the monster that is xorg-drivers. With hat: x11@
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libdrm/Makefile23
-rw-r--r--graphics/mesa-demos/Makefile20
2 files changed, 20 insertions, 23 deletions
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index c503232a0f77..1ff688d92a3d 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libdrm
-# Date created: 29 Dec 2005
-# Whom: lesi@FreeBSD.org
-#
+# Created by: lesi@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= libdrm
PORTVERSION= ${LIBDRM_VERSION}
@@ -15,8 +11,8 @@ MAINTAINER= x11@FreeBSD.org
COMMENT= Userspace interface to kernel Direct Rendering Module services
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
-LIB_DEPENDS= pciaccess.0:${PORTSDIR}/devel/libpciaccess \
- pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs
+LIB_DEPENDS= pciaccess:${PORTSDIR}/devel/libpciaccess \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:${PORTSDIR}/devel/libpthread-stubs
USE_BZIP2= yes
@@ -29,11 +25,12 @@ MAKE_JOBS_SAFE= yes
.if defined(WITH_NEW_XORG)
-OPTIONS= KMS "Enable KMS support (very experimental)" off
+OPTIONS_DEFINE= KMS
+KMS_DESC= Enable experimental KMS support
.include <bsd.port.options.mk>
-.if defined(WITH_KMS)
+.if ${PORT_OPTIONS:MKMS}
CONFIGURE_ARGS+=--enable-libkms
EXTRA_PATCHES+= ${FILESDIR}/extra-xf86drmMode.c
PLIST_SUB+= KMS=""
@@ -53,11 +50,11 @@ PLIST_SUB+= OLD="" NEW="@comment "
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "i386" || ${ARCH} == "ia64" || ${ARCH} == "powerpc"
-PLIST_SUB+= INTEL_DRIVER=""
-PLIST_SUB+= RADEON_DRIVERS=""
+PLIST_SUB+= INTEL_DRIVER=""
+PLIST_SUB+= RADEON_DRIVERS=""
.else
-PLIST_SUB+= INTEL_DRIVER="@comment "
-PLIST_SUB+= RADEON_DRIVERS="@comment "
+PLIST_SUB+= INTEL_DRIVER="@comment "
+PLIST_SUB+= RADEON_DRIVERS="@comment "
.endif
pre-patch:
diff --git a/graphics/mesa-demos/Makefile b/graphics/mesa-demos/Makefile
index 8c4ce1b134f1..2991acebecea 100644
--- a/graphics/mesa-demos/Makefile
+++ b/graphics/mesa-demos/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mesa-demos
-# Date created: 7 Nov 2003
-# Whom: anholt@FreeBSD.org
-#
+# Created by: anholt@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= mesa-demos
PORTVERSION= 7.6.1
@@ -33,12 +29,16 @@ WRKSRC= ${WRKDIR}/Mesa-${PORTVERSION}/
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
-OPTIONS= NVIDIA_GL "Use NVIDIA's libraries" off
+OPTIONS_DEFINE= NVIDIA_GL XCB
+NVIDIA_DESC= Use NVIDIA's libraries
+XCB_DESC= Use XCB for GLX
-.if defined(WITHOUT_XCB)
-CONFIGURE_ARGS+= --disable-xcb
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MXCB}
CONFIGURE_ARGS+= --enable-xcb
+.else
+CONFIGURE_ARGS+= --disable-xcb
.endif
post-patch:
@@ -77,7 +77,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if defined(WITH_NVIDIA_GL)
+.if ${PORT_OPTIONS:MNVIDIA_GL}
CFLAGS+= -DWITH_NVIDIA_GL=1
.endif