aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-08-22 03:45:30 +0800
committerpi <pi@FreeBSD.org>2016-08-22 03:45:30 +0800
commit370b5eb5ea70af28ba58bbfb8fbc8b3a13c84e22 (patch)
tree1fd26315e6e3794a325284e472252708f8eb1460 /graphics
parent5b82d984479d3c2bab670fc05c02a19549915ae3 (diff)
downloadfreebsd-ports-gnome-370b5eb5ea70af28ba58bbfb8fbc8b3a13c84e22.tar.gz
freebsd-ports-gnome-370b5eb5ea70af28ba58bbfb8fbc8b3a13c84e22.tar.zst
freebsd-ports-gnome-370b5eb5ea70af28ba58bbfb8fbc8b3a13c84e22.zip
graphics/zathura: fix -x option
- fix it by adding some additional LIB_DEPENDS and a CPP flag for SYNCTEX PR: 211468 Submitted by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> Reported by: freebsd@schukraft.org Approved by: quentin.stievenart@gmail.com (maintainer timeout)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zathura/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 044f2c325d2d..e0eb0b33d6a8 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -13,15 +13,21 @@ LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcairo.so:graphics/cairo \
- libgirara-gtk3.so:x11-toolkits/girara
+ libgirara-gtk3.so:x11-toolkits/girara \
+ libmagic.so:sysutils/file \
+ libsynctex.so:devel/tex-synctex
+
BUILD_DEPENDS+= rst2html:textproc/py-docutils
-USE_GNOME= glib20 gtk30
+USE_GNOME= glib20 gtk30 gdkpixbuf2
USES= compiler:c11 gmake pkgconfig
MAKE_ENV= SFLAGS="${STRIP}" \
RSTTOMAN=${LOCALBASE}/bin/rst2man \
ZLIB_INC= \
- ZLIB_LIB=-lz
+ ZLIB_LIB=-lz \
+ WITH_SYNCTEX=1
+
+CPPFLAGS+= -DWITH_SYNCTEX
OPTIONS_DEFINE= NLS SQLITE
OPTIONS_SUB= yes