aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-06 06:07:02 +0800
committermarcus <marcus@FreeBSD.org>2005-03-06 06:07:02 +0800
commit3c5a1084f1745ca180cc399cdf81e68e6a9efe34 (patch)
tree0fa7f535d2420a7bd379c2921eaa0f0c4bb8d656 /graphics
parent3494d79bc65bd9a09495b019b7dac5c0274e172b (diff)
downloadfreebsd-ports-gnome-3c5a1084f1745ca180cc399cdf81e68e6a9efe34.tar.gz
freebsd-ports-gnome-3c5a1084f1745ca180cc399cdf81e68e6a9efe34.tar.zst
freebsd-ports-gnome-3c5a1084f1745ca180cc399cdf81e68e6a9efe34.zip
Be sure to link against PTHREAD_LIBS even in the non-GNOME case to fix
a crash with the file chooser when gnomevfs2 is installed.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-app/Makefile2
-rw-r--r--graphics/gimp/Makefile2
-rw-r--r--graphics/gimpshop/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index b95a7c9fe9be..9b6f16a6fd02 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -144,6 +145,7 @@ PLIST_SUB+= GNOMEPANEL:=""
GNOME_ENABLED= yes
.else
PLIST_SUB+= GNOMEPANEL:="@comment "
+CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
.endif
.if ${HAVE_GNOME:Mlibgtkhtml}!="" || defined(WITH_HTML_HELP_BROWSER)
diff --git a/graphics/gimp/Makefile b/graphics/gimp/Makefile
index b95a7c9fe9be..9b6f16a6fd02 100644
--- a/graphics/gimp/Makefile
+++ b/graphics/gimp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -144,6 +145,7 @@ PLIST_SUB+= GNOMEPANEL:=""
GNOME_ENABLED= yes
.else
PLIST_SUB+= GNOMEPANEL:="@comment "
+CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
.endif
.if ${HAVE_GNOME:Mlibgtkhtml}!="" || defined(WITH_HTML_HELP_BROWSER)
diff --git a/graphics/gimpshop/Makefile b/graphics/gimpshop/Makefile
index b95a7c9fe9be..9b6f16a6fd02 100644
--- a/graphics/gimpshop/Makefile
+++ b/graphics/gimpshop/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 2.2.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -144,6 +145,7 @@ PLIST_SUB+= GNOMEPANEL:=""
GNOME_ENABLED= yes
.else
PLIST_SUB+= GNOMEPANEL:="@comment "
+CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
.endif
.if ${HAVE_GNOME:Mlibgtkhtml}!="" || defined(WITH_HTML_HELP_BROWSER)