aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-29 20:42:04 +0800
committerbapt <bapt@FreeBSD.org>2012-06-29 20:42:04 +0800
commit42034a997e9bbb7dd2e66f6719377aebbe4c7abd (patch)
tree44dc0e86776cb3ba9a994d27c2ee2b7a934bcdd2 /graphics
parentff094d05cd8d446e528963491389242e738416e1 (diff)
downloadfreebsd-ports-gnome-42034a997e9bbb7dd2e66f6719377aebbe4c7abd.tar.gz
freebsd-ports-gnome-42034a997e9bbb7dd2e66f6719377aebbe4c7abd.tar.zst
freebsd-ports-gnome-42034a997e9bbb7dd2e66f6719377aebbe4c7abd.zip
Convert to new option framework
Diffstat (limited to 'graphics')
-rw-r--r--graphics/swftools/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 8dcf6ef14b79..d481db45e899 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -24,8 +24,7 @@ LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
-OPTIONS= LAME "LAME MP3 audio encoder support" off \
- PDF "PDFlib support" off
+OPTIONS_DEFINE= LAME PDF
USE_GNOME= pkgconfig
USE_GL= glut
@@ -42,16 +41,16 @@ MAN1= as3compile.1 font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LAME)
+.if ${PORT_OPTIONS:MLAME}
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
#CONFIGURE_ARGS+= --disable-lame
CONFIGURE_ENV+= ac_cv_lib_mp3lame_lame_init=no
.endif
-.if defined(WITH_PDF)
+.if ${PORT_OPTIONS:MPDF}
LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
PLIST_SUB+= PDF=""
MAN1+= pdf2pdf.1
@@ -68,4 +67,4 @@ post-patch:
@${REINPLACE_CMD} -e '/python/d ; \
/avi2swf/d' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>