aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-08-20 09:53:49 +0800
committerstas <stas@FreeBSD.org>2011-08-20 09:53:49 +0800
commit5c473927a225b81bcdc5d19273de4d7f2758207b (patch)
tree614fd94830c1ee3d9ba7a347fef9aaf10985ab07 /graphics
parent8f9e89e8364d8443ffbc0c375317f766e04c9df5 (diff)
downloadfreebsd-ports-gnome-5c473927a225b81bcdc5d19273de4d7f2758207b.tar.gz
freebsd-ports-gnome-5c473927a225b81bcdc5d19273de4d7f2758207b.tar.zst
freebsd-ports-gnome-5c473927a225b81bcdc5d19273de4d7f2758207b.zip
- rawtherapee actually wants lcms1.
- add option to disable OpenMP.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/rawtherapee/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 1e69500036a7..017fada3e498 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -17,7 +17,7 @@ COMMENT= A powerful RAW image processing application
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms2.2:${PORTSDIR}/graphics/lcms2 \
+ lcms.1:${PORTSDIR}/graphics/lcms \
png:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
@@ -42,7 +42,8 @@ LICENSE= GPLv3
RTDIR= ${PREFIX}/libdata/${PORTNAME}
-OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
+OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on \
+ OPENMP "Enable multicore processing using OpenMP" on
.include <bsd.port.pre.mk>
@@ -53,4 +54,10 @@ CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
.endif
.endif
+.if !defined(WITHOUT_OPENMP)
+CMAKE_ARGS+= -DOPTION_OMP:BOOL=ON
+.else
+CMAKE_ARGS+= -DOPTION_OMP:BOOL=OFF
+.endif
+
.include <bsd.port.post.mk>