aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-03-15 20:39:16 +0800
committergahr <gahr@FreeBSD.org>2012-03-15 20:39:16 +0800
commit6552d4855bcde1b333012c9e1ac5e013d633c673 (patch)
tree9734c15398008a3aab049c6d0eaafe0a7ac1e05c /graphics
parentb654168ed064f22006a96d91475de8b6021931ac (diff)
downloadfreebsd-ports-gnome-6552d4855bcde1b333012c9e1ac5e013d633c673.tar.gz
freebsd-ports-gnome-6552d4855bcde1b333012c9e1ac5e013d633c673.tar.zst
freebsd-ports-gnome-6552d4855bcde1b333012c9e1ac5e013d633c673.zip
- Add a patch to fix a missing implementation of a RIB API function, the
patch has been posted to the upstream tracker at http://sf.net/tracker/?func=detail&atid=383970&aid=3505124&group_id=25264 - Bump PORTREVISION Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aqsis/Makefile1
-rw-r--r--graphics/aqsis/files/patch-libs-core-api_ri.cpp14
2 files changed, 15 insertions, 0 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index 6758bff04133..cfb830fa7533 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -8,6 +8,7 @@
PORTNAME= aqsis
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
DISTNAME= Aqsis-${PORTVERSION}-Source
diff --git a/graphics/aqsis/files/patch-libs-core-api_ri.cpp b/graphics/aqsis/files/patch-libs-core-api_ri.cpp
new file mode 100644
index 000000000000..88ac1a78227c
--- /dev/null
+++ b/graphics/aqsis/files/patch-libs-core-api_ri.cpp
@@ -0,0 +1,14 @@
+--- libs/core/api/ri.cpp.orig 2012-03-02 09:03:48.000000000 +0100
++++ libs/core/api/ri.cpp 2012-03-15 11:58:30.000000000 +0100
+@@ -4220,6 +4220,11 @@
+ Aqsis::log() << warning << "RiDeformation not supported" << std::endl;
+ }
+
++RtVoid RiDeformationV(RtToken name, RtInt n, RtToken tokens[], RtPointer parms[])
++{
++ Aqsis::log() << warning << "RiDeformationV not supported" << std::endl;
++}
++
+ RtVoid RiMakeBump(RtString imagefile, RtString bumpfile, RtToken swrap, RtToken twrap, RtFilterFunc filterfunc, RtFloat swidth, RtFloat twidth, PARAMETERLIST)
+ {
+ Aqsis::log() << warning << "RiMakeBump not supported" << std::endl;