aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-05-15 05:44:49 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-05-15 05:44:49 +0800
commit6d741fe19099f9110d35e75acf8d079b88503ec8 (patch)
tree8b79a848f2281b85b5ca6c7aa3f6dbc031e74f11 /graphics
parent120903b30b382be3ca67896790f25910c5bf06b2 (diff)
downloadfreebsd-ports-gnome-6d741fe19099f9110d35e75acf8d079b88503ec8.tar.gz
freebsd-ports-gnome-6d741fe19099f9110d35e75acf8d079b88503ec8.tar.zst
freebsd-ports-gnome-6d741fe19099f9110d35e75acf8d079b88503ec8.zip
graphics/osgearth:
- Update to 2.7 (this new version also allows osgearth to build against osg-3.4.0) - Rename and update patch of src/osgEarth/ThreadingUtils.cpp (pet portlint) - Fix COMMENT (pet portlint) - Fix BUILD_DEPENDS for minizip Changes this release: http://docs.osgearth.org/en/latest/releasenotes.html#version-2-7-july-2015 PR: 209236 Reviewed by: mat (mentor) Approved by: lbartoletti@tuxfamily.org (maintainer), adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6344
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osgearth/Makefile7
-rw-r--r--graphics/osgearth/distinfo5
-rw-r--r--graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp (renamed from graphics/osgearth/files/patch-src-osgEarth-ThreadingUtils.cpp)10
-rw-r--r--graphics/osgearth/pkg-plist145
4 files changed, 97 insertions, 70 deletions
diff --git a/graphics/osgearth/Makefile b/graphics/osgearth/Makefile
index abca9ac3d615..cb82c2c1d172 100644
--- a/graphics/osgearth/Makefile
+++ b/graphics/osgearth/Makefile
@@ -2,17 +2,16 @@
# $FreeBSD$
PORTNAME= osgearth
-PORTVERSION= 2.5
+PORTVERSION= 2.7
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 6
CATEGORIES= graphics geography
MAINTAINER= coder@tuxfamily.org
-COMMENT= osgEarth is a C++ terrain rendering toolkit for OpenSceneGraph
+COMMENT= C++ terrain rendering toolkit for OpenSceneGraph
LICENSE= LGPL3
-BUILD_DEPENDS= ${LOCALBASE}/bin/minizip:archivers/minizip
+BUILD_DEPENDS= minizip:archivers/minizip
LIB_DEPENDS= libosg.so:graphics/osg \
libgdal.so:graphics/gdal \
libcurl.so:ftp/curl
diff --git a/graphics/osgearth/distinfo b/graphics/osgearth/distinfo
index 02b4c18529a1..c6469a132b18 100644
--- a/graphics/osgearth/distinfo
+++ b/graphics/osgearth/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gwaldron-osgearth-osgearth-2.5_GH0.tar.gz) = 73d730fdf615318ef876179b21ff77f508efa20e4dcd8640b999a8235a811616
-SIZE (gwaldron-osgearth-osgearth-2.5_GH0.tar.gz) = 49670415
+TIMESTAMP = 1463133065
+SHA256 (gwaldron-osgearth-osgearth-2.7_GH0.tar.gz) = cf973b664aeb79f70e48f5cd02ba670069ec273d71fe541604ed5b328d956d83
+SIZE (gwaldron-osgearth-osgearth-2.7_GH0.tar.gz) = 61837911
diff --git a/graphics/osgearth/files/patch-src-osgEarth-ThreadingUtils.cpp b/graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp
index bf2f40537dc7..8c31bb782626 100644
--- a/graphics/osgearth/files/patch-src-osgEarth-ThreadingUtils.cpp
+++ b/graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp
@@ -1,5 +1,5 @@
---- src/osgEarth/ThreadingUtils.cpp.orig 2013-05-16 20:29:30.000000000 +0200
-+++ src/osgEarth/ThreadingUtils.cpp 2013-05-16 20:28:01.000000000 +0200
+--- src/osgEarth/ThreadingUtils.cpp.orig 2016-02-10 18:21:28 UTC
++++ src/osgEarth/ThreadingUtils.cpp
@@ -23,6 +23,7 @@
#else
# include <unistd.h>
@@ -8,10 +8,10 @@
#endif
using namespace osgEarth::Threading;
-@@ -38,6 +39,10 @@
- return (unsigned)::GetCurrentThreadId();
- #elif __APPLE__
+@@ -40,6 +41,10 @@ unsigned osgEarth::Threading::getCurrent
return ::syscall(SYS_thread_selfid);
+ #elif __ANDROID__
+ return gettid();
+#elif __FreeBSD__
+ long lwpid;
+ thr_self(&lwpid);
diff --git a/graphics/osgearth/pkg-plist b/graphics/osgearth/pkg-plist
index 32037f17b277..a50a56572750 100644
--- a/graphics/osgearth/pkg-plist
+++ b/graphics/osgearth/pkg-plist
@@ -1,18 +1,23 @@
bin/osgearth_annotation
+bin/osgearth_atlas
bin/osgearth_backfill
bin/osgearth_boundarygen
bin/osgearth_cache
+bin/osgearth_cache_test
bin/osgearth_city
bin/osgearth_clamp
+bin/osgearth_clipplane
bin/osgearth_colorfilter
bin/osgearth_controls
+bin/osgearth_conv
+bin/osgearth_createtile
bin/osgearth_elevation
bin/osgearth_featureeditor
bin/osgearth_featurefilter
bin/osgearth_featureinfo
-bin/osgearth_featuremanip
bin/osgearth_featurequery
bin/osgearth_features
+bin/osgearth_fog
bin/osgearth_graticule
bin/osgearth_imageoverlay
bin/osgearth_los
@@ -20,20 +25,22 @@ bin/osgearth_manip
bin/osgearth_map
bin/osgearth_measure
bin/osgearth_minimap
+bin/osgearth_mrt
bin/osgearth_occlusionculling
bin/osgearth_overlayviewer
bin/osgearth_package
+bin/osgearth_pick
bin/osgearth_sequencecontrol
bin/osgearth_shadercomp
-bin/osgearth_shadow
+bin/osgearth_shadergen
bin/osgearth_sharedlayer
-bin/osgearth_terraineffects
bin/osgearth_terrainprofile
bin/osgearth_tfs
bin/osgearth_tileindex
bin/osgearth_tilesource
bin/osgearth_toc
bin/osgearth_tracks
+bin/osgearth_transform
bin/osgearth_version
bin/osgearth_viewer
include/osgEarth/AlphaEffect
@@ -46,6 +53,7 @@ include/osgEarth/CachePolicy
include/osgEarth/CacheSeed
include/osgEarth/Capabilities
include/osgEarth/ClampableNode
+include/osgEarth/Clamping
include/osgEarth/ClampingTechnique
include/osgEarth/ColorFilter
include/osgEarth/Common
@@ -58,28 +66,32 @@ include/osgEarth/DPLineSegmentIntersector
include/osgEarth/DateTime
include/osgEarth/Decluttering
include/osgEarth/DepthOffset
-include/osgEarth/Draggers
include/osgEarth/DrapeableNode
include/osgEarth/DrapingTechnique
include/osgEarth/DrawInstanced
include/osgEarth/ECEF
+include/osgEarth/ElevationField
include/osgEarth/ElevationLOD
include/osgEarth/ElevationLayer
include/osgEarth/ElevationQuery
include/osgEarth/Export
+include/osgEarth/Extension
include/osgEarth/FadeEffect
include/osgEarth/FileUtils
include/osgEarth/GeoCommon
include/osgEarth/GeoData
include/osgEarth/GeoMath
+include/osgEarth/GeoTransform
include/osgEarth/Geoid
include/osgEarth/HTTPClient
include/osgEarth/HeightFieldUtils
+include/osgEarth/Horizon
include/osgEarth/IOTypes
include/osgEarth/ImageLayer
include/osgEarth/ImageMosaic
include/osgEarth/ImageToHeightFieldConverter
include/osgEarth/ImageUtils
+include/osgEarth/IntersectionPicker
include/osgEarth/JsonUtils
include/osgEarth/Layer
include/osgEarth/LineFunctor
@@ -100,23 +112,30 @@ include/osgEarth/MaskSource
include/osgEarth/MemCache
include/osgEarth/ModelLayer
include/osgEarth/ModelSource
+include/osgEarth/NativeProgramAdapter
include/osgEarth/NodeUtils
include/osgEarth/Notify
+include/osgEarth/ObjectIndex
include/osgEarth/OverlayDecorator
include/osgEarth/OverlayNode
-include/osgEarth/Pickers
+include/osgEarth/PhongLightingEffect
+include/osgEarth/Picker
include/osgEarth/PrimitiveIntersector
include/osgEarth/Profile
+include/osgEarth/Profiler
include/osgEarth/Progress
include/osgEarth/Random
include/osgEarth/Registry
include/osgEarth/Revisioning
include/osgEarth/ShaderFactory
include/osgEarth/ShaderGenerator
+include/osgEarth/ShaderLoader
include/osgEarth/ShaderUtils
-include/osgEarth/SparseTexture2DArray
+include/osgEarth/Shaders
+include/osgEarth/SharedSARepo
include/osgEarth/SpatialReference
include/osgEarth/StateSetCache
+include/osgEarth/StateSetLOD
include/osgEarth/StringUtils
include/osgEarth/TaskService
include/osgEarth/Terrain
@@ -124,12 +143,14 @@ include/osgEarth/TerrainEffect
include/osgEarth/TerrainEngineNode
include/osgEarth/TerrainLayer
include/osgEarth/TerrainOptions
+include/osgEarth/TerrainTileNode
+include/osgEarth/Tessellator
include/osgEarth/TextureCompositor
-include/osgEarth/TextureCompositorMulti
-include/osgEarth/TextureCompositorTexArray
include/osgEarth/ThreadingUtils
+include/osgEarth/TileHandler
include/osgEarth/TileKey
include/osgEarth/TileSource
+include/osgEarth/TileVisitor
include/osgEarth/TimeControl
include/osgEarth/TraversalData
include/osgEarth/URI
@@ -152,6 +173,7 @@ include/osgEarthAnnotation/AnnotationUtils
include/osgEarthAnnotation/CircleNode
include/osgEarthAnnotation/Common
include/osgEarthAnnotation/Decoration
+include/osgEarthAnnotation/Draggers
include/osgEarthAnnotation/EllipseNode
include/osgEarthAnnotation/Export
include/osgEarthAnnotation/FeatureEditing
@@ -179,8 +201,10 @@ include/osgEarthDrivers/engine_byo/Common
include/osgEarthDrivers/engine_mp/Common
include/osgEarthDrivers/engine_mp/DynamicLODScaleCallback
include/osgEarthDrivers/engine_mp/FileLocationCallback
+include/osgEarthDrivers/engine_mp/HeightFieldCache
include/osgEarthDrivers/engine_mp/KeyNodeFactory
include/osgEarthDrivers/engine_mp/MPGeometry
+include/osgEarthDrivers/engine_mp/MPShaders
include/osgEarthDrivers/engine_mp/MPTerrainEngineNode
include/osgEarthDrivers/engine_mp/MPTerrainEngineOptions
include/osgEarthDrivers/engine_mp/QuickReleaseGLObjects
@@ -193,43 +217,10 @@ include/osgEarthDrivers/engine_mp/TileModelFactory
include/osgEarthDrivers/engine_mp/TileNode
include/osgEarthDrivers/engine_mp/TileNodeRegistry
include/osgEarthDrivers/engine_mp/TilePagedLOD
-include/osgEarthDrivers/engine_osgterrain/Common
-include/osgEarthDrivers/engine_osgterrain/CustomTerrainTechnique
-include/osgEarthDrivers/engine_osgterrain/DynamicLODScaleCallback
-include/osgEarthDrivers/engine_osgterrain/FileLocationCallback
-include/osgEarthDrivers/engine_osgterrain/KeyNodeFactory
-include/osgEarthDrivers/engine_osgterrain/LODFactorCallback
-include/osgEarthDrivers/engine_osgterrain/MultiPassTerrainTechnique
-include/osgEarthDrivers/engine_osgterrain/OSGTerrainEngineNode
-include/osgEarthDrivers/engine_osgterrain/OSGTerrainOptions
-include/osgEarthDrivers/engine_osgterrain/OSGTileFactory
-include/osgEarthDrivers/engine_osgterrain/ParallelKeyNodeFactory
-include/osgEarthDrivers/engine_osgterrain/SerialKeyNodeFactory
-include/osgEarthDrivers/engine_osgterrain/SinglePassTerrainTechnique
-include/osgEarthDrivers/engine_osgterrain/StreamingTerrainNode
-include/osgEarthDrivers/engine_osgterrain/StreamingTile
-include/osgEarthDrivers/engine_osgterrain/TerrainNode
-include/osgEarthDrivers/engine_osgterrain/Tile
-include/osgEarthDrivers/engine_osgterrain/TileBuilder
-include/osgEarthDrivers/engine_osgterrain/TransparentLayer
-include/osgEarthDrivers/engine_quadtree/Common
-include/osgEarthDrivers/engine_quadtree/CustomPagedLOD
-include/osgEarthDrivers/engine_quadtree/DynamicLODScaleCallback
-include/osgEarthDrivers/engine_quadtree/FileLocationCallback
-include/osgEarthDrivers/engine_quadtree/KeyNodeFactory
-include/osgEarthDrivers/engine_quadtree/LODFactorCallback
-include/osgEarthDrivers/engine_quadtree/QuadTreeTerrainEngineNode
-include/osgEarthDrivers/engine_quadtree/QuadTreeTerrainEngineOptions
-include/osgEarthDrivers/engine_quadtree/QuickReleaseGLObjects
-include/osgEarthDrivers/engine_quadtree/SerialKeyNodeFactory
-include/osgEarthDrivers/engine_quadtree/TerrainNode
-include/osgEarthDrivers/engine_quadtree/TileModel
-include/osgEarthDrivers/engine_quadtree/TileModelCompiler
-include/osgEarthDrivers/engine_quadtree/TileModelFactory
-include/osgEarthDrivers/engine_quadtree/TileNode
-include/osgEarthDrivers/engine_quadtree/TileNodeRegistry
+include/osgEarthDrivers/feature_elevation/FeatureElevationOptions
include/osgEarthDrivers/feature_ogr/FeatureCursorOGR
include/osgEarthDrivers/feature_ogr/OGRFeatureOptions
+include/osgEarthDrivers/feature_raster/RasterFeatureOptions
include/osgEarthDrivers/feature_tfs/TFSFeatureOptions
include/osgEarthDrivers/feature_wfs/WFSFeatureOptions
include/osgEarthDrivers/gdal/GDALOptions
@@ -240,9 +231,18 @@ include/osgEarthDrivers/mbtiles/MBTilesOptions
include/osgEarthDrivers/model_feature_geom/FeatureGeomModelOptions
include/osgEarthDrivers/model_feature_stencil/FeatureStencilModelOptions
include/osgEarthDrivers/model_simple/SimpleModelOptions
-include/osgEarthDrivers/ocean_surface/OceanSurface
+include/osgEarthDrivers/ocean_simple/SimpleOceanOptions
+include/osgEarthDrivers/osg/ColorRampOptions
include/osgEarthDrivers/osg/OSGOptions
+include/osgEarthDrivers/quadkey/QuadKeyOptions
include/osgEarthDrivers/refresh/RefreshOptions
+include/osgEarthDrivers/scriptengine_javascript/DuktapeEngine
+include/osgEarthDrivers/scriptengine_javascript/JSGeometry
+include/osgEarthDrivers/scriptengine_javascript/duktape.h
+include/osgEarthDrivers/sky_gl/GLSkyOptions
+include/osgEarthDrivers/sky_simple/SimpleSkyOptions
+include/osgEarthDrivers/splat_mask/SplatMaskOptions
+include/osgEarthDrivers/template_matclass/TemplateMatClassOptions
include/osgEarthDrivers/tilecache/TileCacheOptions
include/osgEarthDrivers/tileindex/TileIndexOptions
include/osgEarthDrivers/tileservice/TileServiceOptions
@@ -267,6 +267,7 @@ include/osgEarthFeatures/Feature
include/osgEarthFeatures/FeatureCursor
include/osgEarthFeatures/FeatureDisplayLayout
include/osgEarthFeatures/FeatureDrawSet
+include/osgEarthFeatures/FeatureIndex
include/osgEarthFeatures/FeatureListSource
include/osgEarthFeatures/FeatureModelGraph
include/osgEarthFeatures/FeatureModelSource
@@ -297,6 +298,7 @@ include/osgEarthSymbology/AGG.h
include/osgEarthSymbology/AltitudeSymbol
include/osgEarthSymbology/Color
include/osgEarthSymbology/Common
+include/osgEarthSymbology/CoverageSymbol
include/osgEarthSymbology/CssUtils
include/osgEarthSymbology/Expression
include/osgEarthSymbology/ExtrusionSymbol
@@ -313,6 +315,7 @@ include/osgEarthSymbology/LineSymbol
include/osgEarthSymbology/MarkerResource
include/osgEarthSymbology/MarkerSymbol
include/osgEarthSymbology/MeshConsolidator
+include/osgEarthSymbology/MeshFlattener
include/osgEarthSymbology/MeshSubdivider
include/osgEarthSymbology/ModelResource
include/osgEarthSymbology/ModelSymbol
@@ -332,8 +335,10 @@ include/osgEarthSymbology/StyleSheet
include/osgEarthSymbology/Symbol
include/osgEarthSymbology/Tags
include/osgEarthSymbology/TextSymbol
+include/osgEarthUtil/ActivityMonitorTool
include/osgEarthUtil/AnnotationEvents
include/osgEarthUtil/ArcGIS
+include/osgEarthUtil/AtlasBuilder
include/osgEarthUtil/AutoClipPlaneHandler
include/osgEarthUtil/BrightnessContrastColorFilter
include/osgEarthUtil/CMYKColorFilter
@@ -343,34 +348,42 @@ include/osgEarthUtil/Common
include/osgEarthUtil/ContourMap
include/osgEarthUtil/Controls
include/osgEarthUtil/DataScanner
-include/osgEarthUtil/DateTime
-include/osgEarthUtil/DetailTexture
include/osgEarthUtil/EarthManipulator
+include/osgEarthUtil/Ephemeris
include/osgEarthUtil/ExampleResources
include/osgEarthUtil/Export
-include/osgEarthUtil/FeatureManipTool
include/osgEarthUtil/FeatureQueryTool
+include/osgEarthUtil/Fog
include/osgEarthUtil/Formatter
include/osgEarthUtil/GLSLColorFilter
include/osgEarthUtil/GammaColorFilter
include/osgEarthUtil/GeodeticGraticule
+include/osgEarthUtil/GraticuleExtension
+include/osgEarthUtil/GraticuleNode
+include/osgEarthUtil/GraticuleOptions
+include/osgEarthUtil/GraticuleTerrainEffect
include/osgEarthUtil/HSLColorFilter
include/osgEarthUtil/HTM
include/osgEarthUtil/LODBlending
include/osgEarthUtil/LatLongFormatter
include/osgEarthUtil/LineOfSight
include/osgEarthUtil/LinearLineOfSight
+include/osgEarthUtil/LogarithmicDepthBuffer
include/osgEarthUtil/MGRSFormatter
include/osgEarthUtil/MGRSGraticule
include/osgEarthUtil/MeasureTool
include/osgEarthUtil/MouseCoordsTool
-include/osgEarthUtil/NormalMap
+include/osgEarthUtil/NightColorFilter
include/osgEarthUtil/ObjectLocator
+include/osgEarthUtil/Ocean
include/osgEarthUtil/PolyhedralLineOfSight
include/osgEarthUtil/RGBColorFilter
+include/osgEarthUtil/RTTPicker
include/osgEarthUtil/RadialLineOfSight
-include/osgEarthUtil/ShadowUtils
-include/osgEarthUtil/SkyNode
+include/osgEarthUtil/Shaders
+include/osgEarthUtil/Shadowing
+include/osgEarthUtil/SimplexNoise
+include/osgEarthUtil/Sky
include/osgEarthUtil/SpatialData
include/osgEarthUtil/StarData
include/osgEarthUtil/TFS
@@ -387,45 +400,58 @@ include/osgEarthUtil/WFS
include/osgEarthUtil/WMS
lib/libosgEarth.so
lib/libosgEarth.so.0
-lib/libosgEarth.so.2.5.0
+lib/libosgEarth.so.2.6.0
lib/libosgEarthAnnotation.so
lib/libosgEarthAnnotation.so.0
-lib/libosgEarthAnnotation.so.2.5.0
+lib/libosgEarthAnnotation.so.2.6.0
lib/libosgEarthFeatures.so
lib/libosgEarthFeatures.so.0
-lib/libosgEarthFeatures.so.2.5.0
+lib/libosgEarthFeatures.so.2.6.0
lib/libosgEarthSymbology.so
lib/libosgEarthSymbology.so.0
-lib/libosgEarthSymbology.so.2.5.0
+lib/libosgEarthSymbology.so.2.6.0
lib/libosgEarthUtil.so
lib/libosgEarthUtil.so.0
-lib/libosgEarthUtil.so.2.5.0
+lib/libosgEarthUtil.so.2.6.0
lib/osgPlugins-%%OSGVERSION%%/osgdb_earth.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_kml.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_agglite.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis_map_cache.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_billboard.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_bing.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_bumpmap.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_cache_filesystem.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_colorramp.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_debug.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_byo.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_mp.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_osgterrain.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_quadtree.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_elevation.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_ogr.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_raster.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_tfs.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_wfs.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_gdal.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_label_annotation.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_label_overlay.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mapinspector.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mask_feature.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mbtiles.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_feature_geom.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_feature_stencil.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_simple.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_ocean_surface.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_noise.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_normalmap.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_ocean_simple.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_osg.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_quadkey.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_refresh.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_scriptengine_javascript.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_sky_gl.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_sky_simple.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_splat.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_splat_mask.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_template_matclass.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_terrainshader.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tilecache.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tileindex.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tileservice.so
@@ -433,6 +459,7 @@ lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_tms.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vdatum_egm2008.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vdatum_egm84.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vdatum_egm96.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_viewpoints.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_vpb.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_wcs.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_wms.so