aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2005-04-12 15:58:01 +0800
committerijliao <ijliao@FreeBSD.org>2005-04-12 15:58:01 +0800
commit76d38cf0908a2c7984a2a1e91c030b39d5440f6d (patch)
treeef1f9f4709e8f2dd048026feadd58fb7f97e8861 /graphics
parent9ee0ee84cb970d081cd4dfc9aedbbced0ee2be46 (diff)
downloadfreebsd-ports-gnome-76d38cf0908a2c7984a2a1e91c030b39d5440f6d.tar.gz
freebsd-ports-gnome-76d38cf0908a2c7984a2a1e91c030b39d5440f6d.tar.zst
freebsd-ports-gnome-76d38cf0908a2c7984a2a1e91c030b39d5440f6d.zip
add py-dot 0.9.10
A Python interface to Graphviz's Dot language
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-dot/Makefile25
-rw-r--r--graphics/py-dot/distinfo2
-rw-r--r--graphics/py-dot/pkg-descr5
-rw-r--r--graphics/py-dot/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9c6a44ec83e4..c2ffd90c2bc0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -429,6 +429,7 @@
SUBDIR += py-cairo
SUBDIR += py-cgkit
SUBDIR += py-chart
+ SUBDIR += py-dot
SUBDIR += py-exif
SUBDIR += py-gd
SUBDIR += py-gdchart
diff --git a/graphics/py-dot/Makefile b/graphics/py-dot/Makefile
new file mode 100644
index 000000000000..6219df4b01c2
--- /dev/null
+++ b/graphics/py-dot/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: py-dot
+# Date created: Apr 12, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= dot
+PORTVERSION= 0.9.10
+CATEGORIES= graphics python
+MASTER_SITES= http://www.dkbza.org/data/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pydot-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Python interface to Graphviz's Dot language
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing \
+ dot:${PORTSDIR}/graphics/graphviz
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-dot/distinfo b/graphics/py-dot/distinfo
new file mode 100644
index 000000000000..b6538eee813c
--- /dev/null
+++ b/graphics/py-dot/distinfo
@@ -0,0 +1,2 @@
+MD5 (pydot-0.9.10.tar.gz) = d59609a3b69b19ad018c55d765945baf
+SIZE (pydot-0.9.10.tar.gz) = 14462
diff --git a/graphics/py-dot/pkg-descr b/graphics/py-dot/pkg-descr
new file mode 100644
index 000000000000..d3d25f459077
--- /dev/null
+++ b/graphics/py-dot/pkg-descr
@@ -0,0 +1,5 @@
+An interface for creating both directed and non directed graphs from Python.
+Currently all attributes implemented in the Dot language are supported (up
+to Graphviz 1.16).
+
+WWW: http://www.dkbza.org/pydot.html
diff --git a/graphics/py-dot/pkg-plist b/graphics/py-dot/pkg-plist
new file mode 100644
index 000000000000..a113618669f8
--- /dev/null
+++ b/graphics/py-dot/pkg-plist
@@ -0,0 +1,6 @@
+%%PYTHON_SITELIBDIR%%/dot_parser.py
+%%PYTHON_SITELIBDIR%%/dot_parser.pyc
+%%PYTHON_SITELIBDIR%%/dot_parser.pyo
+%%PYTHON_SITELIBDIR%%/pydot.py
+%%PYTHON_SITELIBDIR%%/pydot.pyc
+%%PYTHON_SITELIBDIR%%/pydot.pyo