aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-02-18 02:01:42 +0800
committerrakuco <rakuco@FreeBSD.org>2016-02-18 02:01:42 +0800
commit8e5a38fd3c396dd4eccce0a81e2276ae2e2688f9 (patch)
tree9142a55f9451545da636b358eecd37cea8d36a26 /graphics
parent9368aad09ece7ed3cea2a009b7b798a7537bee09 (diff)
downloadfreebsd-ports-gnome-8e5a38fd3c396dd4eccce0a81e2276ae2e2688f9.tar.gz
freebsd-ports-gnome-8e5a38fd3c396dd4eccce0a81e2276ae2e2688f9.tar.zst
freebsd-ports-gnome-8e5a38fd3c396dd4eccce0a81e2276ae2e2688f9.zip
Convert to option target helpers and simplify BROKEN definition.
Approved by: portmgr blanket approval
Diffstat (limited to 'graphics')
-rw-r--r--graphics/code-eli/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
index 6bade868e941..269026de30f9 100644
--- a/graphics/code-eli/Makefile
+++ b/graphics/code-eli/Makefile
@@ -32,19 +32,16 @@ EXAMPLES_LIB_DEPENDS= libcpptest.so:${PORTSDIR}/devel/cpptest
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
DOCS_ALL_TARGET= doc
-.include <bsd.port.options.mk>
+# The code uses std::cbrt(). Even if one passes some additional macros for
+# libstdc++ to enable additional math functions in math.h some of them, such as
+# acoshl() are not defined and linking fails.
+BROKEN_FreeBSD_9= Needs additional math functions
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-BROKEN= Can not compile if FreeBSD version lower than 10.0-RELEASE
-.endif
-
-post-patch:
-.if ! ${PORT_OPTIONS:MEXAMPLES}
+post-patch-EXAMPLES-off:
${REINPLACE_CMD} \
-e 's/add_subdirectory(example)//g' \
-e 's/find_package(CPPTest)//g' \
${WRKSRC}/CMakeLists.txt
-.endif
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/eli \
@@ -55,7 +52,8 @@ do-install:
${STAGEDIR}${PREFIX}/include/eli
(cd ${WRKSRC}/include/eli && \
${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/eli "*")
-.if ${PORT_OPTIONS:MEXAMPLES}
+
+do-install-EXAMPLES-on:
${INSTALL_DATA} \
${BUILD_WRKSRC}/example/${VSPPOD_DIR}/VSPPodExample \
${BUILD_WRKSRC}/example/${AIRFOIL_DIR}/AirfoilFitExample \
@@ -67,9 +65,8 @@ do-install:
"-name *Test -type f")
${FIND} ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} -name *Test | \
${XARGS} ${STRIP_CMD}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
(cd ${BUILD_WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.endif
.include <bsd.port.mk>