aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-10-24 19:10:31 +0800
committerkwm <kwm@FreeBSD.org>2014-10-24 19:10:31 +0800
commit8f6235836288086e48fc9b3e9ba75025e3dd30d1 (patch)
tree4c7c9aa621f07fbf133741bdbb05c40f4e2705f6 /graphics
parent449742d182683a14b63da01606c7889c9e5b74c2 (diff)
downloadfreebsd-ports-gnome-8f6235836288086e48fc9b3e9ba75025e3dd30d1.tar.gz
freebsd-ports-gnome-8f6235836288086e48fc9b3e9ba75025e3dd30d1.tar.zst
freebsd-ports-gnome-8f6235836288086e48fc9b3e9ba75025e3dd30d1.zip
Add libepoxy.
Epoxy is a library for handling OpenGL function pointer management for you.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libepoxy/Makefile28
-rw-r--r--graphics/libepoxy/distinfo2
-rw-r--r--graphics/libepoxy/pkg-descr4
-rw-r--r--graphics/libepoxy/pkg-plist10
5 files changed, 45 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4e49e7017f0c..187608013892 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -492,6 +492,7 @@
SUBDIR += libdrm
SUBDIR += libecwj2
SUBDIR += libemf
+ SUBDIR += libepoxy
SUBDIR += libetonyek
SUBDIR += libetonyek01
SUBDIR += libexif
diff --git a/graphics/libepoxy/Makefile b/graphics/libepoxy/Makefile
new file mode 100644
index 000000000000..9527673f32bb
--- /dev/null
+++ b/graphics/libepoxy/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= libepoxy
+PORTVERSION= 1.2
+CATEGORIES= graphics
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= library that handles OpenGL function pointer managerment for you
+
+LICENSE= MIT
+
+USE_GITHUB= YES
+GH_ACCOUNT= anholt
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 7422de5
+GH_TAGNAME= v1.2
+
+USES= autoreconf libtool pathfix pkgconfig python:3,build
+USE_XORG= xorg-macros
+USE_GL= egl glesv2
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+PATHFIX_MAKEFILEIN= Makefile.am
+
+# GLX
+USE_XORG+= x11
+
+.include <bsd.port.mk>
diff --git a/graphics/libepoxy/distinfo b/graphics/libepoxy/distinfo
new file mode 100644
index 000000000000..4d92277a4b8a
--- /dev/null
+++ b/graphics/libepoxy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libepoxy-1.2.tar.gz) = 3364f09ef5cf0c53f8879b6b6165d4d7bd82756ee44f019075fad679346be6d8
+SIZE (libepoxy-1.2.tar.gz) = 267181
diff --git a/graphics/libepoxy/pkg-descr b/graphics/libepoxy/pkg-descr
new file mode 100644
index 000000000000..533ad7fdf8b5
--- /dev/null
+++ b/graphics/libepoxy/pkg-descr
@@ -0,0 +1,4 @@
+Epoxy is a library for handling OpenGL function pointer management for
+you.
+
+WWW: https://github.com/anholt/libepoxy
diff --git a/graphics/libepoxy/pkg-plist b/graphics/libepoxy/pkg-plist
new file mode 100644
index 000000000000..ddf324377937
--- /dev/null
+++ b/graphics/libepoxy/pkg-plist
@@ -0,0 +1,10 @@
+include/epoxy/egl.h
+include/epoxy/egl_generated.h
+include/epoxy/gl.h
+include/epoxy/gl_generated.h
+include/epoxy/glx.h
+include/epoxy/glx_generated.h
+lib/libepoxy.so
+lib/libepoxy.so.0
+lib/libepoxy.so.0.0.0
+libdata/pkgconfig/epoxy.pc