aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-04 01:21:56 +0800
committermakc <makc@FreeBSD.org>2013-02-04 01:21:56 +0800
commit99769320fd4c679659164e26326974d75794145f (patch)
tree66fbbfbf5bab18e735ad851a8c6925ac9e54cd31 /graphics
parentb472ed86be0fe9e643211a1b67de130ed818de06 (diff)
downloadfreebsd-ports-gnome-99769320fd4c679659164e26326974d75794145f.tar.gz
freebsd-ports-gnome-99769320fd4c679659164e26326974d75794145f.tar.zst
freebsd-ports-gnome-99769320fd4c679659164e26326974d75794145f.zip
KDE/FreeBSD team presents Qt 4.8.4 and QtCreator 2.6.1 ports.
The area51 repository features commits by Alonso Schaich, avilla, fluffy, jhale, makc and rakuco. Common changes: - Trim Makefile header - Convert to new option framework - Add/improve desktop entries - Remove upstreamed patches Mk/bsd.qt.mk: - Set QMAKESPEC at late stage (to fix potential problem if USE_GCC is used) [1] devel/qmake: - Fix crash due to off-by one error [2] multimedia/qt4-phonon*: - Deprecate in favour of multimedia/phonon* www/qt4-webkit: - Make dependence on GStreamer optional [3] devel/qtcreator: - Enable qml-designer in devel/qtcreator (requires privite Qt headers) [4] Reported by: avg via irc [1] Submitted by: avg via maillist [2] PR: ports/175644 [3] Submitted by: danfe [3] PR: ports/169809 [4] Reported by: tcb <tcberner at gmail.com> [4]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qt4-iconengines/Makefile7
-rw-r--r--graphics/qt4-imageformats/Makefile9
-rw-r--r--graphics/qt4-pixeltool/Makefile12
-rw-r--r--graphics/qt4-svg/Makefile7
4 files changed, 10 insertions, 25 deletions
diff --git a/graphics/qt4-iconengines/Makefile b/graphics/qt4-iconengines/Makefile
index 066a1059ec88..91241a2fc7e3 100644
--- a/graphics/qt4-iconengines/Makefile
+++ b/graphics/qt4-iconengines/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt40
-# Date created: Wed Jun 29 11:49:42 CEST 2005
-# Whom: lofi@freebsd.org
-#
+# Created by: lofi@freebsd.org
# $FreeBSD$
-#
PORTNAME= iconengines
DISTVERSION= ${QT4_VERSION}
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index d46278737333..6e6247334bc0 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt40
-# Date created: Wed Jun 29 11:49:42 CEST 2005
-# Whom: lofi@freebsd.org
-#
+# Created by: lofi@freebsd.org
# $FreeBSD$
-#
PORTNAME= imageformats
DISTVERSION= ${QT4_VERSION}
@@ -12,7 +7,7 @@ CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt imageformat plugins for GIF, JPEG, MNG, and SVG
+COMMENT= Qt imageformat plugins for GIF, JPEG, MNG and SVG
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
mng:${PORTSDIR}/graphics/libmng \
diff --git a/graphics/qt4-pixeltool/Makefile b/graphics/qt4-pixeltool/Makefile
index 3896030d0138..015f0e27771d 100644
--- a/graphics/qt4-pixeltool/Makefile
+++ b/graphics/qt4-pixeltool/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt40
-# Date created: Wed Jun 29 11:49:42 CEST 2005
-# Whom: lofi@freebsd.org
-#
+# Created by: lofi@freebsd.org
# $FreeBSD$
-#
PORTNAME= pixeltool
DISTVERSION= ${QT4_VERSION}
@@ -26,6 +21,11 @@ CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
+# qtlogo.png is installed by qt4-gui
+DESKTOP_ENTRIES="Qt PixelTool" "${COMMENT}" \
+ "${LOCALBASE}/share/pixmaps/qtlogo.png" \
+ "${PREFIX}/bin/pixeltool" "Graphics;Qt;" true
+
DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
src/activeqt src/dbus src/multimedia src/network src/opengl \
src/openvg src/phonon src/qt3support src/s60installs \
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index f4088c43e930..d5eb24830a1e 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt40
-# Date created: Wed Jun 29 11:49:42 CEST 2005
-# Whom: lofi@freebsd.org
-#
+# Created by: lofi@freebsd.org
# $FreeBSD$
-#
PORTNAME= svg
DISTVERSION= ${QT4_VERSION}