aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-27 06:06:13 +0800
committermiwi <miwi@FreeBSD.org>2008-12-27 06:06:13 +0800
commit9e041ec54c4bcb5e75e695321cc8d08e42d40de3 (patch)
tree6c0636b6556751194b2b9c2fac92aaf51e47c99c /graphics
parent15ade8266e53f3f3dd2daa72725cdb90c392bd84 (diff)
downloadfreebsd-ports-gnome-9e041ec54c4bcb5e75e695321cc8d08e42d40de3.tar.gz
freebsd-ports-gnome-9e041ec54c4bcb5e75e695321cc8d08e42d40de3.tar.zst
freebsd-ports-gnome-9e041ec54c4bcb5e75e695321cc8d08e42d40de3.zip
An experimental clutter cairo 'drawable' actor. Sucks a bit as renders
cairo via an image surface and thus no real cairo rendering acceleration. Experiments with glitz and sharing GL contexts for such acceleration proved problematic. Needs more investigation. WWW: http://clutter-project.org/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/clutter-cairo/Makefile29
-rw-r--r--graphics/clutter-cairo/distinfo3
-rw-r--r--graphics/clutter-cairo/pkg-descr6
-rw-r--r--graphics/clutter-cairo/pkg-plist8
5 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4e96b05c6207..de4d7cf85524 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -67,6 +67,7 @@
SUBDIR += claraocr
SUBDIR += clutter
SUBDIR += clutter-box2d
+ SUBDIR += clutter-cairo
SUBDIR += clutter-gtk
SUBDIR += comical
SUBDIR += comix
diff --git a/graphics/clutter-cairo/Makefile b/graphics/clutter-cairo/Makefile
new file mode 100644
index 000000000000..a543dcbc2774
--- /dev/null
+++ b/graphics/clutter-cairo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: clutter-cairo
+# Date created: 2008-12-25
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clutter-cairo
+PORTVERSION= 0.8.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.clutter-project.org/sources/${PORTNAME}/0.8/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Clutter Cairo integrarion library
+
+LIB_DEPENDS= clutter-glx-0.8:${PORTSDIR}/graphics/clutter \
+ cairo.2:${PORTSDIR}/graphics/cairo
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack ltverhack
+USE_XORG= xp x11
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>
diff --git a/graphics/clutter-cairo/distinfo b/graphics/clutter-cairo/distinfo
new file mode 100644
index 000000000000..48533613d055
--- /dev/null
+++ b/graphics/clutter-cairo/distinfo
@@ -0,0 +1,3 @@
+MD5 (clutter-cairo-0.8.2.tar.gz) = c3bfae082d007be37d9725e5e7b4a30b
+SHA256 (clutter-cairo-0.8.2.tar.gz) = 8d036be4a5834185b2c1bca6fc8db790f240daf70c71c3536439dbb422ee8aea
+SIZE (clutter-cairo-0.8.2.tar.gz) = 341500
diff --git a/graphics/clutter-cairo/pkg-descr b/graphics/clutter-cairo/pkg-descr
new file mode 100644
index 000000000000..935ad2670494
--- /dev/null
+++ b/graphics/clutter-cairo/pkg-descr
@@ -0,0 +1,6 @@
+An experimental clutter cairo 'drawable' actor. Sucks a bit as renders
+cairo via an image surface and thus no real cairo rendering
+acceleration. Experiments with glitz and sharing GL contexts for such
+acceleration proved problematic. Needs more investigation.
+
+WWW: http://clutter-project.org/
diff --git a/graphics/clutter-cairo/pkg-plist b/graphics/clutter-cairo/pkg-plist
new file mode 100644
index 000000000000..7bdd83b11fe4
--- /dev/null
+++ b/graphics/clutter-cairo/pkg-plist
@@ -0,0 +1,8 @@
+include/clutter-0.8/clutter-cairo/clutter-cairo.h
+lib/libclutter-cairo-0.8.a
+lib/libclutter-cairo-0.8.la
+lib/libclutter-cairo-0.8.so
+lib/libclutter-cairo-0.8.so.0
+libdata/pkgconfig/clutter-cairo-0.8.pc
+@dirrm include/clutter-0.8/clutter-cairo
+@dirrmtry include/clutter-0.8