aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-19 11:06:18 +0800
committermarino <marino@FreeBSD.org>2016-08-19 11:06:18 +0800
commitb0c169098d4b1a21b527d517486158c6c91f0b88 (patch)
tree64678e4fce01b74b5e8368ced9727d1abe43ce2f /graphics
parent6356a9d85ad9bef735f7d922b36895cdace85b5e (diff)
downloadfreebsd-ports-gnome-b0c169098d4b1a21b527d517486158c6c91f0b88.tar.gz
freebsd-ports-gnome-b0c169098d4b1a21b527d517486158c6c91f0b88.tar.zst
freebsd-ports-gnome-b0c169098d4b1a21b527d517486158c6c91f0b88.zip
graphics/nomacs: Fix build when RAW option turned off
The opencv-core dependency is not limited to the RAW option. The build fails in a clean jail if the RAW option is turned off due to the missing opencv dependency. Change it to an unconditional LIB_DEPENDS to fix the build in the RAW-off configuration. PR: 202497 Reported by: serpent7776 (gmail) Approved by: maintainer timeout / just-fix-it
Diffstat (limited to 'graphics')
-rw-r--r--graphics/nomacs/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index 312227d08f91..dcce12f53e47 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= nomacs
PORTVERSION= 2.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/nomacs/nomacs-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -13,8 +13,8 @@ COMMENT= Small, fast, and free image viewer
LICENSE= GPLv3
LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
- libsysinfo.so:devel/libsysinfo
-
+ libsysinfo.so:devel/libsysinfo \
+ libopencv_core.so:graphics/opencv-core
USES= cmake desktop-file-utils dos2unix pkgconfig tar:bzip2
USE_QT4= gui network linguist_build moc_build \
qmake_build rcc_build uic_build
@@ -27,14 +27,14 @@ WRKSRC= ${WRKTOP}/${WRKSUBDIR}
OPTIONS_DEFINE= RAW TIFF
OPTIONS_DEFAULT= RAW TIFF
-RAW_LIB_DEPENDS= libraw.so:graphics/libraw \
- libopencv_core.so:graphics/opencv-core
+RAW_LIB_DEPENDS= libraw.so:graphics/libraw
RAW_CMAKE_OFF= -DENABLE_RAW=0
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
TIFF_CMAKE_OFF= -DENABLE_TIFF=0
post-patch:
- @${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' \
+ ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>