aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-12-29 23:47:55 +0800
committermva <mva@FreeBSD.org>2013-12-29 23:47:55 +0800
commitb6e0668545bd03e371216b94931ec19361133576 (patch)
treea80f39d68cf87ddcd7868fe209168a8a296c05ea /graphics
parentb426718713599e9ce79dadf5246f683f947aae5b (diff)
downloadfreebsd-ports-gnome-b6e0668545bd03e371216b94931ec19361133576.tar.gz
freebsd-ports-gnome-b6e0668545bd03e371216b94931ec19361133576.tar.zst
freebsd-ports-gnome-b6e0668545bd03e371216b94931ec19361133576.zip
Partio is a library for reading/writing/processing particle files for a wide
range of tools and file formats. It acts as an abstraction for the commonalities in particle models (i.e. accessing many attributes associated with an index or entity). WWW: http://www.partio.us
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/partio/Makefile52
-rw-r--r--graphics/partio/distinfo2
-rw-r--r--graphics/partio/files/patch-src_lib_core_KdTree.h27
-rw-r--r--graphics/partio/pkg-descr6
-rw-r--r--graphics/partio/pkg-plist122
6 files changed, 210 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bcb81757c268..0f1668bf6818 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -726,6 +726,7 @@
SUBDIR += p5-ming
SUBDIR += panoglview
SUBDIR += panomatic
+ SUBDIR += partio
SUBDIR += passepartout
SUBDIR += pdf2svg
SUBDIR += pear-Horde_Image
diff --git a/graphics/partio/Makefile b/graphics/partio/Makefile
new file mode 100644
index 000000000000..8756bc42e58f
--- /dev/null
+++ b/graphics/partio/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= partio
+PORTVERSION= 1.1.0.20130624
+CATEGORIES= graphics math
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= C++ library for manipulating animation particle formats
+
+LICENSE= BSD3CLAUSE
+
+USES= cmake:outsource
+USE_XORG= xmu
+USE_GL= gl glut
+
+USE_GITHUB= yes
+GH_ACCOUNT= wdas
+GH_PROJECT= partio
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 12428ea
+
+# Workaround until https://github.com/wdas/partio/pull/38
+# is accepted
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS_DEFINE= DOCS PYTHON
+OPTIONS_DEFAULT= PYTHON
+
+DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+PYTHON_USE= PYTHON=2.7+
+PYTHON_BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|python -c|${PYTHON_CMD} -c|; \
+ s|lib64/python$${PYTHON_VERSION}/site-packages|${PYTHONPREFIX_SITELIBDIR:S/${PREFIX}\///}|' \
+ ${WRKSRC}/src/py/CMakeLists.txt
+ @${REINPLACE_CMD} -e '/install(TARGETS/d' \
+ ${WRKSRC}/src/tests/CMakeLists.txt
+.if !${PORT_OPTIONS:MPYTHON}
+ @${REINPLACE_CMD} -e '/ADD_SUBDIRECTORY.*src\/py.*/d' \
+ ${WRKSRC}/CMakeLists.txt
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+post-build:
+ @(cd ${BUILD_WRKSRC}; make doc)
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/partio/distinfo b/graphics/partio/distinfo
new file mode 100644
index 000000000000..78574aa133eb
--- /dev/null
+++ b/graphics/partio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (partio-1.1.0.20130624.tar.gz) = ada3ed0a7e68f7a815dcb894fe425aa72caf2138f11f951a64853bbd8128156e
+SIZE (partio-1.1.0.20130624.tar.gz) = 263739
diff --git a/graphics/partio/files/patch-src_lib_core_KdTree.h b/graphics/partio/files/patch-src_lib_core_KdTree.h
new file mode 100644
index 000000000000..65ae2baab324
--- /dev/null
+++ b/graphics/partio/files/patch-src_lib_core_KdTree.h
@@ -0,0 +1,27 @@
+--- src/lib/core/KdTree.h.orig 2013-12-28 22:59:43.000000000 +0100
++++ src/lib/core/KdTree.h 2013-12-28 22:58:47.000000000 +0100
+@@ -34,7 +34,11 @@
+ */
+ #ifndef KdTree_h
+ #define KdTree_h
++#if defined(__clang__) && defined(_LIBCPP_VERSION)
++#include <numeric>
++#elif defined(__GNUC__)
+ #include <ext/numeric>
++#endif
+
+ namespace Partio
+ {
+@@ -286,7 +290,11 @@
+
+ // assign sequential ids
+ _ids.resize(n);
++#if defined(__clang__) && defined(_LIBCPP_VERSION)
++ std::iota(_ids.begin(), _ids.end(), 0);
++#elif defined(__GNUC__)
+ __gnu_cxx::iota(_ids.begin(), _ids.end(), 0);
++#endif
+ // _ids.reserve(n);
+ // while ((int)_ids.size() < n) _ids.push_back(_ids.size());
+ _sorted = 0;
+
diff --git a/graphics/partio/pkg-descr b/graphics/partio/pkg-descr
new file mode 100644
index 000000000000..919edb51ebfa
--- /dev/null
+++ b/graphics/partio/pkg-descr
@@ -0,0 +1,6 @@
+Partio is a library for reading/writing/processing particle files for a wide
+range of tools and file formats. It acts as an abstraction for the
+commonalities in particle models (i.e. accessing many attributes associated
+with an index or entity).
+
+WWW: http://www.partio.us
diff --git a/graphics/partio/pkg-plist b/graphics/partio/pkg-plist
new file mode 100644
index 000000000000..158a23e4b4bf
--- /dev/null
+++ b/graphics/partio/pkg-plist
@@ -0,0 +1,122 @@
+bin/partattr
+bin/partconv
+bin/partinfo
+bin/partview
+include/Partio.h
+include/PartioAttribute.h
+include/PartioIterator.h
+lib/libpartio.a
+%%PYTHON_SITELIBDIR%%/_partio.so
+%%PYTHON_SITELIBDIR%%/partio.py
+%%PORTDOCS%%%%DOCSDIR%%/PartioAttribute_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/PartioAttribute_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/PartioIterator_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/PartioIterator_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/Partio_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/Partio_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/bc_s.png
+%%PORTDOCS%%%%DOCSDIR%%/bdwn.png
+%%PORTDOCS%%%%DOCSDIR%%/circleFigure.png
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticleAttribute-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticleAttribute.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticleIterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticleIterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesData-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesData.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesData.png
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesDataMutable-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesDataMutable.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesDataMutable.png
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesInfo-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesInfo.html
+%%PORTDOCS%%%%DOCSDIR%%/classPartio_1_1ParticlesInfo.png
+%%PORTDOCS%%%%DOCSDIR%%/classes.html
+%%PORTDOCS%%%%DOCSDIR%%/closed.png
+%%PORTDOCS%%%%DOCSDIR%%/cpptut.html
+%%PORTDOCS%%%%DOCSDIR%%/cpptut_8txt.html
+%%PORTDOCS%%%%DOCSDIR%%/dir_56764cded5a002c3f242069ae9b8ada5.html
+%%PORTDOCS%%%%DOCSDIR%%/dir_7524dcdf2b80aeb1f0178df7bece5e69.html
+%%PORTDOCS%%%%DOCSDIR%%/dir_a14c72e9508914f52e3a23f68290c4ed.html
+%%PORTDOCS%%%%DOCSDIR%%/doc_2CMakeLists_8txt.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/dynsections.js
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/ftv2blank.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2cl.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2doc.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2folderclosed.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2folderopen.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2lastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2link.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2mlastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2mnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2mo.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2node.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2ns.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2plastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2pnode.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2splitbar.png
+%%PORTDOCS%%%%DOCSDIR%%/ftv2vertline.png
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_rela.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_type.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/lib_2CMakeLists_8txt.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/license_8txt.html
+%%PORTDOCS%%%%DOCSDIR%%/main_8txt.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacePartio.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacemembers.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_func.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_type.html
+%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/nav_g.png
+%%PORTDOCS%%%%DOCSDIR%%/nav_h.png
+%%PORTDOCS%%%%DOCSDIR%%/open.png
+%%PORTDOCS%%%%DOCSDIR%%/pages.html
+%%PORTDOCS%%%%DOCSDIR%%/pytut.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1Data-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1Data.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01FLOAT_01_4-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01FLOAT_01_4.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01INDEXEDSTR_01_4-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01INDEXEDSTR_01_4.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01INT_01_4-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01INT_01_4.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01VECTOR_01_4-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ETYPE__TO__TYPE_3_01VECTOR_01_4.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1IS__SAME-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1IS__SAME.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1IS__SAME_3_01T_00_01T_01_4-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1IS__SAME_3_01T_00_01T_01_4.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1PROVIDER-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1PROVIDER.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1PROVIDER_3_01true_01_4-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1PROVIDER_3_01true_01_4.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ParticleAccessor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1ParticleAccessor.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1Provider-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structPartio_1_1Provider.html
+%%PORTDOCS%%%%DOCSDIR%%/sync_off.png
+%%PORTDOCS%%%%DOCSDIR%%/sync_on.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_a.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_b.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_h.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_s.png
+%%PORTDOCS%%%%DOCSDIR%%/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/tutorial_8txt.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%