aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-11-28 10:50:41 +0800
committermmoll <mmoll@FreeBSD.org>2015-11-28 10:50:41 +0800
commitb77521fd448c780ea3098e4933935943d27ecac3 (patch)
tree37b6b45557e86fd7c069e54ded7e587b78cb27af /graphics
parent4a86925186bf0649d8d672520d9590edcdb248f5 (diff)
downloadfreebsd-ports-gnome-b77521fd448c780ea3098e4933935943d27ecac3.tar.gz
freebsd-ports-gnome-b77521fd448c780ea3098e4933935943d27ecac3.tar.zst
freebsd-ports-gnome-b77521fd448c780ea3098e4933935943d27ecac3.zip
graphics/lensfun: fix build on arm
PR: 200028 Submitted by: Mikael Urankar <mikael.urankar@gmail.com> Approved by: danfe (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/lensfun/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index a01747c84230..e5732dfc98c7 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -18,6 +18,14 @@ USE_GNOME= glib20
USE_LDCONFIG= yes
CMAKE_ARGS= -DBUILD_AUXFUN:BOOL=ON -DINSTALL_HELPER_SCRIPTS:BOOL=OFF
+.if ! ${MACHINE_CPU:Msse} == "sse"
+CMAKE_ARGS+= -DBUILD_FOR_SSE:BOOL=OFF
+.endif
+
+.if ! ${MACHINE_CPU:Msse2} == "sse2"
+CMAKE_ARGS+= -DBUILD_FOR_SSE2:BOOL=OFF
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/pkgconfig/s,$${LIBDIR},libdata,' \
${WRKSRC}/libs/lensfun/CMakeLists.txt