aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:34:19 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:34:19 +0800
commitd252b8c59088431ca3dfc79efbffee22186a5992 (patch)
tree48e42623e6c9639fd7258a54397810971e6ecd61 /graphics
parent4665e776612f716c4cb8c002a284383b7c2d3af7 (diff)
downloadfreebsd-ports-gnome-d252b8c59088431ca3dfc79efbffee22186a5992.tar.gz
freebsd-ports-gnome-d252b8c59088431ca3dfc79efbffee22186a5992.tar.zst
freebsd-ports-gnome-d252b8c59088431ca3dfc79efbffee22186a5992.zip
[PATCH] graphics/ipe: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54929 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ipe/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 674ec227c21e..1fb60f896dd3 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -15,10 +15,24 @@ MASTER_SITES= ftp://ftp.cs.uni-magdeburg.de/pub/ipe/ \
MAINTAINER= bremner@unb.ca
COMMENT= Extensible drawing editor
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
latex:${PORTSDIR}/print/teTeX
USE_XLIB= yes
USE_MOTIF= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
.include <bsd.port.mk>