aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-05-21 17:55:59 +0800
committerdinoex <dinoex@FreeBSD.org>2010-05-21 17:55:59 +0800
commitdf605244cccc9a923d7f57acd89de4365247ac60 (patch)
tree5cb46a5761f921b10360ab3196171e486b6bf1dd /graphics
parent9b6b900671f08c8518dc71b575a8d4e1ae2d65e1 (diff)
downloadfreebsd-ports-gnome-df605244cccc9a923d7f57acd89de4365247ac60.tar.gz
freebsd-ports-gnome-df605244cccc9a923d7f57acd89de4365247ac60.tar.zst
freebsd-ports-gnome-df605244cccc9a923d7f57acd89de4365247ac60.zip
- update netpbm-devel to 10.35.74
Diffstat (limited to 'graphics')
-rw-r--r--graphics/netpbm-devel/files/Makefile.config.FreeBSD115
-rw-r--r--graphics/netpbm-devel/files/patch-GNUmakefile8
-rw-r--r--graphics/netpbm-devel/files/patch-cameratopam-identify.c26
-rw-r--r--graphics/netpbm-devel/files/patch-editor-pnmquant12
-rw-r--r--graphics/netpbm-devel/files/patch-lib-Makefile20
-rw-r--r--graphics/netpbm-devel/files/patch-lib-libpm.c8
-rw-r--r--graphics/netpbm-devel/files/patch-pm_config.in.h8
-rw-r--r--graphics/netpbm-devel/files/patch-pngtopnm.c23
-rw-r--r--graphics/netpbm-devel/files/patch-pnmtopng.c35
-rw-r--r--graphics/netpbm/Makefile14
-rw-r--r--graphics/netpbm/distinfo6
-rw-r--r--graphics/netpbm/pkg-plist11
12 files changed, 182 insertions, 104 deletions
diff --git a/graphics/netpbm-devel/files/Makefile.config.FreeBSD b/graphics/netpbm-devel/files/Makefile.config.FreeBSD
index 7d89a0d2704f..8aecf913ab5c 100644
--- a/graphics/netpbm-devel/files/Makefile.config.FreeBSD
+++ b/graphics/netpbm-devel/files/Makefile.config.FreeBSD
@@ -1,33 +1,124 @@
-DEFAULT_TARGET = nomerge
+# This is a make file inclusion, to be included in all the Netpbm make
+# files.
+
+DEFAULT_TARGET = nonmerge
+
BUILD_FIASCO = Y
-LD = ${CC}
-CC_FOR_BUILD = ${CC}
-LD_FOR_BUILD = ${CC}
-SYMLINK = ${LN} -sf
-LDFLAGS = -Wl,--rpath,$(NETPBMLIB_RUNTIME_DIR)
+
+LD = $(CC)
+
+LINKERISCOMPILER=Y
+
+LINKER_CAN_DO_EXPLICIT_LIBRARY=N
+
+INTTYPES_H = <inttypes.h>
+
+HAVE_INT64 = Y
+
+CC_FOR_BUILD = $(CC)
+LD_FOR_BUILD = $(LD)
+CFLAGS_FOR_BUILD = $(CFLAGS)
+
+INSTALL = $(SRCDIR)/buildtools/install.sh
+
+STRIPFLAG = -s
+
+SYMLINK = ln -s
+
+MANPAGE_FORMAT = nroff
+
+AR = ar
+RANLIB = ranlib
+
+LEX = flex
+
+EXE =
+
LDSHLIB = -shared -Wl,-soname,$(SONAME)
-CFLAGS_SHLIB = -fpic -DPIC
+
+LDRELOC = NONE
+
+CFLAGS_SHLIB =
+
+SHLIB_CLIB = -lc
+SHLIB_CLIB =
+
+NEED_RUNTIME_PATH = N
+
+RPATHOPTNAME = -rpath
+
+NETPBMLIB_RUNTIME_PATH =
+
TIFFLIB = ${LOCALBASE}/lib/libtiff.so
TIFFHDR_DIR = ${LOCALBASE}/include
+
+TIFFLIB_NEEDS_JPEG = Y
+TIFFLIB_NEEDS_Z = Y
+
JPEGLIB = ${LOCALBASE}/lib/libjpeg.so
JPEGHDR_DIR = ${LOCALBASE}/include
+
PNGLIB = ${LOCALBASE}/lib/libpng.so
PNGHDR_DIR = ${LOCALBASE}/include
+PNGVER =
+
ZLIB = /usr/lib/libz.so
ZHDR_DIR = /usr/include
+
JBIGLIB = ${LOCALBASE}/lib/libjbig.so
JBIGHDR_DIR = ${LOCALBASE}/include
-URTLIB = $(BUILDDIR)/urt/librle.a
-URTHDR_DIR = $(SRCDIR)/urt
+
+JASPERLIB = ${LOCALBASE}/lib/libjasper.so
JASPERHDR_DIR = ${LOCALBASE}/include
+JASPERDEPLIBS =
+
+URTLIB = $(BUILDDIR)/urt/librle.a
+URTHDR_DIR = $(SRCDIR)/urt
+
+X11LIB = ${LOCALBASE}/lib/libX11.so
+X11HDR_DIR = ${LOCALBASE}/include
+
LINUXSVGALIB = NONE
-LINUXSVGAHDR_DIR = NONE
+LINUXSVGAHDR_DIR =
+
+OMIT_NETWORK =
+
+NETWORKLD =
+
+VMS =
+
+DONT_HAVE_PROCESS_MGMT = N
+
+PKGDIR_DEFAULT = ${PREFIX}
+
+PKGMANDIR = man
+
+SUFFIXMANUALS1 = 1
+SUFFIXMANUALS3 = 3
+SUFFIXMANUALS5 = 5
+
NETPBMLIBTYPE = unixshared
+
NETPBMLIBSUFFIX = so
+
STATICLIB_TOO = y
+
STATICLIBSUFFIX = a
+
SHLIBPREFIXLIST = lib
+
NETPBMSHLIBPREFIX = $(firstword $(SHLIBPREFIXLIST))
-NETPBMLIB_RUNTIME_DIR = ${PREFIX}/lib
+
+DLLVER =
+
+NETPBM_DOCURL = http://netpbm.sourceforge.net/doc/
+
+DEFAULT_TARGET = nonmerge
+NETPBMLIBTYPE=unixshared
+NETPBMLIBSUFFIX=so
+STATICLIB_TOO=y
+LINKERISCOMPILER = Y
+CFLAGS_SHLIB += -fPIC -I..
+LDFLAGS+= -L${LOCALBASE}/lib
SOVER = 1
-pkgdir = ${PREFIX}
+
diff --git a/graphics/netpbm-devel/files/patch-GNUmakefile b/graphics/netpbm-devel/files/patch-GNUmakefile
index cee197cb978b..6601316b1dfa 100644
--- a/graphics/netpbm-devel/files/patch-GNUmakefile
+++ b/graphics/netpbm-devel/files/patch-GNUmakefile
@@ -1,11 +1,11 @@
---- GNUmakefile.orig Fri Jun 14 11:57:11 2002
-+++ GNUmakefile Tue Jun 18 00:00:00 2002
-@@ -236,7 +236,7 @@
+--- GNUmakefile.orig 2008-09-27 03:37:09.000000000 +0200
++++ GNUmakefile 2010-05-21 10:33:07.000000000 +0200
+@@ -361,7 +361,7 @@
install.hdr: $(PKGDIR)/include
$(MAKE) -C lib -f $(SRCDIR)/lib/Makefile \
SRCDIR=$(SRCDIR) BUILDDIR=$(BUILDDIR) install.hdr
- $(INSTALL) -c -m $(INSTALL_PERM_HDR) \
+ ${BSD_INSTALL_DATA} \
- $(SRCDIR)/pm_config.h $(PKGDIR)/include
+ $(BUILDDIR)/pm_config.h $(PKGDIR)/include
ifeq ($(STATICLIB_TOO),y)
diff --git a/graphics/netpbm-devel/files/patch-cameratopam-identify.c b/graphics/netpbm-devel/files/patch-cameratopam-identify.c
deleted file mode 100644
index 283a2480b9b6..000000000000
--- a/graphics/netpbm-devel/files/patch-cameratopam-identify.c
+++ /dev/null
@@ -1,26 +0,0 @@
-
-
-19 Mai 06:06 2006 diff -u -l converter/other/cameratopam/identify.c.orig converter/other/cameratopam/identify.c Page 1
-
-
---- converter/other/cameratopam/identify.c.orig Sat Aug 27 19:29:58 2005
-+++ converter/other/cameratopam/identify.c Fri May 19 06:06:28 2006
-@@ -25,7 +25,7 @@
-
-
- /* This does the same as the function of the same name in the GNU C library */
--static const char *memmem (const char *haystack, size_t haystacklen,
-+static const char *memmem_old (const char *haystack, size_t haystacklen,
- const char *needle, size_t needlelen)
- {
- const char *c;
-@@ -316,7 +316,7 @@
- fread (head, 1, 32, ifp);
- fseek (ifp, 0, SEEK_END);
- fsize = ftell(ifp);
-- if ((c = (char*)memmem (head, 32, "MMMMRawT", 8))) {
-+ if ((c = (char*)memmem_old (head, 32, "MMMMRawT", 8))) {
- strcpy (make, "Phase One");
- data_offset = c - head;
- fseek (ifp, data_offset + 8, SEEK_SET);
-
diff --git a/graphics/netpbm-devel/files/patch-editor-pnmquant b/graphics/netpbm-devel/files/patch-editor-pnmquant
index 60019a46e93f..3a0f3f2579fd 100644
--- a/graphics/netpbm-devel/files/patch-editor-pnmquant
+++ b/graphics/netpbm-devel/files/patch-editor-pnmquant
@@ -1,6 +1,6 @@
---- editor/pnmquant.orig Sun Feb 19 22:03:42 2006
-+++ editor/pnmquant Mon Feb 20 09:41:57 2006
-@@ -116,7 +118,7 @@
+--- editor/pnmquant.orig 2006-08-19 05:12:28.000000000 +0200
++++ editor/pnmquant 2010-05-21 10:37:10.000000000 +0200
+@@ -149,7 +149,7 @@
tell(INFH); # Avoids bogus "INFH is not referenced" warning
}
} else {
@@ -9,12 +9,12 @@
or die("Unable to open input file '$infile'. Errno=$ERRNO");
}
}
-@@ -157,7 +159,7 @@
- $spreadOpt = "-spreadbrightness";
+@@ -194,7 +194,7 @@
+ push(@options, '-quiet');
}
- open(STDOUT, ">", $mapfileSpec);
+ open(STDOUT, ">" . $mapfileSpec);
- my $maprc = system("pnmcolormap", $ncolors, $averageOpt, $spreadOpt);
+ my $maprc = system("pnmcolormap", $ncolors, @options);
diff --git a/graphics/netpbm-devel/files/patch-lib-Makefile b/graphics/netpbm-devel/files/patch-lib-Makefile
index 3282ae35c9aa..4ed3dec176b2 100644
--- a/graphics/netpbm-devel/files/patch-lib-Makefile
+++ b/graphics/netpbm-devel/files/patch-lib-Makefile
@@ -1,17 +1,17 @@
---- lib/Makefile.orig 2005-12-03 17:52:33.000000000 +0100
-+++ lib/Makefile 2008-01-17 11:05:04.000000000 +0100
-@@ -36,6 +36,8 @@
+--- lib/Makefile.orig 2009-09-18 21:04:37.000000000 +0200
++++ lib/Makefile 2010-05-21 10:36:08.000000000 +0200
+@@ -42,6 +42,8 @@
# Library objects to be linked but not built by Makefile.common:
- LIBOBJECTS_X = util/shhopt.o util/nstring.o
+ LIBOBJECTS_X = util/shhopt.o util/nstring.o util/filename.o
+SHLIBOBJECTS = $(patsubst %.o, %.lo, $(LIBOBJECTS))
+
MANUALS3 = libnetpbm
MANUALS5 = pbm pgm ppm pnm pam
-@@ -79,13 +81,17 @@
+@@ -80,13 +82,17 @@
- $(LIBOBJECTS): %.o: %.c $(HEADERLINKS)
+ $(LIBOBJECTS): %.o: %.c importinc
# Note that the user may have configured -I options into CFLAGS.
+ $(CC) -c $(INCLUDES) -DNDEBUG $(CFLAGS) \
+ $(CFLAGS_PERSONAL) $(CADD) -o $@ $<
@@ -28,7 +28,7 @@
ifeq ($(NETPBMLIBTYPE),irixshared)
# The libxxx.so link is needed to link the executables.
-@@ -110,11 +116,8 @@
+@@ -113,11 +119,8 @@
# The $(SONAME) link is needed only to test the programs without
# installing the libraries (in that case, you also need to direct the
# dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
@@ -39,10 +39,10 @@
- $(LD) $(LDSHLIB) -o $@ $(LIBOBJECTS) $(LIBOBJECTS_X) \
+$(SONAME): $(SHLIBOBJECTS) $(LIBOBJECTS_X)
+ $(LD) $(LDSHLIB) -o $@ $(SHLIBOBJECTS) $(LIBOBJECTS_X) \
- $(SHLIB_CLIB) $(LADD)
+ $(SHLIB_CLIB) -lm $(LADD)
endif
-@@ -208,13 +211,10 @@
+@@ -205,13 +208,10 @@
.PHONY: install.lib
ifeq ($(NETPBMLIBTYPE),unixshared)
# install a Unix-style shared library
@@ -60,7 +60,7 @@
endif
ifeq ($(NETPBMLIBTYPE),dll)
#install a Windows DLL shared library
-@@ -244,23 +244,23 @@
+@@ -241,23 +241,23 @@
# directory when you compile your programs.
%_installhdr: $(PKGDIR)/include
diff --git a/graphics/netpbm-devel/files/patch-lib-libpm.c b/graphics/netpbm-devel/files/patch-lib-libpm.c
index a39128efa590..7c805f039462 100644
--- a/graphics/netpbm-devel/files/patch-lib-libpm.c
+++ b/graphics/netpbm-devel/files/patch-lib-libpm.c
@@ -1,6 +1,6 @@
---- lib/libpm.c~ Sun Nov 21 03:55:27 2004
-+++ lib/libpm.c Sat Mar 19 12:39:00 2005
-@@ -617,7 +617,7 @@
+--- lib/libpm.c.orig 2006-08-19 05:12:28.000000000 +0200
++++ lib/libpm.c 2010-05-21 10:37:10.000000000 +0200
+@@ -669,7 +669,7 @@
pm_openr(const char * const name) {
FILE* f;
@@ -9,7 +9,7 @@
f = stdin;
else {
#ifndef VMS
-@@ -639,7 +639,7 @@
+@@ -691,7 +691,7 @@
pm_openw(const char * const name) {
FILE* f;
diff --git a/graphics/netpbm-devel/files/patch-pm_config.in.h b/graphics/netpbm-devel/files/patch-pm_config.in.h
index 21e6d984c5b4..1ccdafc6a9c2 100644
--- a/graphics/netpbm-devel/files/patch-pm_config.in.h
+++ b/graphics/netpbm-devel/files/patch-pm_config.in.h
@@ -1,5 +1,5 @@
---- pm_config.in.h.orig Sat Jul 24 04:40:06 2004
-+++ pm_config.in.h Tue Aug 17 16:53:30 2004
+--- pm_config.in.h.orig 2006-10-18 20:29:13.000000000 +0200
++++ pm_config.in.h 2010-05-21 10:37:50.000000000 +0200
@@ -15,6 +15,10 @@
**************************************************************************/
@@ -11,12 +11,12 @@
#if defined(USG) || defined(SVR4) || defined(VMS) || defined(__SVR4)
#define SYSV
#endif
-@@ -99,9 +103,9 @@
+@@ -67,9 +71,9 @@
#define RGB_DB2 "PBMplus_Dir:RGB.TXT"
#define RGB_DB3 "PBMplus_Dir:RGB.TXT"
#else
-#define RGB_DB1 "/usr/lib/X11/rgb.txt"
--#define RGB_DB2 "/usr/openwin/lib/rgb.txt"
+-#define RGB_DB2 "/usr/share/X11/rgb.txt"
-#define RGB_DB3 "/usr/X11R6/lib/X11/rgb.txt"
+#define RGB_DB1 "%%PREFIX%%/share/netpbm/rgb.txt"
+#define RGB_DB2 "%%LOCALBASE%%/share/netpbm/rgb.txt"
diff --git a/graphics/netpbm-devel/files/patch-pngtopnm.c b/graphics/netpbm-devel/files/patch-pngtopnm.c
index 18c697df8947..b5387857e1b2 100644
--- a/graphics/netpbm-devel/files/patch-pngtopnm.c
+++ b/graphics/netpbm-devel/files/patch-pngtopnm.c
@@ -1,6 +1,15 @@
---- converter/other/pngtopnm.c.orig 2005-10-29 19:40:03.000000000 +0200
-+++ converter/other/pngtopnm.c 2010-03-28 12:40:36.000000000 +0200
-@@ -467,7 +467,7 @@
+--- converter/other/pngtopnm.c.orig 2009-09-03 17:34:36.000000000 +0200
++++ converter/other/pngtopnm.c 2010-05-21 11:24:05.000000000 +0200
+@@ -44,7 +44,7 @@
+ #include "nstring.h"
+ #include "shhopt.h"
+
+-#if PNG_LIBPNG_VER >= 10400
++#if 0
+ #error Your PNG library (<png.h>) is incompatible with this Netpbm source code.
+ #error You need either an older PNG library (older than 1.4)
+ #error newer Netpbm source code (at least 10.48)
+@@ -482,7 +482,7 @@
bool retval;
if (info_ptr->valid & PNG_INFO_tRNS) {
@@ -9,7 +18,7 @@
/* There seems to be a problem here: you can't compare real
-@@ -558,8 +558,8 @@
+@@ -575,8 +575,8 @@
for (i = 0, foundGray = FALSE;
i < info_ptr->num_trans && !foundGray;
++i) {
@@ -20,7 +29,7 @@
foundGray = TRUE;
}
}
-@@ -630,7 +630,7 @@
+@@ -647,7 +647,7 @@
unsigned int i;
trans_mix = TRUE;
for (i = 0; i < info_ptr->num_trans; ++i)
@@ -29,7 +38,7 @@
trans_mix = FALSE;
break;
}
-@@ -874,7 +874,7 @@
+@@ -885,7 +885,7 @@
setXel(&xelrow[col], fgColor, bgColor, alpha_handling,
((info_ptr->valid & PNG_INFO_tRNS) &&
(fgColor.r ==
@@ -38,7 +47,7 @@
totalgamma))) ?
0 : maxval);
}
-@@ -903,7 +903,7 @@
+@@ -914,7 +914,7 @@
setXel(&xelrow[col], fgColor, bgColor, alpha_handling,
(info_ptr->valid & PNG_INFO_tRNS) &&
index < info_ptr->num_trans ?
diff --git a/graphics/netpbm-devel/files/patch-pnmtopng.c b/graphics/netpbm-devel/files/patch-pnmtopng.c
index 50038430f508..14ed8ff7c123 100644
--- a/graphics/netpbm-devel/files/patch-pnmtopng.c
+++ b/graphics/netpbm-devel/files/patch-pnmtopng.c
@@ -1,24 +1,15 @@
---- converter/other/pnmtopng.c.orig 2005-10-16 21:36:43.000000000 +0200
-+++ converter/other/pnmtopng.c 2010-03-28 12:43:18.000000000 +0200
-@@ -267,7 +267,7 @@
- unsigned int option_def_index;
+--- converter/other/pnmtopng.c.orig 2009-09-03 17:34:36.000000000 +0200
++++ converter/other/pnmtopng.c 2010-05-21 10:45:59.000000000 +0200
+@@ -69,7 +69,7 @@
+ #include "nstring.h"
+ #include "version.h"
- unsigned int alphaSpec, transparentSpec, backgroundSpec;
-- unsigned int textSpec, ztxtSpec, modtimeSpec, paletteSpec;
-+ unsigned int textSpec, ztxtSpec, paletteSpec;
- unsigned int filterSpec;
-
- unsigned int nofilter, sub, up, avg, paeth, filter;
-@@ -296,7 +296,7 @@
- OPTENT3(0, "ztxt", OPT_STRING, &cmdlineP->ztxt,
- &ztxtSpec, 0);
- OPTENT3(0, "modtime", OPT_STRING, &modtime,
-- &modtimeSpec, 0);
-+ &cmdlineP->modtimeSpec,0);
- OPTENT3(0, "palette", OPT_STRING, &cmdlineP->palette,
- &paletteSpec, 0);
- OPTENT3(0, "compression", OPT_UINT,
-@@ -2486,7 +2486,7 @@
+-#if PNG_LIBPNG_VER >= 10400
++#if 0
+ #error Your PNG library (<png.h>) is incompatible with this Netpbm source code.
+ #error You need either an older PNG library (older than 1.4)
+ #error newer Netpbm source code (at least 10.48)
+@@ -2611,7 +2611,7 @@
info_ptr->num_palette = palette_size;
if (trans_size > 0) {
info_ptr->valid |= PNG_INFO_tRNS;
@@ -27,7 +18,7 @@
info_ptr->num_trans = trans_size; /* omit opaque values */
}
/* creating hIST chunk */
-@@ -2523,7 +2523,7 @@
+@@ -2648,7 +2648,7 @@
info_ptr->color_type == PNG_COLOR_TYPE_RGB) {
if (transparent > 0) {
info_ptr->valid |= PNG_INFO_tRNS;
@@ -36,7 +27,7 @@
xelToPngColor_16(transcolor, maxval, png_maxval);
}
} else {
-@@ -2535,10 +2535,10 @@
+@@ -2660,10 +2660,10 @@
if (info_ptr->valid && PNG_INFO_tRNS)
pm_message("Transparent color {gray, red, green, blue} = "
"{%d, %d, %d, %d}",
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 122a980f1205..9dd0023cd639 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -40,15 +40,16 @@ USE_LDCONFIG= yes
MAN1= netpbm.1
STABLE_PORTVERSION= 10.26.64
-DEVEL_PORTVERSION= 10.31
+DEVEL_PORTVERSION= 10.35.74
.if defined(WITH_NETPBM_DEVEL)
-MASTER_SITES= SF/netpbm/archive_of_old_release_system/${PORTVERSION}
+MASTER_SITES= SF/netpbm/super_stable/${DEVEL_PORTVERSION}
NETPBM_PORTVERSION= ${DEVEL_PORTVERSION}
-PORTREVISION= 4
+PORTREVISION= 0
NETPBM_SUFFIX= -devel
-CONFLICTS+= netpbm-10.26.*
+#CONFLICTS+= netpbm-10.26.*
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
PATCHDIR?= ${MASTERDIR}/../netpbm-devel/files
+USE_XORG= x11
CFLAGS+= -Iutil
PLIST_SUB+= DEVEL=""
.else
@@ -66,9 +67,12 @@ pre-configure:
@${REINPLACE_CMD} -e 's|<shhopt.h>|<pm_shhopt.h>|g' ${WRKSRC}/lib/pm.h
@${REINPLACE_CMD} -e 's| jpeg2000||g' \
${WRKSRC}/converter/other/Makefile
- @${CP} ${FILESDIR}/Makefile.config.FreeBSD ${WRKSRC}/Makefile.config
+ @${CP} ${PATCHDIR}/Makefile.config.FreeBSD ${WRKSRC}/Makefile.config
@${LN} -sf ${WRKSRC}/lib/util/shhopt.h ${WRKSRC}/lib/util/pm_shhopt.h
@${LN} -sf ${WRKSRC}/lib/util/nstring.h ${WRKSRC}/lib/util/pm_nstring.h
+.if defined(WITH_NETPBM_DEVEL)
+ cd ${WRKSRC} && buildtools/stamp-date > ${WRKSRC}/lib/compile.h
+.endif
post-install:
@${ECHO_MSG} "===> Installing man pages..."
diff --git a/graphics/netpbm/distinfo b/graphics/netpbm/distinfo
index f326ee88a686..a5d8c4b9ca33 100644
--- a/graphics/netpbm/distinfo
+++ b/graphics/netpbm/distinfo
@@ -1,6 +1,6 @@
MD5 (netpbm-10.26.64.tgz) = a895f002d8e20bc68d003ee772db76f1
SHA256 (netpbm-10.26.64.tgz) = 1cf89173f141e2e8f46c54b9537f344c874f8e3ffd1d41a95d41de02d927257b
SIZE (netpbm-10.26.64.tgz) = 2545993
-MD5 (netpbm-10.31.tgz) = 6ba2e0ee998eb23f4620ec9c175a90b6
-SHA256 (netpbm-10.31.tgz) = f954261ebb9765a03d015949e5dc913cfcce5b4f661e334004936c9cdf2e5ee6
-SIZE (netpbm-10.31.tgz) = 2383586
+MD5 (netpbm-10.35.74.tgz) = 86b74489f59708aa4a43119a47f751ea
+SHA256 (netpbm-10.35.74.tgz) = 92f9241958b8dd7ef2cfccf7fec29075b001aac6ab96aaf1824ab07f71793bbb
+SIZE (netpbm-10.35.74.tgz) = 2548702
diff --git a/graphics/netpbm/pkg-plist b/graphics/netpbm/pkg-plist
index 6ed46f52ec31..ff884373ab39 100644
--- a/graphics/netpbm/pkg-plist
+++ b/graphics/netpbm/pkg-plist
@@ -45,6 +45,7 @@ bin/pamchannel
bin/pamcomp
bin/pamcut
bin/pamdeinterlace
+%%DEVEL%%bin/pamdepth
bin/pamdice
bin/pamditherbw
bin/pamedge
@@ -75,6 +76,7 @@ bin/pamstretch
bin/pamstretch-gen
bin/pamsumm
bin/pamsummcol
+%%DEVEL%%bin/pamthreshold
%%DEVEL%%bin/pamtilt
bin/pamtodjvurle
%%DEVEL%%bin/pamtofits
@@ -82,9 +84,12 @@ bin/pamtohdiff
bin/pamtohtmltbl
bin/pamtopfm
bin/pamtopnm
+%%DEVEL%%bin/pamtosvg
bin/pamtotga
%%DEVEL%%bin/pamtotiff
bin/pamtouil
+%%DEVEL%%bin/pamtoxvmini
+%%DEVEL%%bin/pamx
bin/pbmclean
bin/pbmlife
bin/pbmmake
@@ -137,10 +142,13 @@ bin/pfmtopam
bin/pgmabel
bin/pgmbentley
bin/pgmcrater
+%%DEVEL%%bin/pgmdeshadow
bin/pgmedge
bin/pgmenhance
bin/pgmhist
bin/pgmkernel
+%%DEVEL%%bin/pgmmake
+%%DEVEL%%bin/pgmmedian
bin/pgmminkowski
bin/pgmmorphconv
bin/pgmnoise
@@ -150,7 +158,6 @@ bin/pgmramp
bin/pgmslice
bin/pgmtexture
bin/pgmtofs
-%%DEVEL%%bin/pgmmedian
bin/pgmtolispm
bin/pgmtopbm
bin/pgmtopgm
@@ -287,6 +294,7 @@ bin/rasttopnm
bin/rawtopgm
bin/rawtoppm
bin/rgb3toppm
+%%DEVEL%%bin/rlatopam
bin/rletopnm
bin/sbigtopgm
bin/sgitopnm
@@ -295,6 +303,7 @@ bin/sldtoppm
bin/spctoppm
bin/spottopgm
bin/sputoppm
+%%DEVEL%%bin/svgtopam
bin/tgatoppm
bin/thinkjettopbm
bin/tifftopnm