aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-23 17:17:47 +0800
committermiwi <miwi@FreeBSD.org>2009-04-23 17:17:47 +0800
commite2e65fb12739f728c175ef3bd3a6c08813f3599c (patch)
tree95e397fe086647c5466192816a8d7e7fd09df366 /graphics
parent15254b96a47ea3d16234eabdf49fefdbbb0010bb (diff)
downloadfreebsd-ports-gnome-e2e65fb12739f728c175ef3bd3a6c08813f3599c.tar.gz
freebsd-ports-gnome-e2e65fb12739f728c175ef3bd3a6c08813f3599c.tar.zst
freebsd-ports-gnome-e2e65fb12739f728c175ef3bd3a6c08813f3599c.zip
Deegree is a Java Framework offering the main building blocks for
Spatial Data Infrastructures (SDIs). Its entire architecture is developed using standards of the Open Geospatial Consortium (OGC) and ISO Technical Committee 211-Geographic information/Geoinformatics (ISO/TC 211). deegree encompasses OGC Web Services as well as clients. deegree is Free Software protected by the GNU Lesser General Public License (GNU LGPL) and is accessible at http://www.deegree.org. Deegree's Web Catalogue Service implementation (Catalogue Service - Web profile, therefore CS-W) is able to serve different metadata formats in parallel based on the same physical datastore. This is possible because deegree CS-W uses XSLT processing to transform requests as well as responses into the desired format. deegree CS-W does not contain its a data access modul of its own. It uses an OGC WFS (at the moment limited to deegree WFS) as datasource. So in future it will be possible to use deegree CS-W on top of any other OGC compliant WFS to offer catalogue functionalities. WWW: http://www.deegree.org/ PR: ports/133802 Submitted by: wenheping at gmail.com
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/deegree-csw/Makefile46
-rw-r--r--graphics/deegree-csw/distinfo3
-rw-r--r--graphics/deegree-csw/pkg-descr19
-rw-r--r--graphics/deegree-csw/pkg-message10
5 files changed, 79 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 5064233097f5..b48c457dd9ff 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -90,6 +90,7 @@
SUBDIR += dc20pack
SUBDIR += dc3play
SUBDIR += dcraw
+ SUBDIR += deegree-csw
SUBDIR += demeter
SUBDIR += devil
SUBDIR += dia
diff --git a/graphics/deegree-csw/Makefile b/graphics/deegree-csw/Makefile
new file mode 100644
index 000000000000..b0cd9d88eb7f
--- /dev/null
+++ b/graphics/deegree-csw/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-csw
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= csw
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Deegree Catalogue Service(CSW)
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+PLIST_FILES= ${TOMCATVER}/webapps/deegree-csw.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 deegree-csw.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_CSW.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_csw_2.0.2_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/deegree-csw/distinfo b/graphics/deegree-csw/distinfo
new file mode 100644
index 000000000000..b520dd8bee91
--- /dev/null
+++ b/graphics/deegree-csw/distinfo
@@ -0,0 +1,3 @@
+MD5 (deegree-csw_v2_2.zip) = f7c0f5098e07a5a26f2df6c6188aa038
+SHA256 (deegree-csw_v2_2.zip) = 3ae55a414cbd150173847d0e8533fd919439b6d8a1410e0d44eb686b6718a679
+SIZE (deegree-csw_v2_2.zip) = 14367755
diff --git a/graphics/deegree-csw/pkg-descr b/graphics/deegree-csw/pkg-descr
new file mode 100644
index 000000000000..b7779ded7376
--- /dev/null
+++ b/graphics/deegree-csw/pkg-descr
@@ -0,0 +1,19 @@
+Deegree is a Java Framework offering the main building blocks for
+Spatial Data Infrastructures (SDIs). Its entire architecture is
+developed using standards of the Open Geospatial Consortium (OGC) and
+ISO Technical Committee 211-Geographic information/Geoinformatics
+(ISO/TC 211). deegree encompasses OGC Web Services as well as clients.
+deegree is Free Software protected by the GNU Lesser General Public
+License (GNU LGPL) and is accessible at http://www.deegree.org.
+
+Deegree's Web Catalogue Service implementation (Catalogue Service - Web
+profile, therefore CS-W) is able to serve different metadata formats in
+parallel based on the same physical datastore. This is possible because
+deegree CS-W uses XSLT processing to transform requests as well as
+responses into the desired format. deegree CS-W does not contain its a
+data access modul of its own. It uses an OGC WFS (at the moment limited
+to deegree WFS) as datasource. So in future it will be possible to use
+deegree CS-W on top of any other OGC compliant WFS to offer catalogue
+functionalities.
+
+WWW: http://www.deegree.org/
diff --git a/graphics/deegree-csw/pkg-message b/graphics/deegree-csw/pkg-message
new file mode 100644
index 000000000000..13df82f03621
--- /dev/null
+++ b/graphics/deegree-csw/pkg-message
@@ -0,0 +1,10 @@
+==========================================================================
+To start DeeGree correctly, please set the variable JAVA_OPTS with:
+
+setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
+
+Now you should start your Tomcat server and browse with:
+ http://your-server:8180/deegree-wcs
+
+Enjoy it !
+==========================================================================