aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
committerbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
commite6b8ed87b5e99e0ddfa7f575594f03f1992cf201 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /graphics
parent729d5d5ddb37fd2035af319a95b99466360a2e7e (diff)
downloadfreebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.gz
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.zst
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/grafx2/Makefile3
-rw-r--r--graphics/lua-gd/Makefile5
-rw-r--r--graphics/podofo/Makefile6
3 files changed, 4 insertions, 10 deletions
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index b6ba738bace3..6f3dfa9a8dfa 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -33,8 +33,7 @@ MAKE_ARGS+= NOTTF=1
.endif
.if ${PORT_OPTIONS:MLUA}
-USES+= pkgconfig
-USE_LUA= 5.1
+USES+= lua:51 pkgconfig
.else
MAKE_ARGS+= NOLUA=1
.endif
diff --git a/graphics/lua-gd/Makefile b/graphics/lua-gd/Makefile
index e049d64e09c0..6aa1230d86f2 100644
--- a/graphics/lua-gd/Makefile
+++ b/graphics/lua-gd/Makefile
@@ -16,10 +16,9 @@ LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_LUA= 5.1
-
+USES= lua:51
CFLAGS+= -I${LUA_INCDIR} -I${LOCALBASE}/include
-LDFLAGS+= -shared -L${LOCALBASE}/lib -lgd -L${LUA_LIBDIR} -llua -lm
+LDFLAGS+= -shared -L${LOCALBASE}/lib -lgd -L${LUA_LIBDIR} -llua-${LUA_VER} -lm
GDFEATURES= `gdlib-config --features |sed -e "s/GD_/-DGD_/g"`
.include <bsd.port.options.mk>
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 8c316e5e283b..de19e6e9bf0b 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -43,10 +43,6 @@ PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
TIFF_CMAKE_ON= -DWANT_TIFF:BOOL=TRUE
TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMPOSE}
-USE_LUA= 5.1
-.endif
+IMPOSE_USES= lua:51
.include <bsd.port.mk>