aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-03-07 16:49:02 +0800
committerpi <pi@FreeBSD.org>2016-03-07 16:49:02 +0800
commitec540261ecc360b8f9ca375212e637556bd74b14 (patch)
tree775434e1785edfaa1bc617aa89bf04bcf2cdb067 /graphics
parent9868cb83e7c15ad9f6601a2d1da631c98671d176 (diff)
downloadfreebsd-ports-gnome-ec540261ecc360b8f9ca375212e637556bd74b14.tar.gz
freebsd-ports-gnome-ec540261ecc360b8f9ca375212e637556bd74b14.tar.zst
freebsd-ports-gnome-ec540261ecc360b8f9ca375212e637556bd74b14.zip
New port: graphics/libyuv
libyuv is an open source project that includes YUV scaling and conversion functionality. - Prepare content for compression, with point, bilinear or box filter. - Convert to YUV from webcam formats. - Convert from YUV to formats for rendering/effects. - Rotate by 90/180/270 degrees to adjust for mobile devices in portrait mode. - Optimized versions for SSE2/SSSE3/AVX2 on x86/x64, Neon on Arm, DSP R2 Mips are possible. WWW: https://chromium.googlesource.com/libyuv/libyuv/ PR: 205680, 204958 Submitted by: Corey Smith <corsmith@gmail.com>, numisemis@yahoo.com
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libyuv/Makefile18
-rw-r--r--graphics/libyuv/distinfo2
-rw-r--r--graphics/libyuv/files/patch-Makefile26
-rw-r--r--graphics/libyuv/pkg-descr11
-rw-r--r--graphics/libyuv/pkg-plist21
6 files changed, 79 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 53026351bf61..423774b9d37b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -540,6 +540,7 @@
SUBDIR += libwmf-nox11
SUBDIR += libwpg
SUBDIR += libwpg03
+ SUBDIR += libyuv
SUBDIR += lightzone
SUBDIR += linplasma
SUBDIR += linux-adobesvg
diff --git a/graphics/libyuv/Makefile b/graphics/libyuv/Makefile
new file mode 100644
index 000000000000..bbaf36252b5a
--- /dev/null
+++ b/graphics/libyuv/Makefile
@@ -0,0 +1,18 @@
+# Created by: Corey Smith <corsmith@gmail.com>
+# $FreeBSD$
+
+PORTNAME= libyuv
+DISTVERSION= 0.0.1280
+CATEGORIES= graphics
+MASTER_SITES= http://files.freeswitch.org/downloads/libs/
+
+MAINTAINER= corsmith@gmail.com
+COMMENT= Library for freeswitch yuv graphics manipulation
+
+LICENSE= BSD3CLAUSE
+
+MAKE_JOBS_UNSAFE= yes
+CXXFLAGS+= -fPIC
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/libyuv/distinfo b/graphics/libyuv/distinfo
new file mode 100644
index 000000000000..50e5a0533500
--- /dev/null
+++ b/graphics/libyuv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libyuv-0.0.1280.tar.gz) = 97a30b87cbea5a35222cc1071ecb78562245b7c457baa26f41beba8af85861ef
+SIZE (libyuv-0.0.1280.tar.gz) = 297636
diff --git a/graphics/libyuv/files/patch-Makefile b/graphics/libyuv/files/patch-Makefile
new file mode 100644
index 000000000000..66a0e5a868c0
--- /dev/null
+++ b/graphics/libyuv/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig 2015-06-19 22:04:28 UTC
++++ Makefile
+@@ -1,9 +1,9 @@
+ # This is a generic makefile for libyuv for gcc.
+ # make -f linux.mk CXX=clang++
+
+-PREFIX:=/usr
+ EXEC_PREFIX:=$(PREFIX)
+ LIBDIR:=$(PREFIX)/lib/
++LIBDATA:=$(PREFIX)/libdata/
+ INCDIR:=$(PREFIX)/include/
+
+ CXX?=g++
+@@ -63,10 +63,10 @@ install: libyuv.a libyuv.so libyuv.pc
+ install -d -m 755 $(DESTDIR)/$(LIBDIR)
+ install -d -m 755 $(DESTDIR)/$(INCDIR)
+ install -d -m 755 $(DESTDIR)/$(INCDIR)/libyuv
+- install -d -m 755 $(DESTDIR)/$(LIBDIR)/pkgconfig
++ install -d -m 755 $(DESTDIR)/$(LIBDATA)/pkgconfig
+ install -m 644 libyuv.a $(DESTDIR)/$(LIBDIR)
+ install -m 644 libyuv.so $(DESTDIR)/$(LIBDIR)
+- install -m 644 libyuv.pc $(DESTDIR)/$(LIBDIR)/pkgconfig
++ install -m 644 libyuv.pc $(DESTDIR)/$(LIBDATA)/pkgconfig
+ install -m 644 include/libyuv.h $(DESTDIR)/$(INCDIR)
+ install -m 644 include/libyuv/* $(DESTDIR)/$(INCDIR)/libyuv
+
diff --git a/graphics/libyuv/pkg-descr b/graphics/libyuv/pkg-descr
new file mode 100644
index 000000000000..e2c25f70cf6d
--- /dev/null
+++ b/graphics/libyuv/pkg-descr
@@ -0,0 +1,11 @@
+libyuv is an open source project that includes YUV scaling and conversion
+functionality.
+
+- Prepare content for compression, with point, bilinear or box filter.
+- Convert to YUV from webcam formats.
+- Convert from YUV to formats for rendering/effects.
+- Rotate by 90/180/270 degrees to adjust for mobile devices in portrait mode.
+- Optimized versions for SSE2/SSSE3/AVX2 on x86/x64,
+ Neon on Arm, DSP R2 Mips are possible.
+
+WWW: https://chromium.googlesource.com/libyuv/libyuv/
diff --git a/graphics/libyuv/pkg-plist b/graphics/libyuv/pkg-plist
new file mode 100644
index 000000000000..dadff1558ed5
--- /dev/null
+++ b/graphics/libyuv/pkg-plist
@@ -0,0 +1,21 @@
+include/libyuv.h
+include/libyuv/basic_types.h
+include/libyuv/compare.h
+include/libyuv/convert.h
+include/libyuv/convert_argb.h
+include/libyuv/convert_from.h
+include/libyuv/convert_from_argb.h
+include/libyuv/cpu_id.h
+include/libyuv/mjpeg_decoder.h
+include/libyuv/planar_functions.h
+include/libyuv/rotate.h
+include/libyuv/rotate_argb.h
+include/libyuv/row.h
+include/libyuv/scale.h
+include/libyuv/scale_argb.h
+include/libyuv/scale_row.h
+include/libyuv/version.h
+include/libyuv/video_common.h
+lib/libyuv.a
+lib/libyuv.so
+libdata/pkgconfig/libyuv.pc