aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-12-26 07:29:34 +0800
committerantoine <antoine@FreeBSD.org>2013-12-26 07:29:34 +0800
commitfc17e550eddef887d6e1b70a8e7fc9f06056b731 (patch)
tree5d26acd476642c3b773f75db8040205ff9dc4d29 /graphics
parent4c3b90b6bb5bdc235ec60ac72877f1ee418fe1cd (diff)
downloadfreebsd-ports-gnome-fc17e550eddef887d6e1b70a8e7fc9f06056b731.tar.gz
freebsd-ports-gnome-fc17e550eddef887d6e1b70a8e7fc9f06056b731.tar.zst
freebsd-ports-gnome-fc17e550eddef887d6e1b70a8e7fc9f06056b731.zip
Convert the tree to USES=openal
Approved by: portmgr (bapt)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Coin/Makefile2
-rw-r--r--graphics/blender/Makefile2
-rw-r--r--graphics/py-pyglet/Makefile2
-rw-r--r--graphics/py-soya3d/Makefile3
-rw-r--r--graphics/reallyslick/Makefile2
5 files changed, 5 insertions, 6 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index fade18fd9501..51c1ebbfc8a7 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -16,7 +16,7 @@ LICENSE= BSD
LIB_DEPENDS= libsimage.so:${PORTSDIR}/graphics/simage
USE_GCC= any
-USE_OPENAL= al
+USES= openal:al
USE_GL= yes
USE_XORG= xt x11
GNU_CONFIGURE= yes
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index f915a1d9cc87..e6e14b2e2a9b 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -172,7 +172,7 @@ CMAKE_ARGS+= -DWITH_HEADLESS:BOOL=OFF
.if ${PORT_OPTIONS:MOPENAL}
.if ${PORT_OPTIONS:MSAMPLERATE}
-USE_OPENAL= al alut
+USES+= openal:al,alut
CMAKE_ARGS+= -DWITH_OPENAL:BOOL=ON
.else
BROKEN= OPENAL requires SAMPLERATE
diff --git a/graphics/py-pyglet/Makefile b/graphics/py-pyglet/Makefile
index 2f5564f75d16..f1635fa831aa 100644
--- a/graphics/py-pyglet/Makefile
+++ b/graphics/py-pyglet/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_GL= gl glu
-USE_OPENAL= al
+USES= openal:al
PORTDOCS= *
PORTEXAMPLES= *
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 825f12f38614..3ca647f75a2c 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -25,9 +25,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/editobj/editor.py:${PORTSDIR}/graphics/py-edit
USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_OPENAL= al alut
+USES= gmake openal:al,alut
USE_GL= glew glu
-USE_GMAKE= yes
USE_SDL= sdl
PYDISTUTILS_PKGNAME= Soya
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 2753cca66196..dfbea49067c6 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -36,7 +36,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFREEALUT}
-USE_OPENAL= alut
+USES+= openal:alut
.else
CONFIGURE_ARGS+= --disable-sound
.endif