aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2012-10-07 19:29:24 +0800
committercs <cs@FreeBSD.org>2012-10-07 19:29:24 +0800
commit16eabd307c0dc34c31022d2a8872ec4be983999f (patch)
treef0a8daeca546366372d9c9339356ba670b603cd0 /graphics
parentaae09b9396005a6811f6f5f144c70525e631fb1d (diff)
downloadfreebsd-ports-gnome-16eabd307c0dc34c31022d2a8872ec4be983999f.tar.gz
freebsd-ports-gnome-16eabd307c0dc34c31022d2a8872ec4be983999f.tar.zst
freebsd-ports-gnome-16eabd307c0dc34c31022d2a8872ec4be983999f.zip
- Update to 0.1.4
- Convert to new options framework - Update maintainer's e-mail address - Cleanup COMMENT and pkg-descr PR: ports/172360 Submitted by: Maxim Samsonov <xors@imap.cc> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/apvlv/Makefile28
-rw-r--r--graphics/apvlv/distinfo4
-rw-r--r--graphics/apvlv/files/patch-poppler-0.18151
-rw-r--r--graphics/apvlv/files/patch-src_ApvlvDir.cpp11
-rw-r--r--graphics/apvlv/files/patch-src_ApvlvFile.cpp14
-rw-r--r--graphics/apvlv/files/patch-src_CMakeLists.txt43
-rw-r--r--graphics/apvlv/pkg-descr2
7 files changed, 65 insertions, 188 deletions
diff --git a/graphics/apvlv/Makefile b/graphics/apvlv/Makefile
index 4b6326e4aa3f..3d56a1a26d8f 100644
--- a/graphics/apvlv/Makefile
+++ b/graphics/apvlv/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= apvlv
-PORTVERSION= 0.1.2
-PORTREVISION= 2
+PORTVERSION= 0.1.4
CATEGORIES= graphics
MASTER_SITES= http://cloud.github.com/downloads/naihe2010/apvlv/
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
-MAINTAINER= xors@imap.cc
-COMMENT= Apvlv is a PDF/DJVU Viewer and its behaviour like Vim
+MAINTAINER= xors@mailup.net
+COMMENT= PDF/DJVU Viewer that behaves like Vim
LICENSE= GPLv2
@@ -25,19 +24,30 @@ MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DSYSCONFDIR=${PREFIX}/etc \
-DMANDIR=${MANPREFIX}/man \
-DDOCDIR=${DOCSDIR} \
- -DAPVLV_WITH_UMD=OFF
+ -DAPVLV_WITH_UMD=OFF \
+ -DAPVLV_WITH_TXT=ON
MAN1= apvlv.1
-OPTIONS= DJVU "Enable DJVU support" off
+OPTIONS_DEFINE= DJVU WEBKIT
+
+DJVU_DESC= Build with DjVu support
+WEBKIT_DESC= Build with WebKit support
.include <bsd.port.options.mk>
-.if defined(WITHOUT_DJVU)
-CMAKE_ARGS+= -DAPVLV_WITH_DJVU=OFF
-.else
+.if ${PORT_OPTIONS:MDJVU}
CMAKE_ARGS+= -DAPVLV_WITH_DJVU=ON
LIB_DEPENDS+= djvulibre:${PORTSDIR}/graphics/djvulibre
+.else
+CMAKE_ARGS+= -DAPVLV_WITH_DJVU=OFF
+.endif
+
+.if ${PORT_OPTIONS:MWEBKIT}
+CMAKE_ARGS+= -DAPVLV_WITH_HTML=ON
+LIB_DEPENDS+= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
+.else
+CMAKE_ARGS+= -DAPVLV_WITH_HTML=OFF
.endif
.include <bsd.port.mk>
diff --git a/graphics/apvlv/distinfo b/graphics/apvlv/distinfo
index e426fa6f7e8b..98cba6ee1c6f 100644
--- a/graphics/apvlv/distinfo
+++ b/graphics/apvlv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apvlv-0.1.2-Source.tar.gz) = 65f010287dd98644d25997f95054bc95abc22fd8d5e2d7bc3b3b59978fbb470a
-SIZE (apvlv-0.1.2-Source.tar.gz) = 331595
+SHA256 (apvlv-0.1.4-Source.tar.gz) = f803de89aed82fea08f9386a6d6ddec999d0c96bb68c85e4cd527803838d17cd
+SIZE (apvlv-0.1.4-Source.tar.gz) = 337182
diff --git a/graphics/apvlv/files/patch-poppler-0.18 b/graphics/apvlv/files/patch-poppler-0.18
deleted file mode 100644
index 44331aec7bb2..000000000000
--- a/graphics/apvlv/files/patch-poppler-0.18
+++ /dev/null
@@ -1,151 +0,0 @@
-http://bugs.gentoo.org/385057
-http://projects.archlinux.org/svntogit/community.git/tree/trunk/poppler-gdk.patch?h=packages/apvlv
-
---- src/ApvlvFile.cpp
-+++ src/ApvlvFile.cpp
-@@ -29,6 +29,10 @@
- #include "ApvlvUtil.hpp"
- #include "ApvlvView.hpp"
-
-+#ifndef POPPLER_WITH_GDK
-+#include "poppler-gdk.h"
-+#endif
-+
- #ifdef HAVE_LIBUMD
- #define LIBUMD_ENABLE_GTK
- #include <umd.h>
---- src/poppler-gdk.h
-+++ src/poppler-gdk.h
-@@ -0,0 +1,132 @@
-+#include <goo/gtypes.h>
-+
-+static void
-+copy_cairo_surface_to_pixbuf (cairo_surface_t *surface,
-+ GdkPixbuf *pixbuf)
-+{
-+ int cairo_width, cairo_height, cairo_rowstride;
-+ unsigned char *pixbuf_data, *dst, *cairo_data;
-+ int pixbuf_rowstride, pixbuf_n_channels;
-+ unsigned int *src;
-+ int x, y;
-+
-+ cairo_width = cairo_image_surface_get_width (surface);
-+ cairo_height = cairo_image_surface_get_height (surface);
-+ cairo_rowstride = cairo_image_surface_get_stride (surface);
-+ cairo_data = cairo_image_surface_get_data (surface);
-+
-+ pixbuf_data = gdk_pixbuf_get_pixels (pixbuf);
-+ pixbuf_rowstride = gdk_pixbuf_get_rowstride (pixbuf);
-+ pixbuf_n_channels = gdk_pixbuf_get_n_channels (pixbuf);
-+
-+ if (cairo_width > gdk_pixbuf_get_width (pixbuf))
-+ cairo_width = gdk_pixbuf_get_width (pixbuf);
-+ if (cairo_height > gdk_pixbuf_get_height (pixbuf))
-+ cairo_height = gdk_pixbuf_get_height (pixbuf);
-+ for (y = 0; y < cairo_height; y++)
-+ {
-+ src = (unsigned int *) (cairo_data + y * cairo_rowstride);
-+ dst = pixbuf_data + y * pixbuf_rowstride;
-+ for (x = 0; x < cairo_width; x++)
-+ {
-+ dst[0] = (*src >> 16) & 0xff;
-+ dst[1] = (*src >> 8) & 0xff;
-+ dst[2] = (*src >> 0) & 0xff;
-+ if (pixbuf_n_channels == 4)
-+ dst[3] = (*src >> 24) & 0xff;
-+ dst += pixbuf_n_channels;
-+ src++;
-+ }
-+ }
-+}
-+
-+static void
-+_poppler_page_render_to_pixbuf (PopplerPage *page,
-+ int src_x, int src_y,
-+ int src_width, int src_height,
-+ double scale,
-+ int rotation,
-+ GBool printing,
-+ GdkPixbuf *pixbuf)
-+{
-+ cairo_t *cr;
-+ cairo_surface_t *surface;
-+
-+ surface = cairo_image_surface_create (CAIRO_FORMAT_ARGB32,
-+ src_width, src_height);
-+ cr = cairo_create (surface);
-+ cairo_save (cr);
-+ switch (rotation) {
-+ case 90:
-+ cairo_translate (cr, src_x + src_width, -src_y);
-+ break;
-+ case 180:
-+ cairo_translate (cr, src_x + src_width, src_y + src_height);
-+ break;
-+ case 270:
-+ cairo_translate (cr, -src_x, src_y + src_height);
-+ break;
-+ default:
-+ cairo_translate (cr, -src_x, -src_y);
-+ }
-+
-+ if (scale != 1.0)
-+ cairo_scale (cr, scale, scale);
-+
-+ if (rotation != 0)
-+ cairo_rotate (cr, rotation * G_PI / 180.0);
-+
-+ if (printing)
-+ poppler_page_render_for_printing (page, cr);
-+ else
-+ poppler_page_render (page, cr);
-+ cairo_restore (cr);
-+
-+ cairo_set_operator (cr, CAIRO_OPERATOR_DEST_OVER);
-+ cairo_set_source_rgb (cr, 1., 1., 1.);
-+ cairo_paint (cr);
-+
-+ cairo_destroy (cr);
-+
-+ copy_cairo_surface_to_pixbuf (surface, pixbuf);
-+ cairo_surface_destroy (surface);
-+}
-+
-+/**
-+ * poppler_page_render_to_pixbuf:
-+ * @page: the page to render from
-+ * @src_x: x coordinate of upper left corner
-+ * @src_y: y coordinate of upper left corner
-+ * @src_width: width of rectangle to render
-+ * @src_height: height of rectangle to render
-+ * @scale: scale specified as pixels per point
-+ * @rotation: rotate the document by the specified degree
-+ * @pixbuf: pixbuf to render into
-+ *
-+ * First scale the document to match the specified pixels per point,
-+ * then render the rectangle given by the upper left corner at
-+ * (src_x, src_y) and src_width and src_height.
-+ * This function is for rendering a page that will be displayed.
-+ * If you want to render a page that will be printed use
-+ * poppler_page_render_to_pixbuf_for_printing() instead
-+ *
-+ * Deprecated: 0.16
-+ **/
-+void
-+poppler_page_render_to_pixbuf (PopplerPage *page,
-+ int src_x, int src_y,
-+ int src_width, int src_height,
-+ double scale,
-+ int rotation,
-+ GdkPixbuf *pixbuf)
-+{
-+ g_return_if_fail (POPPLER_IS_PAGE (page));
-+ g_return_if_fail (scale > 0.0);
-+ g_return_if_fail (pixbuf != NULL);
-+
-+ _poppler_page_render_to_pixbuf (page, src_x, src_y,
-+ src_width, src_height,
-+ scale, rotation,
-+ gFalse,
-+ pixbuf);
-+}
diff --git a/graphics/apvlv/files/patch-src_ApvlvDir.cpp b/graphics/apvlv/files/patch-src_ApvlvDir.cpp
deleted file mode 100644
index d3e787d87e8d..000000000000
--- a/graphics/apvlv/files/patch-src_ApvlvDir.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ApvlvDir.cpp.orig 2011-06-24 11:30:12.000000000 +0400
-+++ src/ApvlvDir.cpp 2011-10-11 22:07:59.000000000 +0400
-@@ -49,7 +49,7 @@
- realname = NULL;
-
- GtkTreeIter nitr[1];
-- gtk_tree_store_append (dir->mStore, itr, ir);
-+ gtk_tree_store_append (dir->mStore, nitr, ir);
- *itr = *nitr;
-
- GdkPixbuf *pix = gdk_pixbuf_new_from_file_at_size (iconreg.c_str (), 40,
diff --git a/graphics/apvlv/files/patch-src_ApvlvFile.cpp b/graphics/apvlv/files/patch-src_ApvlvFile.cpp
deleted file mode 100644
index 1c4609d6e4e6..000000000000
--- a/graphics/apvlv/files/patch-src_ApvlvFile.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/ApvlvFile.cpp.orig 2011-06-24 11:30:12.000000000 +0400
-+++ src/ApvlvFile.cpp 2011-10-10 01:01:26.000000000 +0400
-@@ -302,9 +302,9 @@
-
- bool ApvlvPDF::pagetext (int pn, int x1, int y1, int x2, int y2, char **out)
- {
-- PopplerRectangle rect = { x1, y1, x2, y2 };
- PopplerPage *page = poppler_document_get_page (mDoc, pn);
-- *out = poppler_page_get_text (page, POPPLER_SELECTION_WORD, &rect);
-+ PopplerRectangle rect = { x1, y2, x2, y1 };
-+ *out = poppler_page_get_selected_text (page, POPPLER_SELECTION_WORD, &rect);
- if (*out != NULL)
- {
- return true;
diff --git a/graphics/apvlv/files/patch-src_CMakeLists.txt b/graphics/apvlv/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..2366d8a63222
--- /dev/null
+++ b/graphics/apvlv/files/patch-src_CMakeLists.txt
@@ -0,0 +1,43 @@
+--- src/CMakeLists.txt.orig 2012-06-13 07:44:28.000000000 +0400
++++ src/CMakeLists.txt 2012-10-05 01:07:49.000000000 +0400
+@@ -17,17 +17,14 @@
+ PKG_CHECK_MODULES (GTK2 gtk+-2.0 REQUIRED)
+ PKG_CHECK_MODULES (GLIB2 glib-2.0 REQUIRED)
+ PKG_CHECK_MODULES (GTHREAD2 gthread-2.0 REQUIRED)
+-PKG_CHECK_MODULES (WEBKIT1 webkit-1.0 QUIET)
+ INCLUDE_DIRECTORIES (${FREETYPE2_INCLUDE_DIRS}
+ ${GTK2_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+- ${GTHREAD2_INCLUDE_DIRS}
+- ${WEBKIT1_INCLUDE_DIRS})
++ ${GTHREAD2_INCLUDE_DIRS})
+ LINK_DIRECTORIES (${FREETYPE2_LIBRARY_DIRS}
+ ${GTK2_LIBRARY_DIRS}
+ ${GLIB2_LIBRARY_DIRS}
+- ${GTHREAD2_LIBRARY_DIRS}
+- ${WEBKIT1_LIBRARY_DIRS})
++ ${GTHREAD2_LIBRARY_DIRS})
+
+ IF (WIN32)
+ SET (POPPLER_DIR ${CMAKE_HOME_DIRECTORY}/win32/poppler-src)
+@@ -128,6 +125,12 @@
+ IF (APVLV_WITH_HTML)
+ ADD_DEFINITIONS (-DAPVLV_WITH_HTML)
+
++ PKG_CHECK_MODULES (WEBKIT1 webkit-1.0 REQUIRED)
++ INCLUDE_DIRECTORIES (${WEBKIT1_INCLUDE_DIRS})
++ LINK_DIRECTORIES (${WEBKIT1_LIBRARY_DIRS})
++ SET (APVLV_REQ_LIBRARIES ${WEBKIT1_LIBRARIES}
++ ${APVLV_REQ_LIBRARIES})
++
+ SET (HEADERS ${HEADERS} ApvlvHtm.h)
+ SET (SOURCES ${SOURCES} ApvlvHtm.cc)
+ ENDIF (APVLV_WITH_HTML)
+@@ -138,7 +141,6 @@
+ ${GTK2_LIBRARIES}
+ ${GLIB2_LIBRARIES}
+ ${GTHREAD2_LIBRARIES}
+- ${WEBKIT1_LIBRARIES}
+ ${APVLV_REQ_LIBRARIES})
+
+ IF (WIN32) \ No newline at end of file
diff --git a/graphics/apvlv/pkg-descr b/graphics/apvlv/pkg-descr
index 37f717befccc..46c147b12482 100644
--- a/graphics/apvlv/pkg-descr
+++ b/graphics/apvlv/pkg-descr
@@ -1,3 +1,3 @@
-Apvlv is a PDF/DJVU Viewer and its behaviour like Vim.
+Apvlv is a PDF/DJVU Viewer and its behaviour is like Vim's.
WWW: http://naihe2010.github.com/apvlv/