aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-05-29 01:08:29 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-05-29 01:08:29 +0800
commit1b2c413cbb41b7faa652770e17f9a484b10e2b97 (patch)
tree8e9aba62b0ddeb483dcc5b8961651e196ea257d2 /graphics
parentb9400b8410193db2538d2c7d5f9431b940fc0838 (diff)
downloadfreebsd-ports-gnome-1b2c413cbb41b7faa652770e17f9a484b10e2b97.tar.gz
freebsd-ports-gnome-1b2c413cbb41b7faa652770e17f9a484b10e2b97.tar.zst
freebsd-ports-gnome-1b2c413cbb41b7faa652770e17f9a484b10e2b97.zip
- Update to 1.1.0
- Change MASTER_SITES back to CHEESESHOP - Remove post-patch: Changes: https://github.com/erocarrera/pydot/blob/master/ChangeLog
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-pydot/Makefile16
-rw-r--r--graphics/py-pydot/distinfo6
-rw-r--r--graphics/py-pydot/files/patch-dot_parser.py45
-rw-r--r--graphics/py-pydot/files/patch-pydot.py112
-rw-r--r--graphics/py-pydot/files/patch-setup.py15
5 files changed, 91 insertions, 103 deletions
diff --git a/graphics/py-pydot/Makefile b/graphics/py-pydot/Makefile
index c651c1a46644..f2e44799884a 100644
--- a/graphics/py-pydot/Makefile
+++ b/graphics/py-pydot/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= pydot
-PORTVERSION= 1.0.29
+PORTVERSION= 1.1.0
CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,19 +13,12 @@ COMMENT= Python interface to the Graphviz Dot language
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing \
- dot:graphics/graphviz
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=1.5.7:devel/py-pyparsing
+RUN_DEPENDS= dot:graphics/graphviz \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=1.5.7:devel/py-pyparsing
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
USES= python
-GH_ACCOUNT= erocarrera
-GH_TAGNAME= ec21a11
-USE_GITHUB= yes
-
-post-patch:
- @${REINPLACE_CMD} -e "s|__version__ = .*|__version__ = '${PORTVERSION}'|" ${WRKSRC}/pydot.py
-
.include <bsd.port.mk>
diff --git a/graphics/py-pydot/distinfo b/graphics/py-pydot/distinfo
index ca3efb0a9249..278ee0d93b3e 100644
--- a/graphics/py-pydot/distinfo
+++ b/graphics/py-pydot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463505798
-SHA256 (erocarrera-pydot-1.0.29-ec21a11_GH0.tar.gz) = 2a9910a5799cb32598e2135dfd5ab4ace8ad645b6e94ecc2e5e85a2a282eb7b6
-SIZE (erocarrera-pydot-1.0.29-ec21a11_GH0.tar.gz) = 262626
+TIMESTAMP = 1464369127
+SHA256 (pydot-1.1.0.tar.gz) = 469d2cf565994064236be24e87ab3571c1c1243fbc8d2ad836d16637d1a5049b
+SIZE (pydot-1.1.0.tar.gz) = 20451
diff --git a/graphics/py-pydot/files/patch-dot_parser.py b/graphics/py-pydot/files/patch-dot_parser.py
index c56d7a875200..f4cd10e70a02 100644
--- a/graphics/py-pydot/files/patch-dot_parser.py
+++ b/graphics/py-pydot/files/patch-dot_parser.py
@@ -1,32 +1,23 @@
---- dot_parser.py.orig 2012-01-03 00:15:07 UTC
-+++ dot_parser.py
-@@ -25,7 +25,7 @@ from pyparsing import __version__ as pyp
- from pyparsing import ( nestedExpr, Literal, CaselessLiteral, Word, Upcase, OneOrMore, ZeroOrMore,
- Forward, NotAny, delimitedList, oneOf, Group, Optional, Combine, alphas, nums,
- restOfLine, cStyleComment, nums, alphanums, printables, empty, quotedString,
-- ParseException, ParseResults, CharsNotIn, _noncomma, dblQuotedString, QuotedString, ParserElement )
-+ ParseException, ParseResults, CharsNotIn, dblQuotedString, QuotedString, ParserElement )
-
-
- class P_AttrList:
-@@ -111,7 +111,7 @@ def push_top_graph_stmt(str, loc, toks):
+--- dot_parser.py.orig 2016-05-24 09:57:52.000000000 +0800
++++ dot_parser.py 2016-05-28 01:23:50.843873969 +0800
+@@ -111,7 +111,7 @@
add_elements(g, element)
-
+
else:
- raise ValueError, "Unknown element statement: %r " % element
+ raise ValueError("Unknown element statement: %r " % element)
-
-
+
+
for g in top_graphs:
-@@ -218,14 +218,14 @@ def add_elements(g, toks, defaults_graph
+@@ -218,14 +218,14 @@
defaults_edge.update(element.attrs)
else:
- raise ValueError, "Unknown DefaultStatement: %s " % element.default_type
+ raise ValueError("Unknown DefaultStatement: %s " % element.default_type)
-
+
elif isinstance(element, P_AttrList):
-
+
g.obj_dict['attributes'].update(element.attrs)
else:
@@ -34,8 +25,8 @@
+ raise ValueError("Unknown element statement: %r" % element)
- def push_graph_stmt(str, loc, toks):
-@@ -267,7 +267,7 @@ def push_default_stmt(str, loc, toks):
+ def push_graph_stmt(str, loc, toks):
+@@ -267,7 +267,7 @@
if default_type in ['graph', 'node', 'edge']:
return DefaultStatement(default_type, attrs)
else:
@@ -44,21 +35,13 @@
def push_attr_list(str, loc, toks):
-@@ -414,6 +414,7 @@ def graph_definition():
-
- double_quoted_string = QuotedString('"', multiline=True, unquoteResults=False) # dblQuotedString
-
-+ _noncomma = "".join( [ c for c in printables if c != "," ] )
- alphastring_ = OneOrMore(CharsNotIn(_noncomma + ' '))
-
- def parse_html(s, loc, toks):
-@@ -523,9 +524,9 @@ def parse_dot_data(data):
+@@ -524,9 +524,9 @@
else:
return [g for g in tokens]
-
+
- except ParseException, err:
+ except ParseException as err:
-
+
- print err.line
- print " "*(err.column-1) + "^"
- print err
diff --git a/graphics/py-pydot/files/patch-pydot.py b/graphics/py-pydot/files/patch-pydot.py
index 4d96d536af22..12731b9ef3db 100644
--- a/graphics/py-pydot/files/patch-pydot.py
+++ b/graphics/py-pydot/files/patch-pydot.py
@@ -1,26 +1,15 @@
---- pydot.py.orig 2012-01-03 00:15:07 UTC
-+++ pydot.py
-@@ -19,7 +19,7 @@ Distributed under MIT license [http://op
-
- __revision__ = "$LastChangedRevision$"
- __author__ = 'Ero Carrera'
--__version__ = '1.0.%d' % int( __revision__[21:-2] )
-+__version__ = '1.0.28'
- __license__ = 'MIT'
-
- import os
-@@ -29,8 +29,8 @@ import tempfile
- import copy
+--- pydot.py.orig 2016-05-24 09:57:52.000000000 +0800
++++ pydot.py 2016-05-28 01:22:15.617300969 +0800
+@@ -29,7 +29,7 @@
+ import warnings
try:
import dot_parser
-except Exception, e:
-- print "Couldn't import dot_parser, loading of dot files will not be possible."
+except Exception as e:
-+ print("Couldn't import dot_parser, loading of dot files will not be possible.")
-
-
-
-@@ -92,7 +92,7 @@ CLUSTER_ATTRIBUTES = set( ['K', 'URL', '
+ warnings.warn(
+ "Couldn't import dot_parser, "
+ "loading of dot files will not be possible.")
+@@ -94,7 +94,7 @@
#
class frozendict(dict):
def _blocked_attribute(obj):
@@ -29,7 +18,7 @@
_blocked_attribute = property(_blocked_attribute)
__delitem__ = __setitem__ = clear = _blocked_attribute
-@@ -190,7 +190,7 @@ def quote_if_necessary(s):
+@@ -192,7 +192,7 @@
return 'True'
return 'False'
@@ -38,25 +27,56 @@
return s
if not s:
-@@ -506,7 +506,7 @@ def find_graphviz():
- #print "Used Windows registry"
+@@ -505,10 +505,10 @@
+ path = os.path.join(path, "bin")
+ progs = __find_executables(path)
+ if progs is not None :
+- #print "Used Windows registry"
++ #print("Used Windows registry")
return progs
-
+
- except Exception, excp:
+ except Exception as excp:
#raise excp
pass
else:
-@@ -717,7 +717,7 @@ class InvocationException(Exception):
+@@ -523,7 +523,7 @@
+ for path in os.environ['PATH'].split(os.pathsep):
+ progs = __find_executables(path)
+ if progs is not None :
+- #print "Used path"
++ #print("Used path")
+ return progs
+
+ # Method 3 (Windows only)
+@@ -550,7 +550,7 @@
+
+ if progs is not None :
+
+- #print "Used default install location"
++ #print("Used default install location")
+ return progs
+
+
+@@ -562,7 +562,7 @@
+
+ progs = __find_executables(path)
+ if progs is not None :
+- #print "Used path"
++ #print("Used path")
+ return progs
+
+ # Failed to find GraphViz
+@@ -719,7 +719,7 @@
-class Node(object, Common):
+class Node(Common):
"""A graph node.
-
+
This class represents a graph's node with all its attributes.
-@@ -756,12 +756,12 @@ class Node(object, Common):
+@@ -758,12 +758,12 @@
# Remove the compass point
#
port = None
@@ -69,50 +89,50 @@
- if isinstance(name, (long, int)):
+ if isinstance(name, int):
name = str(name)
-
- self.obj_dict['name'] = quote_if_necessary( name )
-@@ -834,7 +834,7 @@ class Node(object, Common):
+
+ self.obj_dict['name'] = quote_if_necessary(name)
+@@ -836,7 +836,7 @@
-class Edge(object, Common ):
+class Edge(Common):
"""A graph edge.
-
+
This class represents a graph's edge with all its attributes.
-@@ -925,7 +925,7 @@ class Edge(object, Common ):
+@@ -927,7 +927,7 @@
"""
-
+
if not isinstance(edge, Edge):
- raise Error, "Can't compare and edge to a non-edge object."
+ raise Error("Can't compare and edge to a non-edge object.")
-
+
if self.get_parent_graph().get_top_graph_type() == 'graph':
-
-@@ -1025,7 +1025,7 @@ class Edge(object, Common ):
-
-
-
+
+@@ -1027,7 +1027,7 @@
+
+
+
-class Graph(object, Common):
+class Graph(Common):
"""Class representing a graph in Graphviz's dot language.
This class implements the methods to work on a representation
-@@ -1075,7 +1075,7 @@ class Graph(object, Common):
+@@ -1077,7 +1077,7 @@
self.obj_dict['attributes'] = dict(attrs)
-
+
if graph_type not in ['graph', 'digraph']:
-- raise Error, 'Invalid type "%s". Accepted graph types are: graph, digraph, subgraph' % graph_type
-+ raise Error('Invalid type "%s". Accepted graph types are: graph, digraph, subgraph' % graph_type)
-
-
+- raise Error, 'Invalid type "%s". Accepted graph types are: graph, digraph' % graph_type
++ raise Error('Invalid type "%s". Accepted graph types are: graph, digraph' % graph_type)
+
+
self.obj_dict['name'] = quote_if_necessary(graph_name)
-@@ -2022,7 +2022,7 @@ class Dot(Graph):
+@@ -2024,7 +2024,7 @@
'Program terminated with status: %d. stderr follows: %s' % (
status, stderr_output) )
elif stderr_output:
- print stderr_output
+ print(stderr_output)
-
+
# For each of the image files...
#
diff --git a/graphics/py-pydot/files/patch-setup.py b/graphics/py-pydot/files/patch-setup.py
index e4c9a8b15d76..71544cf3c6f3 100644
--- a/graphics/py-pydot/files/patch-setup.py
+++ b/graphics/py-pydot/files/patch-setup.py
@@ -1,19 +1,10 @@
---- setup.py.orig 2012-01-03 00:15:07 UTC
+--- setup.py.orig 2016-05-24 01:57:52 UTC
+++ setup.py
-@@ -2,7 +2,7 @@
-
- try:
- from distutils.core import setup
--except ImportError, excp:
-+except ImportError as excp:
- from setuptools import setup
-
- import pydot
-@@ -31,5 +31,5 @@ setup( name = 'pydot',
+@@ -27,5 +27,5 @@ setup( name = 'pydot',
'Topic :: Software Development :: Libraries :: Python Modules'],
long_description = "\n".join(pydot.__doc__.split('\n')),
py_modules = ['pydot', 'dot_parser'],
-- install_requires = ['pyparsing', 'setuptools'],
+- install_requires = ['pyparsing>=1.5.7'],
- data_files = [('.', ['LICENSE', 'README'])] )
+ install_requires = ['pyparsing', 'setuptools'] )
+ #data_files = [('.', ['LICENSE', 'README'])] )