aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordan <dan@FreeBSD.org>1999-10-04 05:31:07 +0800
committerdan <dan@FreeBSD.org>1999-10-04 05:31:07 +0800
commit1bdf3041d9c17fe01dbda4a17b60f86611df2a89 (patch)
treecfbe6b68e75e61a2c67d509b524c8092b8de38c0 /graphics
parentd449b38ed0a311b227aaa4a5b668905ac1d97bbb (diff)
downloadfreebsd-ports-gnome-1bdf3041d9c17fe01dbda4a17b60f86611df2a89.tar.gz
freebsd-ports-gnome-1bdf3041d9c17fe01dbda4a17b60f86611df2a89.tar.zst
freebsd-ports-gnome-1bdf3041d9c17fe01dbda4a17b60f86611df2a89.zip
icod is a utility to convert Windows-format icon files
(.ico) to X-format pixmaps (.xpm). It will extract all icon images from each specified .ico file and write out each image to a filename consisting of the basename of the image, the size, and the bit depth. PR: ports/14089 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/icod/Makefile22
-rw-r--r--graphics/icod/distinfo1
-rw-r--r--graphics/icod/pkg-comment1
-rw-r--r--graphics/icod/pkg-descr10
-rw-r--r--graphics/icod/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/graphics/icod/Makefile b/graphics/icod/Makefile
new file mode 100644
index 000000000000..1384a418218f
--- /dev/null
+++ b/graphics/icod/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: icod
+# Version required: 1.0
+# Date created: 02 October 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= icod.1.0
+PKGNAME= icod-1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.linuxberg.com/files/x11/graphics/
+
+MAINTAINER= jedgar@fxp.org
+
+WRKSRC= ${WRKDIR}/icod
+ALL_TARGET= icod
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/icod ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/icod/distinfo b/graphics/icod/distinfo
new file mode 100644
index 000000000000..ff94b00300dd
--- /dev/null
+++ b/graphics/icod/distinfo
@@ -0,0 +1 @@
+MD5 (icod.1.0.tar.gz) = cb94cf6e8c06111190439f33a16d91ec
diff --git a/graphics/icod/pkg-comment b/graphics/icod/pkg-comment
new file mode 100644
index 000000000000..1ae280181ea1
--- /dev/null
+++ b/graphics/icod/pkg-comment
@@ -0,0 +1 @@
+Utility to convert Windows icon files to xpm format
diff --git a/graphics/icod/pkg-descr b/graphics/icod/pkg-descr
new file mode 100644
index 000000000000..74cb42e11679
--- /dev/null
+++ b/graphics/icod/pkg-descr
@@ -0,0 +1,10 @@
+icod is a utility to convert Windows-format icon files
+(.ico) to X-format pixmaps (.xpm).
+
+It will extract all icon images from each specified
+.ico file and write out each image to a filename
+consisting of the basename of the image, the size, and
+the bit depth.
+
+- Chris D. Faulhaber
+jedgar@fxp.org
diff --git a/graphics/icod/pkg-plist b/graphics/icod/pkg-plist
new file mode 100644
index 000000000000..f6bff6f1a1de
--- /dev/null
+++ b/graphics/icod/pkg-plist
@@ -0,0 +1 @@
+bin/icod