aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-07-12 04:18:29 +0800
committerpawel <pawel@FreeBSD.org>2016-07-12 04:18:29 +0800
commit2cc638fb9ad35e1e6d94934ccb5ffb0140308777 (patch)
tree2ea7f876fa31e435f68f99f1dceb1f0853e4d928 /graphics
parent6e348710b5066afce67ea245ec8bb3f6ff4b76bc (diff)
downloadfreebsd-ports-gnome-2cc638fb9ad35e1e6d94934ccb5ffb0140308777.tar.gz
freebsd-ports-gnome-2cc638fb9ad35e1e6d94934ccb5ffb0140308777.tar.zst
freebsd-ports-gnome-2cc638fb9ad35e1e6d94934ccb5ffb0140308777.zip
imv is a command line image viewer intended for use with tiling window
managers. It supports over 30 different image file formats including: Photoshop PSD files, animated GIFS, and various RAW formats. WWW: https://github.com/eXeC64/imv/ PR: 210951 Submitted by: Tobias Kortkamp <t@tobik.me>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/imv/Makefile39
-rw-r--r--graphics/imv/distinfo3
-rw-r--r--graphics/imv/pkg-descr5
4 files changed, 48 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 0583a6be11e9..c3ccd9845fcc 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -365,6 +365,7 @@
SUBDIR += imlib2
SUBDIR += imlib2_loaders
SUBDIR += impressive
+ SUBDIR += imv
SUBDIR += inkscape
SUBDIR += intel-backlight
SUBDIR += intergif
diff --git a/graphics/imv/Makefile b/graphics/imv/Makefile
new file mode 100644
index 000000000000..b716e6dedeaa
--- /dev/null
+++ b/graphics/imv/Makefile
@@ -0,0 +1,39 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= imv
+PORTVERSION= 2.1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= t@tobik.me
+COMMENT= Simple image viewer
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreeimage.so:graphics/freeimage
+
+USES= desktop-file-utils gmake
+USE_SDL= sdl2 ttf2
+
+USE_GITHUB= yes
+GH_ACCOUNT= eXeC64
+
+ALL_TARGET= imv
+
+MAKE_ARGS= V=1
+
+PLIST_FILES= bin/imv \
+ man/man1/imv.1.gz \
+ share/applications/imv.desktop
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/imv \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/files/imv.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_MAN} ${WRKSRC}/doc/imv.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/graphics/imv/distinfo b/graphics/imv/distinfo
new file mode 100644
index 000000000000..3a587ec0c3e4
--- /dev/null
+++ b/graphics/imv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468102451
+SHA256 (eXeC64-imv-v2.1.2_GH0.tar.gz) = 7bb264c23d55795234556b98d63aa17afadbda87cc5a38d684e3a735cb12c135
+SIZE (eXeC64-imv-v2.1.2_GH0.tar.gz) = 27137
diff --git a/graphics/imv/pkg-descr b/graphics/imv/pkg-descr
new file mode 100644
index 000000000000..8cf5f7534a1f
--- /dev/null
+++ b/graphics/imv/pkg-descr
@@ -0,0 +1,5 @@
+imv is a command line image viewer intended for use with tiling window
+managers. It supports over 30 different image file formats including:
+Photoshop PSD files, animated GIFS, and various RAW formats.
+
+WWW: https://github.com/eXeC64/imv/